Jetpack Subscriptions sending in Spanish suddenly

  • Author
  • #969415


    I’m posting this again since it seems the last one was automatically closed for some reason.

    Suddenly Jetpack Subscriptions is sending email in Spanish instead of English. I subscribe to my own blog via Jetpack Subscriptions for reasons such as this, and suddenly, it started sending all posts in Spanish instead of English. I didn’t change anything. When I click on “Unsubscribe or change your email settings at Manage Subscriptions” at the bottom, it opens a new page but doesn’t go anywhere – just a blank page. I can’t find anything is WP or Jetpack settings to correct this, and I don’t know if it’s limited to me or all my subscribers – none of my other subscriptions through WP are doing this. It’s a self-hosted WP blog. Thank you for any help.

    The blog I need help with is



    The blog you specified at does not appear to be hosted at

    This support forum is for blogs hosted at If your question is about a self-hosted WordPress blog then you’ll find help at the forums.

    If you don’t understand the difference between and, you may find this information helpful.

    If you forgot to include a link to your blog, you can reply and include it below. It’ll help people to answer your question.

    This is an automated message.



    Volunteers here at answering support forum questions on this peer support forum cannot help with JetPack issues. Have you filed a JetPack support ticket ?

The topic ‘Jetpack Subscriptions sending in Spanish suddenly’ is closed to new replies.