Need help? Check out our Support site, then

Jetpack translation not applied on self-hosted WordPress

  1. I want to use Jetpack Comments on my self-hosted WordPress site but the af (Afrikaans) translation is not applied to the comment form. I understand that Jetpack Comments is loaded on my site with an iframe.

    This is a WordPress multisite with subdomains. Here is my check-list for configuring my site to use af_ZA (Afrikaans):

    • I configured my wp-config.php to use the language af_ZA.
    • Translation works for the Dashboard and other plugins.
    • af-Afrikaans is chosen on my profile.

    The translation at contains the translated strings that must be applied.

    Does it matter that my wp-config.php specifies 'af_ZA' but specifies 'af'?

    What am I missing? Any help would be much appreciated.

    Kobus (snapalot)

    The blog I need help with is

  2. Hi there,

    Can you let me know exactly what strings are not being translated on your site?

    You can find the Afrikaans Jetpack translation project here:

    It looks like some of the strings related to comments aren't translated yet, in which case they will still show as English strings on your site. If you'd like, you can contribute to the Jetpack translation at that link by adding your own translations for those strings.

    Please let me know if you have any questions about that. :)

  3. Hi Rachel,

    I am the validator for Afrikaans on the, and Jetpack projects and already translated the following strings:

    • "Enter your comment here..." translated with "Tik jou kommentaar hier...";
    • "Fill in your details below or click an icon to log in:" translated with "Verskaf jou besonderhede hieronder of klik op 'n logo om in te teken:"
    • "Email (required)" translated with "E-pos (verplig)";
    • "Name (required)" translated with "Naam (verplig)".
    • "Website" translated with "Webwerf"

    Thanks for the help :)
    Kobus (snapalot)

  4. Hi Kobus,

    Sorry for missing the fact that you're the validator for Afrikaans! :)

    It looks like those strings are actually missing from the Jetpack project (although they are in the project and are translated there). I'm checking with our team about getting them added to Jetpack. Please stay tuned!

  5. Sorry, I just found I was mistaken — those strings should be pulled directly from the translated strings. I'm checking now to find out why they aren't appearing on your site. :)

  6. Hi Kobus, just to confirm, is this for your site at ?

    Can you try disconnecting Jetpack from in your dashboard and then reconnecting it? It may be that your language settings just need to be refreshed in your system, to make sure you get the right strings there.

    Please let me know if that doesn't fix it for you and I can keep looking into this. :)

  7. Hi Rachel, yes this is for I'll follow your advice when I'm back at the office early next year. Thank you and don't work too hard over the festive season.
    Merry Christmas :)

  8. Sounds great — just let me know if I can keep helping with this once you're back at the office. :) Merry Christmas!

  9. Hi Rachel, all the best for the new year!

    I followed these steps to reconnect Jetpack to

    1. go to Jetpack on the menu on the left
    2. activate Jetpack comments
    3. click on Disconnect from
    4. click on Connect to
    5. click on Allow Access (I was already logged in)
    6. a new page loads with a 502 server error with the following URL:
    7. then I refresh the page with F5 and the WP Dashboard loads stating was successfully connected

    Afterwards the Afrikaans translation is still not used on the comment form.

    Sorry about the confusion: my personal account (snapalot) is validator for Afrikaans but I'm posting as maroelamedia because the site is connected with this account.

  10. Hi Kobus, sorry for the delay getting back to you! Thanks for letting me know about reconnecting to Jetpack. I'm having our team look into this further for you, and I'll let you know what we find out. Please let me know if you have any other questions in the meantime. :)

  11. Thank you Rachel!

  12. Hi Kobus,

    After checking with our developers, they confirmed that af (not af_ZA) is the accepted language code for both WordPress core and You can take a look at the locale information for WordPress core here:

    If you switch the locale setup on your blog to af, instead of af_ZA, that should fix it for you.

    If you think the accepted language code for WordPress should be switched to af_ZA, you're welcome to bring that up for discussion here:

    Thanks for your patience while we looked into this, and please let me know if I can provide further help. :)

  13. Hi Rachel, I'll change the locale to af in wp-config.php, test again and let you know if it worked.

    Thanks for the the time you and the team spent on this!

  14. Hi Kobus, that sounds great. Do let me know how it goes. :) Cheers!

  15. Hi Rachel, our implimentation of Jetpack comments has been put on hold because of a change in specification: we want users to have the option to not just log in with Facebook, Twitter or, but also their local account on the self-hosted WordPress.

    Thank you for all the time you guys spent on this. Hopefully it can help someone else.

Topic Closed

This topic has been closed to new replies.

About this Topic