jumps to the top of the page after inserting a link.

  • Author
    Posts
  • #659607

    grandpadavid
    Member

    When you enter a link and click on add link the edit area jumps to the top of the page. The cursor is still in the right place and I have discovered that if you down or up arrow you get back to the right are but it is really disconcerting.

    By the way, on another on my blogs – just started – I do NOT appreciate being called a Dope! You should remove that from your selection of silly comments on completing a post. I don’t know if it means something different in the States but it is not very complimentary in England/Ireland. It could be misconstrued by 2L speakers.
    Blog url: http://quakewatch.wordpress.com/

    #659756

    kardotim
    Member

    Could you please send me a full-screen screenshot where this issue is visible. Also try clearing your browser’s cache. Click here for instructions and for more information about browser troubleshooting.

    #659765

    grandpadavid
    Member

    The only way you can see that is to try it really but I have made a video of it happening as you would really see nothing in a screenshot.

    http://dl.dropbox.com/u/17582872/Video_2011-07-22_121800.wmv

    Also how do I post a screenshot here anyway?

    You need to try it on a page yourself.

    Try editing this page yourself – it won’t show anywhere.

    http://quakewatch.wordpress.com/lorem-ipsum/

    As to clearing the browser cache I would point out that this issue appeared after some changes on WordPress. I really don’t see why I should clear out useful things like lists for drop down boxes when this has been going on for weeks now so the cache will have been refreshed on these pages many times. Is there some way I can preserve the entries for drop down boxes etc? I don’t want to loose them as I use them many times a day. I would clear the cache if there was.

    #659768

    Unfortunately, this looks like a cache or cookie issue with the editor. The only way to make sure is to indeed clear them. Maybe you can try the same operation on another computer, to see is the behaviour is the same?

    #659913

    grandpadavid
    Member

    Not an issue with cookies I am afraid. I have logged in on another computer and done exactly the same editing on that Lorem Ipsum page using Internet Explorer (I use Firefox on my computer) and it behave in exactly the same way when adding a link.

    Rather than making suggestions as to what it might be, try it yourself? Then you can see what is happening.

    #659914

    grandpadavid
    Member

    My partner has just tried this on her computer, in Internet Explorer on her own blog and this behaves exactly the same so the problem is with WordPress and nothing to do with browsers or cookies or cache.

    #659958

    macmanx
    Staff

    Can you tell us which version of Internet Explorer you’re using?

    #659963

    grandpadavid
    Member

    I believe her Internet Explorer is 7. I just tried it in IE 8 and the page does not jump up but the cursor goes to the wrong place. Instead of being between the chevron it is after the closing /a chevron.

    Opera 11.11 sort of gets it right but highlights the whole of the /a block

    I seem to be having a problem with Chrome so I will forget that one.

    So basically what we have is that the problem happens in IE 7 and Firefox 3.6

    Keep this open. I may try upgrading Firefox which mean i lose some widgets but it may be worth a try.

    #659964

    grandpadavid
    Member

    OK. I have upgraded FireFox to 3.6.18 AND cleared the cache. Exited FF abd rebooted.

    Back into WordPress and……..

    …..the problem is still there.

    What is annoying is that I have now lost my eQuake add on for no good reason.

    #659965

    macmanx
    Staff

    Firefox 3.6.18 is the final release of the 3.x branch, but still a bit outdated.

    Is there any chance that you could update to 5.0.1?

    #659978

    grandpadavid
    Member

    Good grief there is a 5? I clicked the update button in Firefox and that was what it downloaded.

    I will have a look and get back to you.

    #659979

    grandpadavid
    Member

    OK, I installed Firefox 5.0.1 (Yuk)

    I have lost nearly all of my add-ons – including Roboform for which I am going to have to shell out nearly $30 to get a later version – and several others, basically because of a problem that WordPress should have fixed.

    It now works. It still sends that scrollbar back to the top, but then it jumps back down again to the right place. This is basically bad programming. Since you have probably many users running on 3.6.x of Firefox who like me don’t want to lose add-ons and can’t afford to shell out for upgrades to other programs, your programmers should ensure backward compatibility at least to 3.6

    You may be Happiness Engineers but I am not happy! With no job $30 is an expense I can do without. Thanks WordPress, and thanks to your lazy programmers.

    I have been a programmer for over 30 years (not web) and if I permitted this in a program I would be ashamed of myself, depending on someone else’s updates to sort my problems.

    I am going to have to consider reverting and living with it – if I can!

    You can close this thread now.

The topic ‘jumps to the top of the page after inserting a link.’ is closed to new replies.