junping images?

  • Author
  • #517552


    It seems that the images on the posts are sometimes slightly misaligned in their borders and “jump” back into the correct position when the cursor approaches the image.

    At other times when the cursor approaches the image the whole image and border jump left slightly.

    Does anyone else have this problem or know why this might be happening?

    Many thanks

    The blog I need help with is beaufortjazz.wordpress.com.



    I’m not seeing this on your blog. What browser and version are you using?



    Thanks for the response raincoaster.

    I am using Internet explorer version 8. I have been using it on the blog for a while without this problem and then it suddenly started occurring after one post I put up.

    It must be a problem at my end I guess. Its not a show stopper – but it is a bit irritating.

    I just realise that I have made a mess of the topic title. Apologies. It obviously should have read “jumping” rather than “junping”



    No worries; it’s easy enough to figure out.

    Can you set that latest post as Draft and see if that fixes things? It’s possible there’s some bad code in it, particularly if you wrote it in Word or something and pasted it in.



    Hi Raincoaster

    Thanks for the suggestion. Changing the post to draft didn’t do the trick – but if you see the blog OK it must mean that its something to do with IE on my computer?

    I hope it isn’t bad code – thanks to the kind advice on this forum, I have avoided writing posts in word and have written them directly in WordPress.



    On your settings->General page, do you have “WordPress should correct invalidly nested XHTML” selected?



    Hi Raincoaster

    Yes – I have recently done this as a “belt and braces” approach even though I was fairly sure that I hadnt corrupted the code in some way.

    If I understand correctly, all posts prior to switching this feature on have to be set as draft and then re-published?

    Thanks and Regards


    Yes, that’s a good way to correct them all at once.



    You don’t have to set them as draft, but it’s a good idea to check if this was causing problems before. To do that, set your blog to display one post per page and click backwards to find if there’s any change: a post after which it doesn’t occur, or before which it doesn’t. If you can find that one post where the change is, edit it. Just click Edit and change something, anything; a period to a comma, italicize something, whatever. Then Update. See if that fixes it.

    If the problem still occurs on all your posts, even ones made after the “invalidly nested” change, then it’s not that which is causing it.



    Many thanks for the responses.

    Ive re-posted all the posts and unfortunately it hasnt done the job.

    Can other people see this problem still when looking at my blog? If it is just me – Ill learn to live with it and assume its a browser issue.

    One last thought, I have attached the same image to two recent posts. is this likely to cause problems?

    Thanks and Regards


    I’ve looked at your blog in both Safari and Firefox and do not see any jumping images. What browser are you experiencing this in, and what version of that browser?



    Hello TSP – many thanks for checking this and responding.

    I am using IE8. When my cursor approaches the image, it jumps slightly to the left and the post text seems to briefly and almost imperceptibly reformat slighty.

    I am relieved that it doesnt appear to be a blog code problem. I’ts a strange one though.

    Thanks again


    IE can be a bit of a challenge due to the way it interprets CSS and displays web pages, and in this case, I think it is because IE insists on putting a border around any linked image, and when you hover your mouse over the image, the border will actually change slightly (typically thicker) which can make images jumpy.

    It would be so nice if IE would simply accept the web standards and make their browsers compliant. As a web designer, I can quickly design a site that works flawlessly in all browsers (excluding IE), but then before I can take it live, I have to go back and tweak the CSS and such so that it will also work with IE. IE8 is better than 7 or 6, but it still is far from what it should be. Still, with the way IE is dropping market share, it might be only a couple years before it is completely irrelevant.

    Try this: Temporarily edit one of your posts that has a jumpy image and delete the caption, save the changes to the image, and then update the post. View the post and see what happens. If it cures the issue, then staff needs to tweak the CSS for captions for IE. If that doesn’t work, go one step further and change the image so that it doesn’t link to the larger image and then check again. If that takes care of the issue, then it is a problem with img a:link in the CSS.

    After staff gets back, contact them and tell them what is happening and that it is happening in IE8 and see if they will fix it.



    Hello TSP – many thanks for the very detailed response.

    I think you have got to the root of the problem! When the cursor actually hovers over the image, the border at the bottom of the thumbnail changes to a thick dotted line. This seems to confirm your thoughts,

    I have removed the caption from the picture in the first visible post and re-published the post. The thumbnail still jumps in that post.

    I have tried to alter the path – but am not sure how to do this. I will have a another go at this later and report back.

    Thanks again for the valuable help – Its comforting to know that this an IE8 problem and not a blog code problem.


    OK, I think we can get rid of this issue for you.

    Open one of the posts. Click on the image to highlight it and then click on the image edit button at top left of the image (mountain looking icon). At the top of the page that opens, click the “advanced settings” tab. In the “styles” field, put the following.


    Click “update” in that window and then click “update” in the post editor and see what happens.

    Since I don’t have IE, I can’t test this, but it should fix the issue.



    Thanks again TSP.

    I entered the code above and updated as you suggested. For some reason, when I check back, the code isnt showing in the style box and the image problem still exists.

    Just as weird, is when I delete the caption as you suggested in an earlier post, the caption still shows underneath the thumbnail.

    It’s quite bizarre. Its as if there are loads of little and annoying glitches in what was once a straight forward system.

    Thanks again for the assistance


    There are a bunch of gremlins running around in wordpress right now, so what you are seeing is quite possibly related to that. I’m not sure why the above inline CSS did not stick in the “style” field. I’ve used it quite a bit before without any problems (one of those gremlins?).

    When staff gets back on the 19th, contact them about it. They need to make an adjustment to the CSS so this does not happen.



    Hello TSP

    Yes – will do,

    Thanks and Regards



    A quick follow-up here which might help others.

    I have managed to solve the problem of the jumping images by turning off the IE8 compatibility view feature. For some reason it had been turned on to view WordPress, though I cannot recall doing this!

    Hopefully this will help others who have similar problems. There are still some other minor glitches (borders) which I will look at again.

    Thanks again for all the help.


    Compatibility view is semi-automatic (supposedly). You will have to watch things for a while, as there have been areas of the dashboard and such that did not work well unless compatibility view was active.

    If you have any issues in the dashboard, you might have to turn it back on.

The topic ‘junping images?’ is closed to new replies.