Just spent an hour on a post, and when I published it it was completely empty

  • Author
  • #1084120


    I used the new interface from the wordpress.org home (what do you want to post? text, image, etc).

    From there, I composed a long, thoughtful post. When I finally hit publish, it was totally empty. I can see a revision history, but those are all empty too. I tried to start writing again but it’s a lot of work. Does anyone know if i can restore it?

    The blog I need help with is sensical.wordpress.com.



    You may be able to recover an earlier post revision. Go to Posts > All Posts, hover over the title of the post, click Edit and check the Post Revisions module for previous saved versions of the post. http://en.support.wordpress.com/posts/post-revisions/

    If you’re not seeing the Revisions module while on the editor screen, click Screen Options (top right corner of your Admin page) http://en.support.wordpress.com/screen-options/ to activate it. Then select the post and page modules to include them. http://en.support.wordpress.com/modules/#list-of-modules Then you ought to be able to go here > Dashboard > All Posts > Posts and locate the post and recover it from post revisions.

    If you cannot locate the post for locating and restoring a post revision, and it’s not in your Trash folder http://en.support.wordpress.com/trash/ then you will not be able to recover it. http://en.support.wordpress.com/trash/#restoring-from-trash

    Did you create your post on the dashboard of your own blog?
    Dashboard > Posts > All Posts > Add New

    Or did you create your post on the front page of WordPress.com?



    Thanks timetheif, I created the post on the front page of wordpress.com, with my blog selected (sensical.wordpress.com). When I published the post, the title of the post was published, but everything else was missing.

    I can see a list of past revisions, but when I open them up they are all empty. I am thinking there’s no way to recover this, but let me know if you have any other thoughts. This is the last time I post on the front page of wordpress.



    I’m so sorry but as the post revisions are empty you have reached the bitter end.



    Were you using http://wordpress.com/#!/post/ ?

    If so, did you see “Post Published” after pressing the Publish button, or did you navigate away from the page before that appeared?


    Hint. Compose all your writing efforts in a word processor (Word?), always save regularly, then copy and paste to WordPress. That way you always have the latest creation/revision. How did I learn this “Best Practices Hint?” You got it–many lost creations on all kinds of programs, not just WordPress.


    Moderator Emeritus

    No, copy-paste from Word is not a great idea.

    Microsoft Word is a fine word processor for producing documents to be shared or printed, with a wealth of print-based options for indexing, and producing table of contents. As a web publishing tool it is a little less than ideal and produces very messy HTML. The same applies when using OpenOffice, or other word processors.

    Read this article about the problems it can cause:

    What to do?
    Use a plain text editor.

    There are several desktop applications which you can use to write and publish content for your WordPress.com blog, even without being connected to the internet. You may often hear this referred to as “offline editing.”




    Thanks everyone, I ended up retyping it so it’s a moot point now I guess. Thanks for all the tips though, and I will use the plainest text editor you could imagine when composing future posts.



    If you don’t mind answering macmanx’s (Staff’s) question it would be helpful to have your answer.

    Were you using http://wordpress.com/#!/post/ ?

    If so, did you see “Post Published” after pressing the Publish button, or did you navigate away from the page before that appeared?



    Yes sorry, @macmanx I was using http://wordpress.com/#!/post/ , and when at one point I tried to preview, the preview was empty too. But I got sidetracked for a few minutes and went back to writing, and then published. I don’t remember seeing ‘post published.’ I went to the site and saw the empty post. Then I went back and clicked thru each of the revisions, but they were each empty.




    Ah, that would be the problem then.

    If publishing doesn’t complete and you navigate away, the text field is cleared just like any other text field.

    In the future, just make sure that you see a new screen which says “Post Published” or try the editor at Posts -> Add New in your blog’s Dashboard.


    @macmanx I saw ‘post published’ and my entry is still empty. This is the 3rd time this week. I use the site and the app and have never had this problem until now. Very un happy here.



    This was an issue with an upgrade to TinyMCE. The issue should be fixed now, please let us know if this continues to happen.

The topic ‘Just spent an hour on a post, and when I published it it was completely empty’ is closed to new replies.