K2-Lite…widget problem

  • Author
    Posts
  • #319373

    davyjones
    Member

    In the K2-Lite theme, the default display shows ‘latest posts’ in the right column. That’s good.

    When I go to the widgets and choose to add (note I say ‘add’) a ‘categories’ widget to the right column…it adds the ‘categories’ but removes the ‘latest posts’.

    ???

    Removing the ‘categories’ widget causes the ‘latest posts’ to reappear again.

    ‘Latest Posts’ is not a selectable widget addition – it appears to be being used by default.

    Not much cop if it gets chucked away as soon as you add another widget!!

    Is this a theme fault?

    H.

    #319629

    rosclarke
    Member

    What normally happens is that the themes have a default group of widgets added. As soon as you make ANY changes to your sidebar, these are removed. You should then be able to add whichever widgets you like. I think it’s Recent Posts, rather than Latest Posts, if that helps.

    #319637

    davyjones
    Member

    Hi Ros,

    Yes, you’re right, it is Recent Posts.

    However, it can’t be added – it’s listed in the widgets list but there’s no ‘add’ button.

    #319641

    vivianpaige
    Member

    Have you cleared your cache?

    Did you change themes? If so, go back to your old theme, remove all the widgets there, then change themes and add them back in.

    #319643

    davyjones
    Member

    Hi Viv,

    “..Did you change themes? If so, go back to your old theme, remove all the widgets there, then change themes and add them back in…”

    WHAT!!….you have got to be joking!!

    I remember all those sales pitch things, now……”change the look of your web site with just a click of the mouse!”

    ;)

    I can see this is going to be an all-nighter……

    #319644

    vivianpaige
    Member

    No, I’m not joking. There was a bug introduced with 2.7 that has created this situation and it has yet to be resolved. (You can check the forums on this.) That’s the only way to fix it at this time.

    #319647

    davyjones
    Member

    what a bummer!

    never mind, thanks for the explanation, Viv!

    #319651

    davyjones
    Member

    Yep, that worked ok, thanks for the workaround, Viv.

    I have to say that this should really feature as a very large HOT TIP somewhere!

    But then maybe everyone else already knows….

    #319736

    @davyjones: No they don’t – we keep giving this tip every few days or so…

The topic ‘K2-Lite…widget problem’ is closed to new replies.