"large" image size is not available

  • Author
    Posts
  • #991539

    ppanbura
    Member

    Hello. When I added an image to a post I do not see “large” bullet option is available. I would like to have the image shown as large or the original size i.e. not scaled or resized to one of the other options.

    I see the maximum image setting allows up to 1024 x 1024 size. My image is 1000 x 700. I would like to retain this size.

    Thanks.

    The blog I need help with is abitofwiggleroom.wordpress.com.

    #991661

    timethief
    Member

    Check out the maximum displayed image width for the theme you are using without and without the sidebar here > http://wpbtips.wordpress.com/2009/07/23/maximum-image-width/

    #991665

    ppanbura
    Member

    Thank you for the pointer to the table. That is very useful. Does it mean that for a given theme there is no other way to force “large” option?

    I also noticed that image quality is reduced by this as well. The link has that mentioned. It is also good to know.

    #991668

    timethief
    Member

    See what justpi says here > image sizes in my theme : Chateau
    https://en.forums.wordpress.com/topic/image-sizes-in-my-theme-chateau?replies=7

    #991686

    justpi
    Member

    The thread TT unearthed explains several things about the available size options, but let me clarify a couple of things:
    a) Thumbnail, Medium and Large are supposed to be three preset options for downsizing larger images, so the Large option isn’t available when you upload an image that’s smaller than the default for that option.
    b) The Full Size option means original size, if the width of the original is smaller or equal to the maximum the theme allows, or downsized to that maximum, if the original is larger.

    Now, re the 1024×1024 you mentioned: I suppose you saw that in Settings > Media. Well, it means nothing. As I explain in the thread TT linked to, the media settings are there for you to set in accordance with the theme you’re using. You’re using Chateau with no sidebar; maximum in this case is 791px wide, so you can’t “retain” the size of a 1000px wide image. If you upload a 1000px wide image, it will be downsized to 791px if you select the Full Size option: if you select one of the other options, it will be downsized to whatever (reasonable) width you’ve set in Settings > Media for that other option.

    #991717

    1tess
    Moderator Emeritus

    The other thing is, though, that if you upload an over-sized (for your theme) image and link to that file, then the picture will open with a little magnifying glass which allows visitors to click to see the super-big photo.

    The image in your post will be automatically downsized (with the not-too-terrific-wp.com-resizing-blur-color-etc.-loss-of-image-quality) but folks can click on the photo link to see it as large as you want.

    Or upload 2 versions, 1. the maximum size for your theme, but linked to 2. an image also uploaded to your library as big as you like.

    #991862

    ppanbura
    Member

    Thank you all for the information.

    #991865

    timethief
    Member

    @ppanbura
    You’re welcome nad best wishes with your blog. :)

The topic ‘"large" image size is not available’ is closed to new replies.