latest_read_on ("Continue Reading") not there on featured post

  • Author
    Posts
  • #830630

    hughlilly
    Member

    Per the subject line, at http://cinefile.net.nz/, the “Continue Reading” link that’s usually under the latest post excerpt (along w/ the comment count and category) and is controlled in the CSS by “.latest_read_on” seems to have disappeared.

    Help?

    The blog I need help with is cinefile.net.nz.

    #830774

    raincoaster
    Member

    Do you have the Custom CSS upgrade?

    #830779

    hughlilly
    Member

    Yes… I haven’t adjusted anything under “.latest_read_on” though…

    #830780

    There is no “continue reading” link under the featured post. See the theme demo at http://themorningafterdemo.wordpress.com/ .

    One thing that will get you in trouble though is pasting the entire CSS stylesheet into the CSS edit window. You put ONLY the specific selectors, and ONLY the specific declarations you are adding or changing into the editor and then make sure that “add to existing…” is selected otherwise it breaks any relative links to any images used in the theme.

    #830782

    Sorry, that first sentence should have read, “There is no “continue reading” link under the latest post.”

    #830783

    hughlilly
    Member

    The “continue reading” link is in the demo of the theme at woothemes though; my question is why it’s been deactivated on WordPress.com…

    (I’m working on taking out the modified bits from my adapted CSS file and will paste them in with “add to existing” selected.)

    #830785

    WordPress.com themes are not like the self-hosted version and are modified to work here. Most likely the version used here is an earlier version of the theme. It is unlikely that it will be updated since in the past when staff have done that with other themes, there has been angry mobs show up in the forums with pitchforks and torches and staff have either had to roll them back, or offer two version of the theme.

    Never compare a self-hosted theme to what is available here.

    #830786

    hughlilly
    Member

    OK, thanks. I guess this topic can be closed now. The funny thing is, I’m absolutely certain that when I first applied the theme, the “Continue Reading” link was there. Oh well!

    #830787

    justpi
    Member

    The theme does display the Continue Reading link when the option “Show Full Content Home” in Theme Options is not checked. You have disabled it yourself, because you’ve added this:

    #latest_post p a {
        display: none;
    }

    #830788

    hughlilly
    Member

    Ah, yes, I’ve done that on purpose: I’m not trying to enable the “Continue reading »” text link that appears at the end of the extract; I’m trying to enable the “Continue Reading” link that appears next to the comments and category meta links underneath the extract.

    #830790

    justpi
    Member

    That doesn’t exist in the wordpress.com version of the theme.

    #830791

    justpi
    Member

    Or, more accurately, no longer exists. You’re right, it was there at first – see screenshot in my guide to the theme:
    http://wpbtips.wordpress.com/2011/06/02/the-morning-after/

    #830792

    hughlilly
    Member

    Hmm, thanks. I suppose it’s far too much to hope that the folks at WordPress.com might reinstate it, huh!

    #830795

    justpi
    Member

    You can never know: they change their mind all the time. You can post a request in the Themes forum.

    #830818

    I suppose it’s far too much to hope that the folks at WordPress.com might reinstate it, huh!

    I wouldn’t say that at all! It never hurts to ask, and then you can find out if the option was disabled to fix something or for some other reason.

    In this case, the fact that there were two “continue reading” links was reported as a bug and one was removed. Out of curiosity, what was different about the one that was removed that you wanted to keep? And why won’t the “feat_exc” one that you have hidden with CSS work in it’s place? Note: I’m maybe forgetting how it looked before, but I looked at juspi’s screenshot at http://wpbtips.wordpress.com/2011/06/02/the-morning-after/ and that’s the way the demo page looks to me now: http://themorningafterdemo.wordpress.com/ It’s possible it’s been changed around a little since you first wrote this thread too, so it might have been in flux *while* you were talking about it.

    #830840

    hughlilly
    Member

    The “feat_exc” class the link that displays after the excerpt for featured posts, not for the latest post.

    That demo contains neither the “Continue Reading” link (in black text below the latest-post excerpt) nor the “Continue reading »” link that appears (in blue text directly after the latest post excerpt, that is, within the same paragraph) which I’ve (also) hidden via CSS. This second link is disabled in the CSS by setting “latest_post p a” to “display:none;”.

    This demo at WooThemes shows the “Continue Reading” link, in black next to the category and comments-count links, that I wish to be reinstated.

    To test my theory, I reinstated it manually using Google Chrome’s and manually inserting a link between span class “latest_read_on” tags. It works.

    #830942

    Ah, I see now. Thanks for re-explaining it for me. I’ll see what else I can find out about why the “Continue reading” link below the latest post on The Morning After theme is no longer showing up even if the “Show Full Content Home” option is checked on the Appearance -> Theme Options page.

The topic ‘latest_read_on ("Continue Reading") not there on featured post’ is closed to new replies.