Layout in visual editor seems fine but doesn't hold when published.

  • Author
    Posts
  • #1084091

    brianat9
    Member

    I’m still having difficulties with one page ( birds, liminality, and Transformation ) where the layout looks fine in visual editor, but paragraphs breaks don’t show when published. I previously tried to make alterations in text editor ( I’m a raw beginner ). This seemed to work, but the correction hasn’t held.

    I was previously advised to set ‘format -paragraph’ ( click on paragraph, it shows in top row ) then go to text editor, then back to visual editor, and save changes. This doesn’t seem to have any effect.

    It looks as though I’ll have to type the whole ( long ) page out again? If so I’d appreciate clear instructions on how to avoid the formatting error that seems to be bugging it.

    I’ll look forward to any suggestions.

    The blog I need help with is animistjottings.wordpress.com.

    #1084401

    brianat9
    Member

    I’ve experimented in text editor again, with passable results – but am worried that the layout/formatting ( on this page only ) is unstable. Since the editor is set to ‘paragraph’ by default, I find it hard to see th logic of the move mentioned above.

    Any ideas for ensuring this doesn’t happen again??

    #1084402

    timethief
    Member

    Blog editors and word processors are not the same and do not work the same way. The web standard is one blank line only, so you cannot add more blank lines by pressing return repeatedly like you would do with a typewriter or in a word processing application. If you want to learn how to format and space your posts and pages see:
    http://en.support.wordpress.com/writing-and-formatting-poetry/

    If you are working in the Visual editor, to get single spacing between paragraphs hold the SHIFT key down and simultaneously click ENTER at the end of the paragraph.

    If you are working in the HTML (Text) editor, a single click of ENTER will give you a single-spaced line, and two clicks of ENTER will result in double spaced lines. http://onecoolsitebloggingtips.com/2011/09/13/wordpress-formatting-and-spacing/

    P.S. When you create a new post, always make sure the Format tool is set to Paragraph before you start typing. It’s in the Visual editor Row 2 first position “style”. See the illustration here http://en.support.wordpress.com/visual-editor/#row-2 If you forget to do that then edit the post, highlight all in the Visual editor, select Paragraph from the Format tool, switch editor to Text then switch back to Visual and click Update.

    #1084444

    justpi
    Member

    @TT:
    There’s no point copypasting the same stock reply you copypasted here:
    https://en.forums.wordpress.com/topic/space-not-appearing-above-and-below-one-paragraph-when-i-publish?replies=8

    @btaylor679:
    In the thread I linked to I made a general remark to clear things up; I didn’t check your page, since you said you had resolved the issue. Now that I checked the code of the page I can tell you more. There’s a strange mixture of paragraphs and divs (probably because of your attempts to change things) that can’t be completely corrected via the highlight etc trick. You need to switch the editor to Text and update the page after you delete all of these:
    <div>
    and all of these:
    </div>

    The most likely reason for the appearance of the original divs is that you copypasted the content from another source (such as Word). So: never copypaste from other sources into the Visual editor; if you copypaste, paste into the Text editor.

    #1084456

    brianat9
    Member

    Many thanks for this. I havn’t copy pasted anything at all yet, so am still not sure why the error occured in the first place. Since the editor is set to paragraph by default, and I hadn’t changed this, I don’t see how it could have been due to this setting? Anyway, I’ll try and remedy thing as you suggest. I may copy the page first, so I’ve got a spare, in case this doesn’t work out.

    Brian

    #1084482

    brianat9
    Member

    Clearing out the <div>’s seems to have worked. Thanks!

The topic ‘Layout in visual editor seems fine but doesn't hold when published.’ is closed to new replies.