Leave a Comment box

  • Author
    Posts
  • #1120078

    I disabled comments on all of my new posts but the “Leave a Comment” link is still showing up at the bottom of my posts. When it is clicked, either nothing happens or it sends you to the top of the post. Is there any way to delete this link altogether? I have found other people asking about this o the forum and the only solutions offered involve the Custom Design upgrade which I am not using.

    Thanks.

    The blog I need help with is answersfromthebook.org.

    #1120213

    timethief
    Member

    This does not require CSS editing.

    This page > Settings > Discussion
    Discussion settings is where you set up defaults for comments.
    http://en.support.wordpress.com/settings/discussion-settings/

    We can also override the default settings and enable or disable future comments on any individual post or page.
    http://en.support.wordpress.com/enable-disable-comments/

    Note 1: By default, new blogs on WordPress.com will have the Discussion hidden. You can reveal it by clicking on Screen Options http://en.support.wordpress.com/screen-options/ on the top right corner of your Admin page, and checking the box that says Discussion so the module is included. http://en.support.wordpress.com/modules/#list-of-modules

    Note 2: To disable comments on already-published posts or pages, you can edit each post and uncheck the “Allow comments” setting. See http://en.support.wordpress.com/enable-disable-comments/#enabledisable-comments

    To disable comments on already published pages (not posts), you go to Pages > All Pages, click the little square to select all the pages, select “Edit” from the Bulk Actions pulldown, click Apply, select “Do not allow” from the Comments pulldown, click Update. Same thing for already published posts, in Posts > All Posts.

    #1120309

    justpi
    Member

    I disabled comments on all of my new posts but the “Leave a Comment” link is still showing up at the bottom of my posts. When it is clicked, either nothing happens or it sends you to the top of the post.

    This means you disabled commenting successfully but you neglected to disable pingbacks as well.

    #1120310

    timethief
    Member

    @justpi
    Great catch!
    I have missed your brilliance.

    #1120329

    Yep, I sure did. Thanks for catching that :)

    I unchecked the box and am hoping everything goes smoothly for the next post. Thanks Justpi and Timethief!

    Loren

    #1120330

    timethief
    Member

    @loren
    Best wishes with your blog.

    #1120336

    justpi
    Member

    @loren: You’re welcome.
    “I unchecked the box”: Apparently you unchecked it in Settings > Discussion. This will apply to future posts but it doesn’t apply to already published posts. To correct the latter, you need to go to Posts > All Posts and quick edit them or bulk edit them to uncheck the option.

The topic ‘Leave a Comment box’ is closed to new replies.