Like button not working

  • Author
    Posts
  • #1125133

    wpvins
    Member

    No, it does NOT work. And it is NOT a browser problem on my computer as it happens with all three browsers I use and as it happens to quite a few other customers as well.
    As to your suggested solutions: you have offered them for other problems before, only to later find out that it was YOUR side that had the programming glitches and not the customers’ side.
    But tell you what, I’m simply going to forget it. I appreciate your trying to help, but I’m sorry to say that I’m fed up.

    #1125134

    macmanx
    Staff

    Ok, all I can say is that the Like button works for me, so I’m sure it works for others, and the issue must be something related to your setup, which you could perhaps find if you tried the troubleshooting steps.

    Ad blockers often interfere with account-activated bits like our Like buttons, also severely outdate browsers may not be able to use them.

    If you doubt me, please feel free to see my Like on http://pitsbilderbuch.wordpress.com/2013/02/09/england-reise-fruhjahr-2011-357/

    #1125135

    boles
    Member

    wpvins —

    I, too, just LIKED the article macmanx LIKED. No problems here on a Mac running Google Chrome 25.0.1364.99.

    #1125136

    wpvins
    Member

    @macmanx
    First of all: I do not doubt you and I appreciate you trying to solve the problem.
    Second: I’m sorry that I have not made myself clear enough and misinterpreted some of the complaints here. My problem is not that I can’t receive likes on my blogs, it is that I can’t leave likes on other WordPress blogs, regardless which browser I use. When I click on the “like” button, no matter if it’s the one on top of the page or under the post, nothing at all happens.
    What I can do, though, is leave a “like” via the reader.
    Btw, this problem only started after you had changed the design so that now only one row of gravatars from the people who liked a post shows up.
    But as I said, I’m simply giving up.

    #1125137

    macmanx
    Staff

    Ok, so it sounds like the problem is definitely something in your setup, since the rest of us aren’t having any issue. I’d love to help you track it down.

    Have you tried the other troubleshooting steps, specifically disabling all add-ons and extensions? Are you running any ad blockers?

    #1125140

    wpvins
    Member

    @macmanx
    I really appreciate your offer: thank you ever so much. But I have decided no to pursue the matter any further.

    #1125141

    wpvins
    Member

    @macmanx
    just one more thought:
    maybe you should check this thread https://en.forums.wordpress.com/topic/like-button-not-working-2/page/2?replies=45#post-1164740
    there are more people like me out there who have (the same) problem
    and again: thanks for your continuous offer to help

    #1125144

    I don’t see the Like button under my posts, although a few people have liked the post. Few other people also have complained that they cant view the like button. Find it a bit strange. Moreover I can see like button on various other blogs so the browser related issues are negated. Kindly look into it.. Blog in question is ( sidharthshukla.wordpress.com )

    #1125145

    timethief
    Member

    This is an active link that’s immediately usable > http://sidharthshukla.wordpress.com
    I’m not clear on what you are reporting. Did you follow this guide for enabling the like button or not? http://en.support.wordpress.com/likes/#likes-and-your-site

    #1125146

    yes, i have checked all option to enable the like button for the post as mentioned in the article, few people have liked the post as well but still i along with many are not able to see the like button below the post.

    #1125147

    wpvins
    Member

    @ sidharthshukla
    I’ve just checked out your blog.
    – in Firefox, there IS a “like” button under your post, but it doesn’t work for me. And there’s no bar at the top of the page with “Follow”, “Like” & “Reblog”. [Btw, for me, that happens with every single blog I visit.]
    – in Chrome, this bar as well as the “like” button under the post appear, and both buttons work
    – in MS IE, no bar at the top, but the “like” button under the post, and it works, PLUS, to my utter surprise, an imbedded video, which did not show up in any of the other browsers!!!
    I hope these obeservations will help you.
    Best regards from southern Texas,
    Pit
    P.S.: I like your photos. Great shots!

    #1125148

    macmanx
    Staff

    wpvins you’ll need to be logged in to WordPress.com to see the bar at the top and Like a post.

    Perhaps that has been the problem all along?

    Try visiting http://wordpress.com/ directly in Firefox and IE.

    #1125149

    wpvins
    Member

    Thanks for the suggestion. I knew that I have to be logged in to see the bar at the top. But that bar doesn’t work. I see the bar, as well as the like button under the post, but when I click on it, nothing happens: the buttons stay as they are, and my gravatar doesn’t appear.
    Well, something does happen: if I’m not logged in, a pop-up window opens where I am asked to log in. If I AM logged in, that same pop-up window opens, but without any fields to fill in, and the closes all by itself. That’s in Foirefox, btw.
    Btw, as I can “like” a post either directly from the e-mail notifications or the reader or in Chrome, I use those workarounds. But if I have used one of those, I don’t see the results in Firefox. It simply is strange.
    Thanks again for your continuing offer to help despite me being quite stubborn: it’s very much appreciated.
    Best regards,
    Pit

    #1125150

    macmanx
    Staff

    Hm, I definitely can’t reproduce the issue when logged in with Firefox.

    I can reproduce the issue when logged out, as Firefox is silently blocking the login pop-up. We are working on that now.

    #1125151

    like button not working. ive been having this problem since i joined…if i’m already logged in, go to someones blog and hit the wordpress like button, a window pops up but nothing happens. sometimes it works if i need to login on that page for some reason, otherwise, the like button has never worked for me…never.

    #1125152

    macmanx
    Staff

    First, please make sure that your browser is up to date by visiting http://whatbrowser.org/

    If it is not, please try updating your browser or switching to a different browser.

    If it is, please do these four things:

    1. Try clearing your browser’s cache and cookies: http://en.support.wordpress.com/browser-issues/

    2. Make sure that you have third-party cookies enabled: http://en.support.wordpress.com/third-party-cookies/

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS: http://en.support.wordpress.com/https/

    Please let us know how each step goes for you, and which browser (and version of) you’re using if you’re still having trouble.

    #1125153

    thetarotnook
    Member

    Hi, I’ve recently had complaints from visitors that they can’t like my posts. It is a wordpress.com blog at http://thetarotnook.com. Any help would be much appreciated. Thanks.

    #1125154

    macmanx
    Staff

    Would you please open your own support thread about that?

    https://en.forums.wordpress.com/?new=1

    #1125155

    emtiu
    Member

    wpvins:

    It might have to do with the setting in Firefox that disables “Accepting third-party cookies”.

    I enabled that (and told Firefox to forget those cookies on exiting), and it appears to work now.

    And BTW, I also find those “Have you tried turning it off and on again” kind of “support” messages very annoying and unhelpful.

    #1125156

    macmanx
    Staff

    But it did work, right? Since #2 above addresses enabling third-party cookies? ;)

    Such troubleshooting steps are often necessary as they rule-out a variety of popular problems so we can identify the issue. Otherwise, we’re just shooting in the dark.

The topic ‘Like button not working’ is closed to new replies.