"Like" button requiring readers to have password

  • Author
    Posts
  • #891797

    bookoftips
    Member

    Hi,

    I’ve had a few people tell me they’ve gone to “like” posts of mine, but a message pops up requiring them to input a username and password. One user (does not have a WordPress blog – or any blog) thought okay, so created a username/password – but site wouldn’t accept it. Could you please help me out?

    Thank You!! :)

    The blog I need help with is cancerwhattodoorsay.wordpress.com.

    #891890

    timethief
    Member

    Only WordPress.com members who are logged into WordPress.com can use the WordPress.com “like” button.

    Regarding the user with the new username account log-in issue that person must post a thread here and Staff will help them sort their issue.

    #892067

    leeinblack
    Member

    Hi,

    Sorry to butt in on this thread but I started a similar one last week with zero response:

    https://en.forums.wordpress.com/topic/liking-other-blogs-posts-problem?replies=3

    As it says, even though I am logged in I’m asked to log in again before I can “like” something. The workaround I discovered was to post a comment which again asked me to log in (I do this via the WordPress button at the top of the box) then I can “like” something.

    Surely it should already recognise that I am logged in and not make me go through this entire rigmarole every time I want to “like” a post?

    #892068

    timethief
    Member

    The WordPress.com “like” button can only be used by WordPress.com bloggers who are logged into WordPress.com.

    #892069

    leeinblack
    Member

    And as I said I am a WordPress blogger logged into WordPress.com yet I am still asked to login again so for some reason it doesn’t recognise that I – and now it transpires other bloggers – are logged in to WordPress.com.

    And since the “Like” login option doesn’t work, only the comment login, that suggests there is a flaw within the system surely?

    #892070

    timethief
    Member

    I’ve flagged this thread for Staff attention. Please be patient while waiting for a response.

    #892071

    leeinblack
    Member

    No problem. Thanks for the reply! :)

    #892074

    macmanx
    Staff

    Do you have any luck if you clear your cache and WordPress.com-related cookies?

    http://en.support.wordpress.com/browser-issues/#clear-your-cache-and-cookies

    #892077

    leeinblack
    Member

    Nope. Doesn’t make a lick of difference.

    Just to clarify something, if we are logged into our own sites and the fact we can access our own WordPress account main page, support forums etc. does that qualify as being “logged in” to WordPress.com?

    #892078

    macmanx
    Staff

    Yes, it does.

    Is this only affecting your blog? Are you able to Like posts elsewhere without issue?

    #892079

    leeinblack
    Member

    Also it varies from blog to blog. I just managed to like a post on one blog but not another. Is it perhaps a bug in the themes?

    The successful “Like” was using “Twenty Eleven” – This one worked!

    The two unsuccessful ones were using Customised Twenty Ten – Fail No 1

    and Imbalance 2 – Fail No 2

    #892080

    macmanx
    Staff

    Ah, this might be a third-party cookies issue since the unsuccessful ones were on mapped domains.

    Do you have third-party cookies enabled?

    http://en.support.wordpress.com/third-party-cookies/

    #892083

    timethief
    Member

    @macmanx
    Sheesh! Both of my blogs are on mapped domains so I hope my readers aren’t experiencing this and I don’t have to publish a post on this subject for them. :(

    #892085

    macmanx
    Staff

    timethief, mine is too. I’m not seeing it on other mapped domains with third-party cookies disabled though.

    If this fixes it for leeinblack, at least we have a few more things to go on.

    #892087

    I experience this, too. Some blogs I subscribe to allow me to like without 3rd party cookies, and some I subscribe to will not allow me to like without going into my tools-options-enabling 3rd party cookies, refreshing and then liking. Then disabling cookies. All while logged in to my dashboard. I recently unsubscribed to several culprit blogs because of this – got tired of the above process.

    I don’t know what a mapped domain is, but I wish I could ‘like’ and comment while logged in, across the board without this cumbersome process. Example: never have to have 3rd party cookies with “The Waiting;” always have to enable 3rd party cookies with “Shoes on the Wrong Feet.” Not sure what the dif is. Thanks for this thread!

    #892089

    leeinblack
    Member

    Morning everyone! (well it is here in the UK ! :P)

    Okay, I saw macmanx’s post about third party cookies and found they were disabled on my browser so I enabled them and BINGO – I can “like” posts without climbing over mountains now! Yay! :D

    Huge thanks for the solution macmanx!! :)

    But I have to ask, is this going to cause problems in the future since the “disabled” setting was the default setting?

    #892101

    macmanx
    Staff

    If you can’t Like a blog without third-party cookies enabled, would you please tell us which browser (and version of) you’re using?

    #892102

    leeinblack
    Member

    Firefox v. 12.0

    #892103

    macmanx
    Staff

    Thanks for confirming!

    1southernseamuse1, how about you?

    timethief, are you experiencing the same problem, or do you have third-party cookies enabled?

    #892107

    leeinblack
    Member

    Just noticed something weird since enabling third party cookies – the little icons in my Facebook “like” box have doubled up so there are now two of every icon!?!

The topic ‘"Like" button requiring readers to have password’ is closed to new replies.