Line returns being removed?

  • Author
    Posts
  • #86515

    blaggeruk
    Member

    Does anyone know why my line/paragraph returns are removed once the blog is saved or published?

    Doesn’t happen to all of the returns but noticably the first one at the end of the first paragraph.. it does this every time and is maddening, I have spent an hour before trying to “untweak” the mess everytime line returns are removed by Wp..

    Any advice anyone?

    #86683

    drmike
    Member

    Been discussed before many times. Try using the standard editor, not the rich text editor. Dashboard -> Users -> Your profile -> Uncheck the box for the rich text editor. TinyMCE does like doing things like that.

    #86685

    blaggeruk
    Member

    Thanks for the advice and so promptly! ;)

    I’ll try what you suggest..

    #87443

    doggerelist
    Member

    I’m having the same problem with line/paragraph returns being ignored. I tried unchecking the RTE box, which has allowed me to put in up to 2 returns; but no more!

    I don’t have this problem when cut’n’pasting stuff (written by me) from other blogs and forums, only with stuff written anew on the wordpress blog. I can’t believe it’s fundamentally impossible to put in more than 2 returns, and this newby would welcome any help….thanks….

    #87444

    Are you using Safari? The TinyMCE editor that wordpress uses for writing pages and posts is not fully compatible with Safari and you will find problems in other areas as well.

    I would suggest downloading the Firefox or Camino browsers to use with wordpress as they are the most compatible with wordpress.

    Firefox: http://en.www.mozilla.com/en/
    Camino: http://caminobrowser.org/

    Alternately, you can go to “my profile” in the upper right of your dashboard and uncheck “use visual rich text editor,” click “update profile and then you will be doing all your writing in code view. Some, including myself, find this a little confusing since in addition to the text of your post, you will see all the html code for your formatting.

    Another alternative is to use an offline blog editor. Timethief has rounded up all the most popular and listed them on her wordpress resources blog at: http://wpbloggingtips.wordpress.com/2007/10/26/offline-blog-editors-reviews/

    #87445

    doggerelist
    Member

    Thanks for the reply, thesacredpath.

    No, I’m not using safari, just bog-standard IE. (We’ve tried firefox previously, but had to dump it as it had some problems with my wife’s commercial website.)

    I did previously try unchecking the RTE box, which as I said improved matters slightly in that I can now put in 2 returns, but no more (using RTE only one line return was acknowledged). Puzzlingly, having unchecked RTE, I don’t get the visual html as you suggested would happen. I’ll check out the timethief tips and see if inspiration dawns….

    #87446

    timethief
    Member

    I can switch to the standard editor using either Firefox 2.0.0.11 or IE7 and I have no problem at all inserting the line breaks I want. Are you using outdated versions of these browsers? I’m asking because I know that IE6 does not play well with wordpress.

    #87447

    doggerelist
    Member

    timethief – that might be an issue. We are still using IE6 (when we upgraded to IE7 a while ago, that caused us some problems, hence the return to the antediluvian IE6….) I guess we’ll just have to bite the bullet, upgrade, and try to deal with the other problems….or else I’ll have to live with the limited line breaks, if my wife demurs ;-)

    thanks….

    #87448

    timethief
    Member

    Best wishes for a happy outcome. :)

    #87453

    options
    Member

    > I can’t believe it’s fundamentally impossible to put in more than 2 returns.

    yes, it is. indeed. every other extra whitespace newlines are getting stripped off.

    the same goes for this very forum reply boxes.

    .
    when I’m lazy, I usually just put a ‘dot’ char. (full stop) to emulate extra empty newline before a para. like I just did.

    sometimes (when I have to) I use:
    <p>&nbsp;</p>
    code for that. both ways produce ugly markup. perhaps, it should be dealt with the CSS instead.

The topic ‘Line returns being removed?’ is closed to new replies.