line spacing/ paragraph how-to

  • Author
  • #161673


    I can’t seem to find this in the FAQ’s.
    I tried to write a new post tonight, but it won’t keep the lines I put between the different paragraphs (meaning, a blank line to separate them). And in previous posts, I couldn’t get more than one space. How can I fix this?
    Thanks much!


    It sounds like you are using Safari on a Mac. Safari – sadly – is not supported by the TinyMCE visual rich text editor used by wordpress. Your best solution is to download the Firefox or Camino web browsers and use one of them. Alternately you can go into your profile and turn off the visual rich text editor.


    Turning off the rich text editor puts you in “code” mode, which is a little more confusing since you will see all the html code.

    Another alternative is to use an offline editor. Timethief has a good round up of both Mac and Windows editors here:



    I’ve been having the problem on Safari and Foxfire. I’ll try turning off the rich text editor. Thanks for your help!


    Your are welcome.

    Make sure you are using the latest version of FF ( I think). You might want to have a look at the offline editors. I use Ecto and I am quite pleased with it.



    I’m using FireFox and it doesn’t handle paragraphs properly either. Neither is Safari 3.0, which came with OS 10.4.11.

    The most bizarre thing is, when I was last here in July, Safari 2.x was working fine!


    I’m using with 10.4.11 (Macbook Pro Intel core 2 duo) and Firefox works fine for me and handles extra lines between paragraphs just fine, so I’m not sure what to suggest. Safari support in TinyMCE is listed as “experimental or partial” and I have had problems with both Safari 2.x and 3.x although 3.x is better, it’s still not really useable.

    That said, I’ve been using the Ecto offline blog editor for quite some time because I always have a copy of my posts on my hard drive which is handy when there is an issue with wordpress. I never loose any work. Ecto is not perfect, and sometimes the code will get messed up (probably my fault) and I have to go into code view and do some cleanup, but for the most part it’s solid and works well. It’s not free, but then again, at around $20 US it won’t break the bank either. And once you’ve paid for it, all updated from that point on are free, major and minor alike.



    Sorry for the multiple posts, but I can’t edit my last one.

    I forgot to mention how I finally worked around the issue: I turned on the Advanced Toolbar in the Visual Editor, selected each paragraph in turn, and clicked on the “Paragraph” tag in the toolbar. I was editing a Published entry at the time. Hopefully the same technique works with the normal New Entry workflow.


    Ahh, yes, that works and I’ve had to do that on some previous stuff I later edited as well. Glad you found a work around for the problem, and for posting it here.

    And yes, the ability to edit posts here in the forums was taken away a little while ago.

The topic ‘line spacing/ paragraph how-to’ is closed to new replies.