Link a question to an answer

  • Author
    Posts
  • #330807

    vincentssm
    Member

    I’m new to coding, have read other info but still not clear as to how to code.
    I am trying to create a page of F.A.Q.s where the questions are in one area and the answer below. I want to be able to link the question to the answer. How do I code this?

    Question 1:
    Question 2:

    Answer 1:
    Answer 2:

    The blog I need help with is vincentplacessm.ca.

    #331073

    rosclarke
    Member

    Please give us a link to your blog so we can see how to help you.

    #331185

    vincentssm
    Member

    Sorry it took so long. My blog is http://www.vincentplacessm.ca. My F.A.Q.’s are in a draft mode.

    #331186

    ellaella
    Member

    When you get a moment, could you link your blog to your user name? If you don’t know how, it’s in the “8 things to know before posting” sticky at the top of the forum.

    A page jump should handle what you want to do:

    http://support.wordpress.com/splitting-content/page-jumps/

    #331191

    vincentssm
    Member

    I believe that I’ve done this. I still don’t get how to use the achor link? I have a series of Questions and below that I have the answers. I want to link the question to the answer.
    i.e. Q1: What do you grow in your garden?

    A1: I grow tomatoes, potatoes and lettuce.

    So by clicking on the question it will bring me to the answer then a link to return me to the top of the page.

    Thanks to all who help me in getting this done.

    #331192

    Your blog isn’t hosted here, but the html code is the same no matter where you are, and some of our local bloggers (on WordPress.COM) may want the information.

    This is the code for your list of questions. Each question (wording optional) is an internal link that points to a “target” shown below:

    <a href="#question1">This is question one</a><br />
    <a href="#question2">This is question two</a><br />

    The answers should each begin like this:

    <a name="question1">Answer to question one:
    
    <a name="question2">Answer to question two:
    #331193

    That got somewhat messed up. The “question links” should end after

    #331194

    Aaarrrhhhh! The “question links” should end after </a>

    #331195

    justjennifer
    Moderator

    @sensuouscurmudgeon, the blog is a COM blog, if I can judge by the Admin bar at the top of the page. :)

    Answer’s still the same though.

    #331196

    The code for the answers also needs the closing “a” tag afterwards.

    #331197

    (Afterwards? I mean at the end…)

The topic ‘Link a question to an answer’ is closed to new replies.