Link button not working in pages

  • Author
    Posts
  • #2444847

    whatmeread
    Member

    All of a sudden today, the link button doesn’t work on my page editor. My topic editor is fine, but when I try to add a link to a topic in one of my pages, clicking the button does nothing. On the html view, the row of buttons that is usually there is completely gone. I was able to add my links by coding them in html by hand, but would like to know if there is anything I can do to get this functionality working, as it is easier. I tried closing my browser tab and closing my browser. It was working the last time I updated on Friday.

    The blog I need help with is whatmeread.wordpress.com.

    #2444959

    beautybonus
    Member

    This is also happening to me; I can’t edit any pages (not posts). Plus when I go to edit a different page it hangs on the beep beep boop page. Also tried the backdoor (old) method of editing pages, that doesn’t work either.

    https://gwpaddict.wordpress.com/

    #2444964

    npmbmd
    Member

    Also non functional (on old version) is the button for ‘copy a post’, the help button (and also the button to left of that). I need this asap. Please what’s gone wrong.

    #2444966

    timethief
    Member

    Be sure you are using a browser and version of it found at http://browsehappy.com and upgrade it required.

    If that does not resolve your issue type modlook into the sidebar tags on this thread for Staff help. How do I get a Moderator/Staff reply for my question? https://en.support.wordpress.com/getting-help-in-the-forums/#how-do-i-get-a-moderatorstaff-reply-for-my-question Then please subscribe to this thread so you are notified when they respond. To subscribe look in the sidebar of this thread, find the subscribe to topics link and click it.

    #2444970

    mikecane
    Member

    It’s clear that without warning WordPress has deprecated the Classic Editor by deleting buttons, rendering it unusable.

    Those of us who had the Classic Editor access via Bookmark now have to deal with the new editor.

    This sucks.

    #2444972

    beautybonus
    Member

    Mike I thought so too, but I can’t even edit pages in the new editor, so I think it might be a bigger issue?

    #2444973

    timethief
    Member

    @mikecane
    In essence you are months late to the party as these changes were made in March. It’s true that you cannot deactivate the new Beep Beep Boop editor but you do not have to use it. For locating the ways and means of accessing the legacy or classic pages for creating posts, editing posts, and for viewing stats see here > Navigating the Classic WordPress.COM interface http://onecoolsitebloggingtips.com/2015/04/05/navigating-the-classic-wordpress-com-interface/

    On the dashboard of your own blog at
    Dashboard > Posts > All Posts > Add New
    To create posts in the classic editor for you that link is http://theradiocrytic.wordpress.com/wp-admin/post-new.php

    If you have cookies enabled on your browser your preference will be saved unless or until your clear your cookies, and it will take you to the classic editor automatically every time you create a new post via the drop-down menu in the black admin bar or edit a post via the edit button on the blog itself.

    Mar 18, 2015, 10:29 AM
    The Classic Editor will continue to exist in wp-admin. We know some users prefer to use this editor, so we want you to have access to it, instead of phasing it out with the new version of the Dashboard. However, a link to the Classic Editor will not return to the New Editor. https://en.forums.wordpress.com/topic/when-editing-an-old-post-how-do-i-switch-to-the-classic-editor?replies=5

    Features that won’t be included in the new editor
    Post Revisions
    Copy a Post
    Link back to wp-admin
    Read more here https://en.forums.wordpress.com/topic/please-reinstate-the-option-of-choice-to-use-the-old-publishing-format/page/32?replies=942#post-2338964

    #2444974

    timethief
    Member

    but I can’t even edit pages in the new editor, so I think it might be a bigger issue?

    Agreed and that’s why I advised tagging this thread for Staff help.

    #2444978

    beautybonus
    Member

    Tagged and waiting, thanks timethief!

    #2444981

    mikecane
    Member

    Well, I just used my Classic Editor bookmark and got all the buttons again. This might have been a temporary glitch. Panic over.

    #2444983

    timethief
    Member

    @mikecane
    I use only the classic editor.

    just used my Classic Editor bookmark and got all the buttons again.

    Good to know and thanks for telling us.

    #2444984

    beautybonus
    Member

    I see the buttons but no scroll bar on the right and linking is still not working plus new editor still hangs too; panic for me not over! :)

    #2444985

    timethief
    Member

    Please be patient while waiting for a Staff response.

    #2444987

    npmbmd
    Member

    Yup – just temporary. AOK :-)

    #2444989

    timethief
    Member

    @npmbmd
    Thanks for the update and best wishes.

    #2445005

    Don’t mind me. Just hopping on the page-editor-loading-problem train, to wait for the update.

    #2445011

    beautybonus
    Member

    As a temporary workaround, I edited my content in a draft post, then copied and pasted into the old page editor (being patient! Just thought this might help others with the same problem).

    #2445012

    timethief
    Member
    #2445120

    rootjosh
    Staff

    So, there was a glitch with the editor today. It should be fixed. You might need to reload it if you happen to have a page open to it (remember to save your work).

The topic ‘Link button not working in pages’ is closed to new replies.