Need help? Check out our Support site, then

link buttons not working in visual mode (writing and editing posts)

  1. while writing or editing posts, on firefox, IE, chrome and safari
    i tried clearing cookies and all the stuff one usually does, all browsers are updated but i'm still having issues and can only insert links in text view (sometimes it takes a while in txt too)

    The blog I need help with is

  2. You write the word or phrase that will act as the link, highlight it, then click the Link tool to add the URL.

  3. and i'm doing that like i've always done, but when i click on the link button it doesn't open.

  4. I'm having similar problem. I have written the word or phrase, highlight it and then use the link tool. When I view my posts the links work fine. If I however try to view them as a rss feed -- the links are not clickable for content in my body. There is on link attempt I tried today where I put the link in the title or header. This looks clickable but does not fully work. I really want them to work on my posts in the feed format. Any suggestions? I'm still just learning how to use, but I do understand about adding the text/highlighting it/using link tool.

    Thank you very much.

  5. I'm having exactly the same problem as elipunto : (
    Any fix?

  6. @emessageqa
    There's nothing wrong at all. The links do work in the test posts you are creating. May I suggest that you start creating actual content in the test post rather than posting a single ink in the post?

    If you are not running one of these browsers and versions of them please upgrade
    Firefox has a built in feed reader but Chrome doesn't so a feed reader extension is required. Here's the link for that extension
    If you are using Chrome which lacks the built-in feed reader you need to install the browser addon.

    Here's how to make links in posts and pages >
    This is the general link model:
    <a href="URL HERE">Highlighted anchor text here</a>
    This is a the appearance (it's not actually linked her in the forum)
    Highlighted anchor text here

    We get so many requests for this assistance that I published a post on the topic. See here please > Creating HTML Hyperlinks (Links) in WordPress >

  7. @nandacb
    The links in your posts work for me. I suggest the fix needed is at your end of things. If you are using Chrome please read what I posted above re: feedreader addon required.

    1. If you are not running one of the browsers and versions listed at please try upgrading or switching first.

    2. If you are using an IE browser in compatibility mode please disable that mode.

    3. If you are running one of the browsers and versions listed at

    (a) Try clearing your browser’s cache

    If applicable see here for instructions on how to clear the cache for Chrome and Safari on the iPad:

    (b) Make sure that you have both third-party cookies enabled and JavaScript enabled

    (c) Disable all browser extensions or add-ons temporarily.

    (d) Try enabling HTTPS:

    Add both * and * to your list of trusted sites under the Security tab. Make sure to uncheck the box for “Require server verification (https:) for all sites in this zone.”

    4. Try using another browser.

    5. If you are not successful let us know:
    (a) Exactly what kind of device you are using to connect to the internet and to
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary
    (c) And what any error reports you receive state.

  8. Clearing the browser’s cache worked for me. Who'd say... such a simple fix for such an annoying bug!
    Thanks : )

  9. Hooray! Best wishes for trouble-free blogging.

Topic Closed

This topic has been closed to new replies.

About this Topic