Need help? Check out our Support site, then

Link order suddenly reverted to alphabetic

  1. Suddenly my list of links to my old posts are alphabetized, when this morning they were not. My blog is and the links in question are under Far Back Posts on the right side, below the other lists.

    On this earlier topic (closed now), the responder said the only way to avoid alphabetic listing of links was to add numbers.
    That was never true for me. I've been adding links for YEARS to my Far Back Posts links list and each one has been put at the bottom of the list, regardless of title. Until today. Suddenly they are all alphabetized and I don't know why. I didn't do anything that I know of to alphabetize them, and there is no way to change it back. Note: in my dashboard view of the list, I can sort by URL and it will give me the list in the order I added them, possibly because the slugs contain a date? But this doesn't show on the public view of the site.

    Can anyone help? Thank you!

    The blog I need help with is

  2. Go to appearance > widgets open the links widget for edting and set the "sort by" to link ID and see if that does not fix it.

    Also I suggest going to settings > reading and setting your site to show at most 5 posts per page. On my wireless internet service it took literally 3 minutes for your site to load and the search engines take page loading time into account when determining search engine ranking now a days and you could quite possibly have your search engine ranking discounted. Also there are still a lot of people on slower internet connections (less than 1Mbps) that will be very grateful not having to wait 2 or 3 minutes for your site to load.

  3. thesacredpath,
    Thanks for taking the time to help, and for the feedback about my long page-loading time. I've reduced the number of posts showing to 5, as you suggested. However, I checked the widget setting in appearance for that list and it was already sorted by link ID. I set it again anyway but it didn't help.

    Anything else I might try on that? It seems that that would be the right setting. Maybe I'll change it to something else, save, then change it back. If that works I'll post back. Otherwise, still looking for ideas. Thanks again,

  4. Yeah, that should be the right setting. Since it is set that way, and since this just happened, you might want to contact staff directly on this as they may have made some code change that caused it (unintended consequence).

  5. hi i can;t open up links of sections on MYaccount,MY BLOG, ADD says this website can not be found.even i couldn't open the link of since the third time.(this link worked at the first and second time,but failed after matter how i try it,just didn;t work anymore).so i couldn;t get help from staff. i don;t know what happened to my wordpress.can anyone help me ???? thank you very much :P

  6. Log out of wordpress, clear your browser cache and cookies, restart your browser and then try again.

    Also, what browser and browser version are you using?

  7. i use internet explore 8 brower btw thank u thesacrepath :p

  8. Try setting the browser to compatibility view, or if it is already on, try turning it off.

  9. hey the sacredpath,i hv click sorry i;m a compputer idiot.i don;t understand the terms on IE8and what does the website mean???can i open up my wordpress by using internet 8 or not??? would you pls tell me how to fix it.thank you very much.

  10. There is an icon on internet explorer 8 that is "compatibility view. It is a toggle. Click it and it turns it on or off depending on the state it was in before you click it.

    My ultimate suggestion would be to tell you to dump IE8 and get Firefox. Firefox works very well with WordPress.

  11. thesacredpath,
    I've fiddled a little with the settings and here's the report. When I first went to sort that widget by link ID as you suggested I found that it was already set to linkID and yet the list was showing alphabetically. I then went to try to "shake it up" by setting it to something else, saving, and then setting it back (believe it or not sometimes this works with some apps). I changed it to sort by Random and to my astonishment the list went back to the way I'd always had it (which is really by date posted). I put it back to linkID again and again it went alphabetical. So finally I set it back to random again and it seems to be holding steady in the way I wanted it. However, I think I will mention this to staff because it definitely smacks of a bug.

    Thanks for your help with this. Thought you might like to know my experience in case it comes up for anyone else.

  12. You are welcome and thanks for letting us know. It certainly sounds like a bug to me too.

  13. @TSP
    What I see is a slew on links on the front page of this blog. On a directly related issue I wonder if this member is aware that search engines spiders stop crawling when they reach 100 - 113 links on any page. I would remove that that Far Back Posts links list from the front page entirely. I would create a page and use the archives shortcode. How about you?

  14. Thanks both of you,
    (timethief, don't I know you from invisible mikey's place?). Thanks for this input. Do you mean like put up a tabbed page (like my About page) and then put the links there using the archive codes you referenced? But wouldn't such a long list of links still cause the same problem for search engines even though it's not on the home page?

    Also, I find the historical list more useful than a "last 10" or "most popular" or "alphabetical". I want it to stay in the order I put them up. Does the "post by post" option provide that?

    Thanks again,

  15. Yes I have met you on invisiblemikey's blog. :) Yes, creating a static page and using the archive shortcode would create a long page with many links like Archives page do. IMO that's would be preferable to having that lengthy list on the front page of your blog but the choice is up to you.

  16. HEY Thesacredpath,

    i did what i was told to turn on the icon of compatibility view in IE8,but the compatibility view in IE8 doesn;t work on my there any method to fix the problem if i can keep IE8???thank you


Topic Closed

This topic has been closed to new replies.

About this Topic