Need help? Check out our Support site, then

Links in Pages

  1. I am trying to place links in a newly created Page. It is not working. Links are working fine in new blog posts. Am I doing something wrong? Or can I not link on a PAGE?

    The blog I need help with is

  2. Are they advertising links like affiliate links? if so the software will strip the code out to preserves security on this multi-user blogging platform.

    Are they restricted code links? We cannot run JavaScript or use iframe of form codes here.

  3. The guide for creating links in posts and pages is here:
    This is the general link model:
    <a href="URL HERE">Highlighted anchor text here</a>

    Enter your anchor text you want to link to first.
    Then use your mouse to highlight that anchor text.
    Next click the chain icon in the editor and proceed to create the link.

  4. They are not affiliated links. They are links to other wordpress blogs. Basically, I wanted to create a PAGE for the Blogs I follow, rather than have them in a sidebar. I link in posts all the time (highlight, chain icon, etc.) and the links show up fine. I used the exact same method in a new page and nothing happened. I just wanted to make sure that there wasn't a different method when linking in pages (though I thought that would be weird, it occurred to me that it wouldn't be out of the question.) I am going to try it again. If I still cannot get it to work, what would you recommend I do?

  5. There is no technical reason I can think of that could be causing this problem, provided you are following the instructions I linked to and your browser is not an outdated version. You can upgrade any browser version here Please post the URL for the Page you are having issues with. I have flagged this thread for Staff support.

  6. It really is the strangest thing, but I did get it to work... Here's how:

    that little a thingie at the beginning and the end... it's not putting the end one after my highlighted text. So, I have to do it manually.

    Or, it puts the whole link on the top of the page (and doesn't format it properly, as above), so I have to cut and paste manually to get the link to work properly.

    But, at least I got it to work at all.

  7. lightworkerarts

    I am having similar issues with inserting internal links within pages or posts, using the toggle menu to select existing content.

    And also the editing and assignment of internal (or external) links using the links icon in the visual editor is also not working. The URL remains in the field even after inserting and exiting the modal window. If I then try to insert another URL using the same procedure, the former link is visible in the newly reopened modal window. If I delete the former URL, add a new one and save/exit the window, the resulting link in the page or post is now the same (new) link for both embedded links on the page or post.

    My troubles started at a similar time as javaj240 today.

    We have tried this on 2 separate computers with different users, and the issue remains.


  8. @javaj240
    Thanks for that updated information as to how you resolved this for Staff. I flagged the thread so they are aware of it. Please tell us which browser and version of it you are using. If you aren't sure then check here

  9. @lightworkerarts
    Thanks for your information too. Please tell us which browser and version of it you are using. If you aren't sure then check here

  10. RATS! I b0rked that link twice.
    I'm sorry :(

  11. P.S. Staff assist
    I would appreciate it if you repaired the links I b0rked.

  12. lightworkerarts

    My issues are browser independent.

    I am using Mac 10.7x, on Chrome, Safari & Firefox.
    The other admin/user is using Windows 7, with other browsers.
    We are working geographically apart using different ISPs.
    The problems are identical. It looks like a WordPress system issue.

    I am an advance user. Never seen this issue before. Could this be testing out before WP 3.5 goes live next month to self-hosted blogs?

  13. I'm having the same issues as Peter. When I go to insert a link in a newly created post, the previous link appears that I embedded before. It is not saving the new link, so all links in my post are the same. I logged in and out a couple of times, as well as changed browsers (firefox to chrome) and it still did it. I just now restarted my computer and it still doesn't work. The blog I'm having issues with is:


  14. lightworkerarts

    @Melissa... relieved I am not alone, though not happy for either of us.

    Am sure there are MANY more!

  15. lightworkerarts

    PS: I have posted to the Forum, and had no answers (6 hours ago). Have now sent a parallel service cry for help to Tech Support.


  16. This thread is already flagged for Staff assistance. Staff deal with support tickets on the basis of attending to those with the earliest dates first and sending additional cries for help simply moves the date forward.

  17. @lightworkerarts

    I am an advance user. Never seen this issue before. Could this be testing out before WP 3.5 goes live next month to self-hosted blogs?

    Yes indeed WordPress upgrades go live here a month before the versions are released. We under-valued users are guinea-pigs. ;)

  18. Thanks for all the reports. This issue should now be fixed.

    If anyone is still experiencing the issue, please clear your browser cache to ensure that you're loading the latest version of the Visual Editor.

    Let me know if anyone is still having this problem.

  19. having the same problem exverytime i past the web address click update it disapear
    not a advert or antything but a link to a site of interest todo with my blog

  20. @dsg257
    There is no blog linked to your username. Please post an active link starting with http:// to your blog. If you have an example of this issue in a post or page then post an active link to it.

  21. dsg257 - if you still need help, could you please start a new thread describing your issue more fully, and link to it from here so I can take a look? Thanks.

  22. Can't insert links about same topic to my earlier blog posts into a page (not post) which features a gallery of images. Using the "or search..." option on text view to select the posts to insert as link. The links appear, but when page is saved, they disappear.

  23. Fixed problem by using Blogger page. Problem seems that too many sets of quotation marks appear around the actual title e.g. where no quotes should appear.

  24. Oooops! here's the cause of the problem: my slow connection, so the TinyMce link icon on the Visual option of the Page is faded, i.e. shows as inactive. Now it's working, now it shows as active.

  25. thosnevin - Glad you solved the problem. I'm going to close this thread now, but feel free to start a new one if you need further help.

Topic Closed

This topic has been closed to new replies.

About this Topic