Looks good on Firefox, MSIE crappy

  • Author
    Posts
  • #194625

    anubis311
    Member

    I’m usually not the one to just give up and post when I have a technical problem, but I’m at the end of my wits with this. Can somebody tell me why my site looks perfect on Firefox but is completely screwed up on MSIE?

    http://www.captain-angry.com

    The sites been up for like 3 weeks and I just never realized how bad it was becoming with firefox. I got temporarily got rid of all my pages because the top horizontal menu was taking up three lines instead of one, and then I realize the side bar is all the way at the bottom of the page.

    While I love the look, I’m about 5 minutes from scrapping this entire theme because its been a real PITA for me from the start. Please help, I will post whatever code is requested.

    #194779

    Since you are self-hosted and using the software downloaded from wordpress.org, you need to direct your question to http://wordpress.org/support/ . WordPress.com uses a multi-user version of the software which is different and few, if any, here know anything about it.

    7 Things to Know Before Posting in WordPress.com Forums
    WordPress.com or WordPress.org? The difference.

    #194782

    Set your blog to display only one post per page (options > reading) and go through them one at a time to see which is causing the problem. The look over the code in that post. According to the W3C validator, you have quite a few open tags. The more tag has been causing some issues, and you might try putting an ending div tag right before it in code view </div>

    #194787
    #194813

    anubis311
    Member

    Thanks for responding. That validator report will be a good resource. All those errors are the evidence of my own attempts at shoehorning this theme to do what I want. I will try to figure out whats hanging out there. Thanks.

The topic ‘Looks good on Firefox, MSIE crappy’ is closed to new replies.