Lost post because I clicked the wrong button

  • Author
  • #1022463


    I’ve just spent an hour and a half writting a post and now I’ve lost it. I was using the url http://wordpress.com/#!/post/

    It was ready for publication but I want to post a draft first for review and couldn’t see how to do it using the simple publish page I was on, so clicked the help button. When I clicked back, all my work had gone. I stupidly thought it would be saving a draft as I typed. And I didn’t have a backup. I realise I should have gone to the site and used /wp-admin/ rather than the http://wordpress.com/#!/post/.

    Is my work saved anywhere? I really don’t want to retype what I’ve written. I write from the heart and it would be impossible to recreate.



    Using that link, the quick post link, means that no, autosave is not enabled. That is why experienced volunteers here never recommend using it. We always recommend using the Dashboard->New Post page.

    You could check in your Posts->Trash file, but I doubt it will be there. You might, just possibly, be able to hit the back arrow enough times to get back to it, but it’s doubtful.


    @dogandman I’m sorry to hear about this! We try very hard to make it so data doesn’t get lost—on the home page post form, an autosave should kick in at the 60-second mark. However, I tested this and I found that autosaves only happen if you’ve made sure to select a blog at the bottom of the form and I suspect you hadn’t done that. Do you remember if that’s the case?

    @raincoaster, we should fix it so that new home page posting experience is equal or better than the dashboard posting experience so that top volunteers like yourself don’t feel like they need to recommend avoiding it (hopefully we can turn that around!). It helps tons if we can gather up examples like this one. I tagged this one with “lost post new dashboard” in case you (or anyone) remembers to tag similar examples the same way so there’s a good record of how many people are affected.



    Everyone I have encountered has been affected by this. I’ve been reporting it for months now.




    we should fix it so that new home page posting experience is equal or better than the dashboard posting experience so that top volunteers like yourself don’t feel like they need to recommend avoiding it (hopefully we can turn that around!).

    I know you are addressing raincoaster but this has been going on for months now and the likelihood I will ever use that link to create an Aside is the proverbial snowflake’s chance in Hades. I will continue to login directly to my own blog and create posts only on my own dashboard. I restraining myself from say more on this issue lest I get back a Pollyanna response from you.



    @ dogandman
    I am very sorry to say that if were using the “Add New” on the main page for wordpress.com here http://wordpress.com/#!/post/ then the draft is lost and cannot be recovered. That link is only for creating “Asides”. They have no titles and can’t have categories assigned to them and when edited the draft content is gone because the auto-save does not work on them.

    1.Create posts and pages on your own blog’s dashboard.

    2. Or when you start a new post, add the title, set it to private and then publish it. When you are done with the post edit it to update it and set it back to publish.

    3. The third option is to get and use an offline blog client such as Windows Live Writer (Windows) or Ecto (Mac) and then everything is saved on your computer and when you are done with the post, you actually publish it directly from the blog client software. See here for offline blog editors so you don’t have to go through this again http://en.support.wordpress.com/xml-rpc


    I totally understand. In this case I’m referring to the bug reported in this OP, which I understand as: autosave didn’t trigger when posting in the new dashboard because no blog was selected.

    I did check the “lost post” tag in the WordPress.com forums, and there are currently 7 other reports in the last 6 months showing but they have very little info. to go on—most (all?) don’t even say which dashboard people were using when the problem happened (it’d be very helpful to ask about that). Also, it’s totally possible that some of the past reports you’re referring to are because of a different bug—impossible to tell based on the information given so far.

    That link is only for creating “Asides”.

    I just tested the form, and it didn’t post as an Aside post type. Maybe that’s a theme-specific thing you’re thinking of, or maybe the new dashboard form has changed since the last time you checked it? It’s not just for creating asides.



    My memory must be faulty as I thought it all began in March https://en.forums.wordpress.com/topic/lost-an-article?replies=3


    This is a particularly tough issue to pin down without more information. Even with more information, it still might be hard to track down if a browser crash is actually to blame. I noticed that https://en.forums.wordpress.com/topic/lost-an-article?replies=3 doesn’t provide very much information to go on… no errors, no info about what might have caused the browser to crash or even their browser version, no info about the blog post in question such as the title, no indication about whether they had tried saving the post as a draft during the 2 hours they were writing, no hint about whether they were still logged in when their browser crashed, and they didn’t even mention which dashboard they were using (which is relevant to this OP). It seems like the problem was a browser crash in the case from March, and that’s not the same issue as the one reported in this thread.

    It’s tough to think of details like those when reporting a problem though—so that’s why I try to ask for a lot of questions about what’s going on when I notice strong statements about something not working as it should. If that user’s issue from March somehow turned out to be the same one as this OP, it’s not evident in the info given so far and recent reports with more detail will be way more helpful.

    Lately I’m finding consistent forum tags for issues like this to be extremely helpful. For the tag “lost post,” I only found 8 reports in the past 6 months though. Let’s start getting new reports with relevant details tagged so we have more information to go on.



    As far as I can recall the bug has been occurring since that feature was invented. I don’t tag, because it’s hardly likely that what I’d consider an accurate tag for the problem “New Post” is what you’d consider an accurate tag for the problem. Besides, do you know how many of those threads NOT tagged “lost post” I tagged “modlook?” Surely if a staffer has looked at it a staffer can handle tagging it.


    Accurate tagging is just one thing that I’ve personally found super helpful and which could help lead to more bugs getting found and fixed. Personally I always tag posts I’ve reviewed, especially if I see a trend forming. You don’t have to tag if you don’t want to. No worries!


    I’ve just spent an hour and a half writting a post and now I’ve lost it.

    That wouldn’t happen if you would do your typing, proofreading, corrections, etc. OFFLINE in something like Notepad. Get the basics the way you want them, save a copy to your PC, than Copy and Paste it into the Post form.

    If something goes wrong in the Post process, you haven’t lost anything at all. Just paste it again.



    I recommend Windows Live Writer, as you can do formatting and add tags and categories to it. Notepad is fine if writing in code comes naturally to you.



    Thank you for the replies. It’s the only time I’ve used the quick post page. I liked it’s simplicity so you could focus on the text you’re writing rather than the clutter. In that respect, it’s a good tool. I won’t use it again though until I’m 100% sure it works. Loosing words is a blow.

    Thanks for the recommendations for offline tools. I may investigate. I’m happy with the normal wp-admin tools as I can pick up from any machine.

    I’ve worked with computers for 30+ years and always backed up / saved as I go, so I’m feeling pretty dumb not following my own practices.

    I had put in a title – One week later and selected my plot32b blog. It was the first thing I did when I started the post. I’ve investigated local caching, local temp files and found no trace, so I’ll have to start afresh.


    I double checked all your blogs (just in case) and I couldn’t find any drafts dated September 24th. I’m sorry your post didn’t get saved! I also tested autosaves and they worked in my tests as long as blog was selected. If you’re interested in helping to debug this further by any chance, please let me know.

    I had put in a title – One week later and selected my plot32b blog.

    This is helpful to know. Thank you.




    I created a second blog today. Now neither of my blogs posts under “my blogs” or “manage my blogs”….





    Your issue is off-topic in this thread. Please click this link and start your own thread and we will help you in it. https://en.forums.wordpress.com/?new=1


    @timethief, thanks for the tag links, I’ll check them out.



    You’re welcome.

The topic ‘Lost post because I clicked the wrong button’ is closed to new replies.