Lost the "Attachment Display" settings" side bar.

  • Author
    Posts
  • #2526320

    In my ‘Add Media’ page I have somehow lost the “Attachment Display settings” side bar. (Just a beginner!) I have the Premium Edition

    The blog I need help with is searchscriptures.wordpress.com.

    #2526375

    justjennifer
    Moderator

    Which Dashboard are you using to write your posts?

    The New Dashboard Post Editor at https://wordpress.com/post/ or the WP Admin Post Editor at https://searchscriptures.wordpress.com/wp-admin/post-new.php

    #2526536

    Hi Jennifer, wordpress.com I think. Does it matter? Martin

    #2526548

    justjennifer
    Moderator

    Hi there, Martin, yes it does matter.

    While the New Dash Post Editor does offer some advanced features if you first highlight the image you want and then click the “Edit” button at the bottom of the Add Media screen, it doesn’t have all the features of the full WP Admin Dash Post Editor. This includes, apparently, the ability to link single images to their attachment page. You can however link them when adding Media in the WP Admin Dash Post Editor (the second link I gave above).

    More info on advanced image settings can be found here, and most of it relates to working in the WP Admin Post Editor. https://en.support.wordpress.com/images/image-settings/

    Hope that helps. Let us know if you have more questions on that.

    #2526549

    Thanks Jennifer very much for coming to my aid.
    To make clear where my problem lays I have on my site a “Media” page for audio files (which happens to be password protected).
    I used open that page and go to Edit. (I haven’t done this for some months)
    Then I clicked on the ‘add media’ icon to place a link to an audio file (MP3) I had already down loaded.
    This opened the Media library where the media waited to be inserted AND on the right hand side was the sidebar “Attachment Display Settings” which allowed me to embed an audio file, OR set a link for the audio file.
    That sidebar is now missing and if I hit the ‘Insert’ button at the bottom right, it embeds the audio whereas I want to place a link to it!!
    I hope I have explained my problem clearly.
    Martin

    #2526566

    justjennifer
    Moderator

    Hi again,

    I used open that page and go to Edit. (I haven’t done this for some months)

    If you are referring to the EDIT link that you see on every page and post on the front-facing side of your site (on the actual published page and post), clicking on that link now takes you to the New Dashboard Editor, which is what I described above.

    Now in order to get to the WP Admin Editor to edit that page, you need to open your WP Admin at https://searchscriptures.wordpress.com/wp-admin/ and navigate to that specific page under PAGES > All Pages. Hover your cursor over the title of the page until you see the Edit link appear and click on it.

    Regardless, I’ve just tested uploading an audio file in the New Dash Editor on one of my sites. Once I selected the file in the Media Library, I could Edit some details, including copying the file’s link, by using the Edit link at the bottom of in the New Dashboard Media Library that appears after selecting the media file.

    There do seem to be more options when working with audio files in the full WP Admin Dashboard, including Link to Media File and Link to Attachment Page.

    I’m also going to tag this for Staff attention so they take note of your feedback on working with audio files in the New Editor. Perhaps also there is something I am missing with working in the New Editor that should be obvious, but at first glance doesn’t seem to be.

    Please be patient as Staff presence in the forums is minimal at this time.

    #2526567

    justjennifer
    Moderator

    Lovely, not sure what happened there, probably an unclosed tag. #facepalm

    #2526568

    Hi Jennifer,
    Wonderful – it works (of course). Thanks for your patience. REally appreciate your help. Martin

    #2526573

    kokkieh
    Staff

    Hi there,

    I can confirm that the ability to edit media attachment settings is not available in the new editor at the moment, but it is on the list of features we are looking at adding in future versions.

    In the meantime, please use the WP-Admin editor as @justjennifer explained to make these types of edits.

    Let me know if you have more questions about this.

    #2526584

    Hello Kokkieh,
    It is straightforward when you know what has happened, but it is a backward step really for a new development. (Perhaps ‘they’ should have left well alone!! :-0
    I just go to the ‘My Sit’ drop down, select ‘pages’ and ‘edit’ and there is the publish sidebar.
    Thanks for you comments,
    Martin

    #2526585

    ‘My Site’ drop down, sorry. M

    #2526586

    justjennifer
    Moderator

    @martinjfuller- You’re quite welcome. There’s been lots of feedback about various “missing” features in the New Editor. Some will be incorporated in upcoming versions, but at least now you know how to get to the WP Admin Dashboard Editor. Best wishes from me.

    #2526593

    kokkieh
    Staff

    @martinjfuller
    I agree that from a certain perspective the new editor looks like a step backwards – I’d even blogged about it before I started working for WordPress.com – but from a programming perspective it’s necessary if we don’t want WordPress.com to be overtaken by newer, more streamlined services. You can read the full story here:
    https://developer.wordpress.com/2015/11/23/the-story-behind-the-new-wordpress-com/

    But there is a lot that still needs to be done, and we appreciate all constructive feedback and feature requests that will help us ultimately make the new editor as good as, if not better than, the WP-Admin one.

The topic ‘Lost the "Attachment Display" settings" side bar.’ is closed to new replies.