Mac editing problems

  • Author
    Posts
  • #148368

    neilbowers
    Member

    At some point recently visual editing support seems to have been added for the Mac.

    It looks like a bug was introduced at the same time. If I edit a page, and put multiple P elements inside a TD inside a TR inside a TABLE, then after saving it, the paragraph tags have been lost, and the text has all merged into a single paragraph.

    I had two tables in the same page, and there seemed to be some circumstances in which paragraphs would be retained in one of the tables but not the other.

    I tried using the visual editor, but it has the same problem. As I’m on a Mac (using Safari), I don’t know if this is a Mac issue, or possibly even a Safari issue.

    Finally, any chance of a config option so I can specify that I want the Code editor view as the default, not Visual. That would save me a mouse click for every post :-)

    #148679

    neilbowers
    Member

    Also, I forgot to add: after editing in the Code view, and then Saving. All layout I’ve put in is lost; in particular newlines seem to be getting stripped. Which is a tad frustrating when you’re using the Code editor :-)

    #148687

    judyb12
    Member

    http://faq.wordpress.com/2006/05/20/im-using-safari-and-i-have-problems/

    If you use Safari, you probably want to stick with the code editor for now.

    #148692

    For editing and writing pages and posts, I’ve found FireFox for the Mac much more usable. Safari has some issues. FireFox is not perfect, I run into little problems quite often, but it’s better than Safari. The Safari Beta 3.0.3 seems pretty good though and I have hopes it will work with wordpress.com although I haven’t checked out all the problem areas yet.

    #148719

    trent
    Member

    It wasn’t until upgrading to Safari 3.0.x beta that the editor started to work correctly. It is not a download from the ‘software upgrade’ so you have to go to Apple directly to download it until it becomes a commercial release. Firefox is the only one that works right now with the visual editor for Mac right now out of the box. Something that is changing quickly, but needed for everyone’s attention on a mac ;)

    Trent

    #148722

    turtlebutt
    Member

    Ugh, I like Safari so much better than Firefox. I hope they resolve the issue so I don’t have to switch browsers just to post a blog.

    #148724

    trent
    Member

    You can head over to http://www.apple.com/safari/ if you are adventurous!

    Trent

    #148733

    @turtlebutt

    Get the Safari 3.03 Beta browser, it is very stable in my experience.

    #148855

    neilbowers
    Member

    I’m using Safari 3.0.3, and getting these problems. So it wasn’t that visual editing support was recently added, just that I started using a browser which resulted in Visual editing being available.

    I edit the following post:

    http://felixbowers.wordpress.com/2007/09/23/a-walk-in-burnham-beeches/

    I get put into the Visual editor, and switch into Code. I put two paragraph elements in each of the two tables – you can see the breaks in the text next to the 1st and 3rd images. If I save, the structure is saved fine.

    But if I now edit the post, going into the Visual editor (which happens automatically) seems to screw up the HTML, losing the paragraph tags. If I switch into Code, I’ve still lost those tags, and if I save without putting them back in, they’re lost.

    I’ve also tried using Firefox (2.0.0.7 — the current release), but can’t edit posts at all with that. I don’t get any editing area, either for Visual or Code. Happy to provide a screenshot if it’s not clear what I’m saying, and isn’t reproducible.

    #148856

    timethief
    Member

    (1) If you are using the Adblock extension in Firefox, open it, click Preferences, click Exception Rules and add this as a filter:
    @@|http://*.wordpress.com

    (2) Stab in the dark, if that doesn’t work – Have you tried using Camino?

    #148857

    @neil
    I’ve seen this behavior with the visual editor as well (even in FireFox), which is why I switched to a desktop blog client for my posts. If I put in two paragraph breaks (to double-space between paragraphs) the visual editor will strip one of them out, and I’m not sure why that is. I haven’t yet tried double-spacing in Safari 3.0.3 Beta yet, but from what you are saying, the problem is there as well. It would be nice if we could choose which editor we wanted to use.

    {waving to timethief}

    #148858

    timethief
    Member

    You can shut off the visual rich text editor Tiny MCE.
    I do it all the time. -> Users -> Your Profile
    (find the checkbox and remove the indicator) then click “Update Profile”.
    Now you can use the standard editor.

    #148860

    neilbowers
    Member

    Thanks timethief — turning off the visual editor did the trick for me. I didn’t look hard enough through all the menus to find that option.

    Now I’ve turned off the visual editor I’m not losing markup.

    And your first firefox suggestion also did the trick, though now I can use my preferred browser, I’ll stick with Safari.

    Thanks for your timely help.

    #148864

    timethief
    Member

    YAY! Another happy camper. I’m so glad I was help to help you. :)

    #148883

    terraflora
    Member

    I am probably sorely under-proficient in this arena, but I’m really hoping I can understand what I need to do to get my tabs/indents to stay.

    After following this thread (VERY helpful in realizing that Safari 2.0+ is the reason I am not getting the rich editor) and switching to Firefox (also sad about that like neils), I don’t understand what I can do to maintain indents.

    I’ve pasted the content from Word using the “paste from Word” icon; I’ve free entered; I’ve tried using the indent icon (but dang, it adds an extra height line!)

    What can I do?? Any suggestion would be very appreciated.
    Thanks!!

    #148885

    @terraflora
    Here are some alternatives.

    (1) Have you tried shutting off the text rich editor and using the standard editor instead?
    -> Users -> Your Profile
    uncheck the checkbox for “use the text rich editor” then click “Update Profile” to save the change.

    (2) A second alternative is to use an off-line blog editor.

    (3) A third alternative is to ditch Word with all it’s extra microsoft stuff in it cluttering up the html and use a plain text editor like notepad instead.

    P.S. It’s also recommended that you upgrade your safari and firefox browsers to the new versions.

    #148886

    Safari 3.0.3 Beta works nicely (as long as your running OS X 10.4.8 or higher). Doesn’t work with earlier versions of the OS.

    #148901

    terraflora
    Member

    @sacraedpath: Yes, I’m 10.4.10, So I guess I can check. I was a little skittish since its still beta. But maybe I’ll give it a go. Many thx!!

    @thistime…: Yes, I did turn the checkbox on and off… Oh, well, wait. I did that while still trying to get Safarie (earlier version) to work. I didn’t again! try to toggle on/off in Firefox.

    I did read on the horrors of word. Darn. SO: ANY suggestions on off-line blog editors??

    Thanks so much!

    #148903

    Safari 3.0.3 Beta is steady as a rock. I’ve had no problems whatsoever.

    I use Ecto http://infinite-sushi.com/software/ecto/ as an off-line editor and have been reasonably happy with it. Once in a while I will somehow get formatting kinked up in a post, but I just pop into the code mode and delete the offender and all is back to normal. There is also another one I’ve downloaded to try, but haven’t yet called MarsEdit http://www.red-sweater.com/marsedit/ . Both cost money, but less than $30. For a free editor you might check out one of the following:

    QTM: http://qtm.blogistan.co.uk/
    Lycos-Qumana: http://lycos.qumana.com/download.htm

    #148905

    terraflora
    Member

    Thanks so much for all of the info! I’ve already download and activated Safari 303! I do tend to trust Apple!!

    I have so much to learn about in blogging. I haven’t even (or maybe have only just) found where I want my focus… but I realize that the look of some of y’alls blogs is SO much better. Well, I will continue to play and tweak… until I really hit my stride and then want to upgrade to paid.

    Thanks again!

The topic ‘Mac editing problems’ is closed to new replies.