Why is my main page not appearing correctly in Internet Explorer?

  • Author
    Posts
  • #646670

    craigtowens
    Member

    When going to craigtowens.com, the three columns do not appear correctly. But if I click on an individual post, then the proper formatting appears. This only happens in Explorer. Firefox and Safari do not have an issue.

    If it’s helpful, I have two screenshots I can share with you.
    Blog url: http://craigtowens.wordpress.com/

    #646807

    Screenshots would most certainly help, thanks; on my end your blog appears to display correctly.

    #646812

    craigtowens
    Member

    How can I upload the screenshots to you?

    #646814

    You can upload them to your Media library and I’ll take a look at them there, thanks.

    #646820

    craigtowens
    Member

    Two pictures are uploaded: one of the incorrect view (on the main page), and one of the correct view (after I click on an individual post).

    #646821

    Ok (you can delete that post now, if you want), this appears to be either a connection issue, i.e. the CSS styles aren’t being applied or, more likely a browser issue. Could you to clear cache & cookies and reloading the page?

    #646826

    craigtowens
    Member

    I cleared everything. When I reload the page, it starts to load correctly (I see all three columns just for a brief moment) and then it reverts to the one column view again. Any other thoughts?

    #646883

    macmanx
    Staff

    Can you tell us what browser (and version of) you’re using?

    #646886

    craigtowens
    Member

    I’m using the latest Explorer (I believe it’s 10). The problem only occurs on the main page. It doesn’t occur on the individual post, or when using Firefox or Safari.

    #646894

    macmanx
    Staff

    I do see the problem now, in IE 9 (10 isn’t release yet), so I’ll pass this on and see what we we can do about that.

    #647041

    craigtowens
    Member

    Any updates to pass along on this? I appreciate your expertise (way beyond my knowledge base!).

    #647047

    macmanx
    Staff

    Unfortunately, this is not actually a general issue with your theme.

    There’s something on your blog messing with IE, probably in your posts.

    To find it, I recommend setting your blog to display one post at a time via Settings -> Reading in your Dashboard, then page through your posts individually until you find the problem.

    If you can’t find a single post causing the issue, start removing widgets individually until you find the cause.

    #647050

    lance
    Staff

    @craigtowens

    This is a weird one! We’ve spent a bit of time troubleshooting it, but didn’t come up with anything to report.

    For now I’ve fixed it by changing the setting on your Settings > Reading page to “10” for “Blog pages show at most”.

    #647052

    craigtowens
    Member

    Thanks for all your help!! It looks “normal” again. :-)

    #647053

    lance
    Staff

    Great to hear that. Thanks for your patience.

The topic ‘Why is my main page not appearing correctly in Internet Explorer?’ is closed to new replies.