Make a static page my home page

  • Author
    Posts
  • #712861

    vuthisa
    Member

    I know there is a ton of information out there to make another static page your Home page and have the Blog posts appear as another page, and I’ve got my blog to function OK – thanks to this forum. But unfortunately when readers click the Blog Page on the navigation bar, the Home page and Blog page are both highlighted at the same time – which could be quite confusing for the reader! A bit of history on how I got my Home page to display the way it is: I created a static page to be my main page, and made a child page under it. I then needed to “make private” the parent page for the child page to appear. Perhaps it has something to do with my theme Greenery by iLemoned, but every time I want to edit my child page, I need to “Publish” the parent Home page, and of course return it to “Private” when I am done. If I don’t do that my permalink address of the main page changes – gets a numerical number added to it, I got to no.5 when I finally figured this out. I have left it like that for a few months now, but perhaps there is a way to fix it.

    Parent permalink: http://vuthisa.com/home-5/
    Child permalink: http://vuthisa.com/
    Home page: http://vuthisa.com/
    Blog posts: http://vuthisa.com/posts/

    Please help.

    Thanks

    The blog I need help with is vuthisa.com.

    #713066

    airodyssey
    Member

    Hi. What exactly is your question? How to remove the duplicate tab on your blog? If that’s the case, you can hide the page…
    http://en.support.wordpress.com/pages/hide-pages/#hide-from-the-navigation-menu
    …or use a custom menu
    http://en.support.wordpress.com/menus/

    #713080

    vuthisa
    Member

    Thanks airodyssey. The links you provided did not help. Changing the order or the parent page in Attributes does little to stop both my page titles on the header nav bar to be highlighted simultaneously. Click on http://vuthisa.com/posts/ and you’ll see what I mean. I just wanted to know if it is a glitch with my specific theme or whether it can ‘somehow’ be fixed in Attributes or by doing it differently to the way I explained above.

    #713082

    The double highlighting is a mistake in the theme, and the parent/child/private mess is your mistake. To correct the problem, forget all about child and private pages, and create a custom menu including only the items you need.

    #713090

    vuthisa
    Member

    Thanks panaghiotisadam. So if I copy all the contents of my child home page to my parent home page and delete the child page it will sort out my parent/child/private mess? I’ll revert and let you know how it goes. Pity about the double highlighting.

    #713099

    In case I wasn’t clear, if you create a custom menu with the right items there will be no double highlighting.

    And you don’t need to copypaste anything: just turn your actual intro page into a parent page and trash its useless parent. Go to Settings>Reading and make sure your intro page is selected as your front page. Then go to Appearance>Menus, click the cross to create a menu, give it a name, click View All in the Pages module, select the pages, click Add to Menu; when they’re added, drag them to change their order if necessary, click Save Menu; then select that menu from the pulldown in the Theme Locations module, click Save.

    #713107

    vuthisa
    Member

    Thank you panaghiotisadam! I followed your steps and everything works 100% now. I did not even know about the Appearance>Menus option until today. Will use it in future. You guys are awesome.

The topic ‘Make a static page my home page’ is closed to new replies.