Managing DNS for ARUBA email

  • Author
    Posts
  • #1501685

    gchirici
    Member

    I have as registrar aruba.it where my domain aisf.it is registered.
    I mapped aisf.it changing the dns in aruba to the WordPress ones:
    ns1.wordpress.com
    ns2.wordpress.com
    ns3.wordpress.com
    Everything fine. The mapping was completed in approx. 5 hours.
    Of course the mail at aruba stop working.
    I asked to aruba how to change the DNS to maintain at the same time the wordpress dns and the mail working at aruba.
    They don’t know how to help me.

    Can you help me in configuring DNS in WordPress for let the mail working in aruba?
    From aruba control paneI I only have this information:

    Mail Record Aruba
    mx.aisf.it 62.149.128.72
    mx.aisf.it 62.149.128.74
    mx.aisf.it 62.149.128.151
    mx.aisf.it 62.149.128.154
    mx.aisf.it 62.149.128.157
    mx.aisf.it 62.149.128.160
    mx.aisf.it 62.149.128.163
    mx.aisf.it 62.149.128.166
    pop3.aisf.it 62.149.128.73
    pop3.aisf.it 62.149.128.75
    pop3.aisf.it 62.149.128.152
    pop3.aisf.it 62.149.128.155
    pop3.aisf.it 62.149.128.158
    pop3.aisf.it 62.149.128.161
    pop3.aisf.it 62.149.128.164
    pop3.aisf.it 62.149.128.167
    mail.aisf.it 62.149.128.72
    mail.aisf.it 62.149.128.74
    mail.aisf.it 62.149.128.151
    mail.aisf.it 62.149.128.154
    mail.aisf.it 62.149.128.157
    mail.aisf.it 62.149.128.160
    mail.aisf.it 62.149.128.163
    mail.aisf.it 62.149.128.166
    smtp.aisf.it 62.149.128.200
    smtp.aisf.it 62.149.128.201
    smtp.aisf.it 62.149.128.202
    smtp.aisf.it 62.149.128.203
    webmail.aisf.it 62.149.158.91
    webmail.aisf.it 62.149.158.92

    Thank you

    The blog I need help with is aisf.it.

    #1501764

    kraftbj
    Staff

    Howdy,

    From checking the domain’s current MX record (where DNS tells e-mail servers to use for mail), the MX record should be mx.aisf.it

    From what you pasted below, those look to be A records (pointing a specific subdomain to an IP address(es)).

    Is that correct from your understanding?

    If so, your Custom DNS ( at https://aisfdotit.wordpress.com/wp-admin/paid-upgrades.php?page=domains&action=dnsedit&domain=aisf.it ) should be set to

    MX 10 mx.aisf.it
    A mx 62.149.128.72
    A mx 62.149.128.74
    A mx 62.149.128.151
    A mx 62.149.128.154
    A mx 62.149.128.157
    A mx 62.149.128.160
    A mx 62.149.128.163
    A mx 62.149.128.166

    in order to receive mail.

    For your e-mail clients and your web client, I would think that the rest of the entries would be added as A records in addition to the above. Thus:

    A pop3	62.149.128.73
    A pop3	62.149.128.75
    A pop3	62.149.128.152
    A pop3	62.149.128.155
    A pop3	62.149.128.158
    A pop3	62.149.128.161
    A pop3	62.149.128.164
    A pop3	62.149.128.167
    A mail	62.149.128.72
    A mail	62.149.128.74
    A mail	62.149.128.151
    A mail	62.149.128.154
    A mail	62.149.128.157
    A mail	62.149.128.160
    A mail	62.149.128.163
    A mail	62.149.128.166
    A smtp	62.149.128.200
    A smtp	62.149.128.201
    A smtp	62.149.128.202
    A smtp	62.149.128.203
    A webmail	 62.149.158.91
    A webmail 	62.149.158.92

    I’m happy to add these, with your permission, or you could add them as well.

    Since your e-mail provider didn’t provide confirmation, there’s the possibility that we may be missing something. However, from examining your current DNS, I feel confident in this solution.

    #1501769

    gchirici
    Member

    Thank you very much for your kind reply.
    For the moment, in order to re-activate e-mail addresses to the people working at aisf.it (!), I have restored default DNS at aisf.it. The e-mails now are back, but (of course) the web http://www.aisf.it disappeared. I choose the minor damage, let’s say.
    I will try your solution re-mapping aisf.it during the week-end.

    I will take you informed!

    Cheers

    Gherardo

    #1501772

    kraftbj
    Staff

    Please do let me know how it works out. I typically am not online during the weekend, but will check in over the weekend in case you need anything. Worst case, I’ll field anything you need first thing Monday morning (in the States).

    Cheers!

    #1501775

    gchirici
    Member

    OK! Thank you again.

    #1501807

    gchirici
    Member

    Dear kraftbj, from Aruba they suggest a possible different solution.
    Can you please let me have the ip address of http://aisfdotit.wordpress.com/ ?
    I noticed that you at WordPress gave this info for similar solutions (see for example https://en.forums.wordpress.com/topic/which-are-the-ip-addresses-for-ns1wordpresscom-ns2wordpresscom-and-ns3word?replies=4)
    Thanks again.
    Gherardo

    #1501814

    kraftbj
    Staff

    We don’t recommend assigning A records to the IPs on WordPress.com. Each site is fully cloud-based and distributed on a number of servers with a load balancer. The six IPs that would need to be assigned can and will change (as we deploy additional servers, add datacenters, etc), which could result is degraded performance or outright failure.

    I’ll send you an e-mail to the address on the account with additional information (as I wouldn’t want someone to find old IP addresses, like in the post you linked to, and use the outdated information).

    #1501854

    gchirici
    Member

    Dear Brandon, good job!
    I followed your recommendation and now our domain aisf.it is successfully remapped in wordpress and at the same time the e-mail @aisf.it managed by the registrar ARUBA are ok.

    Last problem:
    we have a third level at ojs.aisf.it that is on an external machine at 5.9.108.199 that now is no more working. I added the line in the DNS:
    A ojs.ais.it 5.9.108.199
    But it doesn’t work. Do you have a solution for this too?

    #1501859

    kraftbj
    Staff

    Hi Gherardo,

    Sure thing! I made a small tweak, since the line should be A ojs 5.9.108.199—as it was, it actually created an A record for ojs.aisf.it.aisf.it.

    It should start working as soon as the DNS caches cycle.

    Please let me know if you have any questions or need anything else!

    #1501867

    gchirici
    Member

    Brandon I’m very, very sorry I have to disturb you again.
    Everything was fine.
    I was trying to verify aisf.it with the tool for Google App. After I pressed the button “Generate DNS records” WordPress generated the new records but also deleted all the previous DNS records!
    So I erased all the DNS records and then wrote again the previous DNS records. I validated and then saved.

    Now I have this new problem with e-mails @aisf.it:
    – we are able to send from @aisf.it
    – we are able to receive mails sent to @aisf.it BUT the person who send an email to @aisf.it receive this message back of “Mail Delivery Subsystem”:

    Delivery to the following recipient failed permanently:

    (email redacted)

    Technical details of permanent failure:
    Google tried to deliver your message, but it was rejected by the server for the recipient domain aisf.it by aspmx.l.google.com. [2607:f8b0:4002:c02::1b].

    The error that the other server returned was:
    550-5.1.1 The email account that you tried to reach does not exist. Please try
    550-5.1.1 double-checking the recipient’s email address for typos or
    550-5.1.1 unnecessary spaces. Learn more at
    550 5.1.1 http://support.google.com/mail/bin/answer.py?answer=6596 p49si1939462yho.321 – gsmtp

    —– Original message —–

    DKIM-Signature: v=1; a=rsa-sha256; c=relaxed/relaxed;
    d=gmail.com; s=20120113;
    h=mime-version:sender:date:message-id:subject:from:to:content-type;
    bh=EYbNben4zb5OErQinQy2AoVFrydqEpjGBXgbnaxFiH0=;
    b=gBbXdrrb6op+3TohZyzUkC5gfqZUm6Bg3x56KGGjfYFo+2LWzr03f/bCiXEiUUxKn8
    zcOqzP28KPcht3vBK19Qevq2VpB/H8iOp51wmw7qigAKet1XX4UDwJQSPKvUIt9WOZ7Q
    QLrRiW1J6MnNLOeGxwznrDQa34/3aK0KdEbpnMa1yrPRVb7iiWDCyNydy0U8gxijBcmd
    OriKw4gBYBtLcjzWTfn6ddP6yyjgvpqkcJY3Co9zVslw65MKhBkfX4WtZYHB5fpLEj6g
    hDncdhvOpnY8UHv+FktzKigoaKgs9VEald2I1JWahhb8KE5Ss99XorSMbpEBX1XXjEBl
    Cf7Q==
    MIME-Version: 1.0
    X-Received: by 10.50.115.35 with SMTP id jl3mr4338409igb.37.1383355547098;
    Fri, 01 Nov 2013 18:25:47 -0700 (PDT)
    Sender: (email redacted)
    Received: by 10.64.233.38 with HTTP; Fri, 1 Nov 2013 18:25:47 -0700 (PDT)
    Date: Sat, 2 Nov 2013 02:25:47 +0100
    X-Google-Sender-Auth: 2YOc36wVg2VNI87pTM1pFA46F30
    Message-ID: <CAEjkB8_LHL1S9Wf3mPWDPmQk4=BFdcL==Cp5z4BNSGTdk6To=(email redacted)>
    Subject: test
    From: Gherardo Chirici <(email redacted)>
    To: (email redacted)
    Content-Type: multipart/alternative; boundary=089e01183fccfbafe604ea278fcc

    test

    #1501868

    gchirici
    Member

    Brandon it seems now everything is ok. Maybe just a matter of propagation?

    Thanks a lot for your help!

    Cheers

    Gherardo

    #1501871

    kraftbj
    Staff

    What i looks like is when you sent the e-mail, it went through during the time when the Google MX records were set by the Google Apps tool since the failure is coming from Google Apps’ server.

    Likely just a bit of a hiccup with changing over the DNS settings, but I’d imagine everything should be good going forward, assuming nothing changes on the setup!

    Please do let me know if there’s anything else I can do for you!

    #1501872

    gchirici
    Member

    Great support!

    Thank you

The topic ‘Managing DNS for ARUBA email’ is closed to new replies.