Map not displaying in post

  • Author
    Posts
  • #1504632

    I have embedded a Google map in a post according to the instructions in WordPress but it is not displaying. I have previously done this correctly, and have not done anything different this time. What is happening? Help please! The post is http://londondiaryblog.wordpress.com/2013/10/31/bradshaws-hand-book-sixth-day-the-west-no-32/

    The blog I need help with is londondiaryblog.wordpress.com.

    #1504690

    Your code does look like it’s outputting in a wonky way. It looks like it’s spitting some of the formatting code into the link itself, which is preventing the map from displaying.

    View 0000FF;text-align:left”>Bradshaw, Day 6, Berkeley & Grosvenor Squares in a larger map

    It’s hard to tell whether it’s an output problem or just an accidental typo. Have you tried embedding it again, making sure to follow the instructions here? Embedding Google Maps

    Have you tried embedding a different map, to see if something else works?

    #1504697

    I have followed the instructions exactly and get the same result. I then tried embedding a map which I had used earlier in the year and it would also not display. I am using Google Classic Maps – would this have an effect?

    #1504698

    I tested it on my end, and it only worked on the second try, when I made sure to save the draft and watch the iframe code get turned into the shortcode (as they describe in the instructions). Could you do this and verify that it turns into the shortcode in your text editor before you publish?

    #1504700

    I repeated as per instructions, and waited. This is the code that is displayed in the post:
    <small>View Bradshaw, Day 6, Berkeley & Grosvenor Squares in a larger map</small>
    The map opens in a new frame but does not show in the post – perhaps the size is wrong?

    #1504701

    Thanks. Could you show us the code that displays in your Text editor on your Edit Post page?

    If the shortcode conversion happened as it was supposed to (turning the ‘iframe’ code to a ‘googlemaps’ code), your code snippet should start with [googlemaps.

    #1504727

    <small>View Bradshaw, Day 6, Berkeley & Grosvenor Squares in a larger map</small>

    #1504729

    <small>View Bradshaw, Day 6, Berkeley & Grosvenor Squares in a larger map</small>

    #1504730

    The above is not displaying the full code; I will try to reply via email

    #1504732

    ‘<small>View Bradshaw, Day 6, Berkeley & Grosvenor Squares in a larger map</small>’

    #1504733

    `<small>View <a style=”color: #0000ff; text-align: left;” href=”https://www.google.co.uk/maps/ms?msa=0&msid=215027497458586671504.0004e9c93b80f96616070&ie=UTF8&t=m&ll=51.516414,-0.148668&spn=0.013231,0.016157&source=embed”>Bradshaw, Day 6, Berkeley & Grosvenor Squares</a> in a larger map</small>’

    #1504767

    Are you copying that from viewing your source code through a browser, or are you copying it from the edit field on your Edit Post page? (I need you to copy it from the Edit Post page.)

    #1504774

    I have got it right! I used the new Google maps, and followed the instructions as before for embedding. Previously I had been using Google maps in Classic view. This is the only procedure which was different. Thank you so much to everyone who pointed me in the right direction, and thank you for such speedy responses.

    #1504775

    Very glad to hear it. :)

    #1504811

    Urghh! Problem back with inserting Google maps. I inserted a map, then wanted to change it, deleted the map from the post and tried to reinsert a new map – no display, only a line saying ‘view in a larger map’, effectively a link to Google maps. What am I doing wrong?

    #1504812

    justpi
    Member

    Make sure you post the iframe code into the Text editor, not the Visual editor.

    #1504813

    I did indeed post into text editor view, not visual editor view

    #1504814

    justpi
    Member

    Link to the post or page in question please.

    #1504816

    I have created a new post and have the same problem: http://londondiaryblog.wordpress.com/2013/11/06/post-33a/

    #1504817

    justpi
    Member

    The code for this map doesn’t have the same elements as other Google maps I tried (including the one you have successfully inserted). My guess is that something in your customization produces a result that WP cannot recognize and convert.
    Well, if WP can’t do it, I can. Paste this into the Text editor:

    [googlemaps https://www.google.co.uk/maps/ms?msa=0&msid=215027497458586671504.0004ea1a65f4b961cae53&hl=en&ie=UTF8&t=m&source=embed&ll=51.515138,-0.12576&spn=0.002777,0.013409&output=embed&w=425&h=350]
    <a href="https://maps.google.com/maps?msa=0&msid=215027497458586671504.0004ea1a65f4b961cae53&hl=en&ie=UTF8&t=m&source=embed&ll=51.515138,-0.12576&spn=0.009254,0.019763&z=16" style="color:#0000FF;text-align:left">View Larger Map</a>

The topic ‘Map not displaying in post’ is closed to new replies.