Media upload issue on WordPress 3.4.2 with multisites.

  • Author
    Posts
  • #1024626

    Hello,

    When trying to upload media using either the flash or browser method messages informing me that the upload has failed are shown. These issue revolve around the permissions of /wp-content/blogs.dir/2/files/2012/09/. I have manually created this path and have given it the required permissions.

    I think this is likely an issue with my .htaccess but I’m not sure exactly where the issue lies.

    I have tried giving the www-data account, the root account and the sites FTP accounts access to this. Still no success.

    Although not particularly secure, I have also set all permissions to Read / Write. (777).

    .htaccess file shown below:
    RewriteEngine On
    RewriteBase /
    RewriteRule ^index\.php$ – [L]

    # uploaded files
    RewriteRule ^files/(.+) wp-includes/ms-files.php?file=$1 [L]

    RewriteCond %{REQUEST_FILENAME} -f [OR]
    RewriteCond %{REQUEST_FILENAME} -d
    RewriteRule ^ – [L]
    RewriteRule . index.php [L]

    There are no errors in the Apache access or error logs.

    Any suggestions? I’m under pressure to get this resolved quickly so any help would be really appreciated.

    The blog I need help with is www.digitaldarragh.com.

    #1024714

    supportbot
    Member

    The blog you specified at http://www.digitaldarragh.com does not appear to be hosted at WordPress.com.

    This support forum is for blogs hosted at WordPress.com. If your question is about a self-hosted WordPress blog then you’ll find help at the WordPress.org forums.

    If you don’t understand the difference between WordPress.com and WordPress.org, you may find this information helpful.

    If you forgot to include a link to your blog, you can reply and include it below. It’ll help people to answer your question.

    This is an automated message.

    #1024715

    timethief
    Member

    Your question is about a self-hosted WordPress.org blog and you’ll find help at the WordPress.org forums. http://wordpress.org/support/

The topic ‘Media upload issue on WordPress 3.4.2 with multisites.’ is closed to new replies.