Minor quote button annoyances

  • Author
    Posts
  • #1131483

    jongleason
    Member

    1. I paste a quote into my post (usually using plain text). I click on it, and then click the quote (“) button, and nothing happens. I click the ” button again, and it properly formats it as a quote (indented, italics).

    The first time this happened, I thought it was just me, doing something strange or not clicking when I thought I did, or something. The second through tenth time, I thought it was as well. It isn’t just me. It doesn’t happen every time, but it happens most of the time.

    I’m using Firefox 18.0.1. I just updated, it was happening on earlier versions, too. It’s been happening for quite a while.

    2. I frequently quote both poems and (especially) Scripture. I paste it in (plain text). I don’t want each verse of Scripture, or each line of the poem, to be a separate paragraph. So I use shift-return to format it, and then, since it is a quote, I hit the quote button. Beautiful, single-spaced poetry or Scripture in quote format.

    A few months back, when I hit the quote button (and it worked, see #1 above), I started getting a different behaviour. Instead of formatting the quote, it collapsed the line I was on with the next line (removing the single-space line feed/CR) without putting it in quote format at all. If I then clicked the quote button again, it would quote format it — but I’d have to reformat the poetry by using shift-return again.

    So basically, I now have to remember to put a poem in quote format before formatting it as a poem. If I forget, then putting it in quotes destroys all my poetry formatting, and I have to re-format it.

    Again, I can live with this by simply remembering to do it in that order, but it IS annoying when I forget, and it didn’t work this way previously.

    I could go back to using IE if it’s a Firefox issue, but my kids make fun of me when I use IE. Horrible, isn’t it? :)

    The blog I need help with is mindrenewers.com.

    #1131633

    1tess
    Moderator Emeritus

    Sounds like a bug. I’ll flag this for staff to take a look.

    #1131640

    jongleason
    Member

    Thank you.

    #1131693

    richardmtl
    Staff

    Hi Jon,

    Try as might, I can’t reproduce what you are describing, but I want to ask you a few questions to make sure I completely understand what you’re doing:

    1) “I paste a quote into my post (usually using plain text). I click on it, and then click the quote (“) button”

    Are you selecting all of the text that you want format as a quote, before clicking the quote button? Or are just placing your cursor in the text and then clicking the quote button? It might work better for you if you select/highlight all the text first.

    2) Do you switch back and forth between the Visual and Text modes?

    #1131694

    jongleason
    Member

    Hi, Richard, thanks.

    1) Just placing the cursor in the text. In the past (until a couple months ago) that always turned the whole paragraph into a quote. It still does on the second click. I’ll try what you suggest (though to be honest, one click in the text and two on the button is probably faster / easier than highlighting all the text).

    2) Almost never. I only go to text mode if I’m making a table or something, which is very rare. I’m generally html clueless, not a high-powered blogger at all. :)

    #1131712

    richardmtl
    Staff

    Hi again Jon, I’m positive that you’ll have better results by selecting the text that you want to turn into a quote. Try that for a bit, and let me know how it goes.

    #1131714

    jongleason
    Member

    Ok, Richard, thanks.

    #1131749

    richardmtl
    Staff

    Hi Jon,

    Just checking in, how has is been going for you with the quotes technique I explained? Let me know if you need anything else. :)

    #1131750

    jongleason
    Member

    Hi, Richard, thanks.

    I’m lazy, ok? :) So I really like just clicking into the quote and clicking the quote button, like I’d been doing, rather than having to select the whole text, and only the text, first. So I still do that a lot.

    But when I forget to do it before formatting, and I select the text, it works fine. So at least I don’t have to reformat the whole thing again. So, helpful.

    But yesterday, I forgot to turn it into a quote before formatting. I selected text, but not all of it, clicked the quote button, and instead of turning it all (or any of it) into a quote, it collapsed the formatting. Annoying.

    Stupid computer. I’m sure it knew what I wanted it to do. :)

    This is workable, Richard. It doesn’t let me be as lazy as I’d like, but I know now when I have to be careful, and how to handle it if I don’t turn it into a quote first. So, all good. I’ll mark it as resolved.

The topic ‘Minor quote button annoyances’ is closed to new replies.