Missing "Add Location" Button in Firefox on the Classic Editor

  • Author
    Posts
  • #2551039

    I accidentally clicked “Add Location” tonight on a post I was editing and now the “Add Location” button is gone while using Firefox.

    I tried using Chrome, and the button is still there.

    I don’t want to use it, but why is the button missing?

    The blog I need help with is dandelionsalad.wordpress.com.

    #2551122

    I’m having other difficulties tonight using the classic editor on Firefox.

    I recently restarted my computer, cleared cache, cleared cookies, and restarted Firefox.

    Chrome is working fine. So the problem(s) seems to be with Firefox.

    #2551123

    Nothing is working properly while using Firefox and the classic editor tonight.

    Can’t use Copy Post, can’t add a link, the scrolling isn’t working properly, can’t click the Text button.

    Something is going wrong with Firefox.

    #2551172

    Hello dandelionsalad!

    Could you, please, check if you’re using the Firefox last version? You can check the latest browser versions below:

    http://browsehappy.com/

    And you can see your browser version at:

    http://whatbrowser.org/

    #2551186

    carinapilar, thank you. I updated Firefox, restarted the computer and Firefox and still have these problems.

    #2551190

    timethief
    Member

    @carinapilar
    I tested this on a PC running Windows 10 and FF44 and I had no issues with adding a location.

    @dandelionsalad
    I was able to copy a post as well. Perhaps there are browser add-ons and/or extensions that are the cuplrits here. I would disable them all and see if that works.

    #2551191

    Thanks, Timethief, I will have to try to do that. Right now I can’t use Firefox for WP classic editor at all (lots of things are not working properly). Chrome works fine.

    #2551192

    timethief
    Member

    That’s strange because FF44 is working fine for me in the classic editor. Have you tried:
    disabling all browser add-ons and/or extensions?
    uninstalling Firefox and reinstalling it?

    P.S. I don’t run a lot of add-ons and extensions. I don’t indicate I don’t want to be tracked because that’s laughable. And, I never use private browsing.

    #2551193

    OK, everything is working fine again.

    Thanks for your help, Timethief. Now to add back some of Add-Ons that I still use.

    #2551194

    Everything else is working fine, but the “Add Location” button is still missing.

    I clicked on it once and then it disappeared forever.

    #2551218

    dandelionsalad, good to hear that everything else is back to normal.

    When you add a location on a post/page it will not show “Add Location” anymore, it shows the location you have selected. It will show the “Add Location” button again on a new post/page. I tested on Firefox 44 with Win 8.1 and it worked too.

    You can try to see if it’s showing any error on the Firefox console (pressing F12).

    #2551229

    carinapilar, I accidentally clicked the button when editing a post. I never set a location. A location is not showing up on the blog post either. The Add a Location button is missing from all new and other previously posted posts.

    I’m using Firefox 44, Win 7.

    On Chrome, the button shows up on all new posts, and previously posted ones, including the post when I did click it.

    I don’t use the button, so really no worries. I am just wondering why it disappeared?

    #2551230

    timethief
    Member

    @dandelionsalad
    Windows 7 is outdated and Windows 10 is a free upgrade. I upgraded 3 different PCs and have no issues at all. Why don’t you upgrade to Windows 10 because there is no such issue when using it?

    #2551238

    dandelionsalad, sorry, I tried a different couple things on Firefox, but wasn’t able to reproduce that behavior. I suggest you follow @timethief suggestion and upgrade your Windows to see if that fixes the issue.

    #2551240

    Thanks for trying, carinapilar. I don’t intend to upgrade to Win 10. I prefer Win 7 for many reasons.

    #2551242

    You’re welcome dandelionsalad! :)

    If you don’t mind, you can create a screencast showing the steps you do to reproduce the issue, then press F12 so we can see if there is any error on the Firefox console.

    #2551243

    There are no steps I take. The button flickers and goes missing when loading the page whether a New Post or an edit of a previous post. Like I said before I won’t be using the Add Location button, so no worries.

    Thanks again.

    #2551244

    dandelionsalad, okay, I’m going to test a few more things. Let us know if you find anything that can help to reproduce this situation. :)

    #2551245

    It is probably due to my cookies settings. Are there any particular cookies that are used for the Add Location button?

    #2551250

    dandelionsalad, is the Add Location feature working on the new layout? It will show under “More Options” when editing a post.

    That’s probably related with something blocking Javascript, could you, please, check if you’re using any script-blocking add-ons?

The topic ‘Missing "Add Location" Button in Firefox on the Classic Editor’ is closed to new replies.