Missing posts on my homepage

  • Author
    Posts
  • #848695

    carmenmccain
    Member

    For the past couple of days, I have been archiving on my blog articles from a column I write and I have been back-dating them to the dates that they were originally published. Tonight I updated the blog, and about 6 of the previous posts have disappeared from my home page. When I scroll down my home page, I will briefly see the post before the one I posted tonight, but after about 5 seconds it will disappear, and then it will appear that the post following the one I blogged tonight is one I wrote back in November. The 6 missing posts are still listed in the “Recent Posts” list, but you can’t see them on the home page. I have tried accessing the blog in chrome, firefox, and internet explorer and they are all having the same problem.

    So for example, tonight’s post is “The Darkness only Love Can Drive out.” That should be followed by “Duniya Juyi Juyi”, “STOP INTERNET CENSORSHIP”, “Cross of Crescents”, “Splitting a Nation”, “Unity or Hell”, “Christmas bombs in Madalla”, and then “Interview with Ghanaian-British filmmaker Julius Amedume”.
    However, what I’m seeing is “The Darkness only Love Can Drive out” and then “Interview with Julius Amedume” with all the rest gone.

    Does anyone know how to fix this?

    The blog I need help with is carmenmccain.wordpress.com.

    #848907

    carmenmccain
    Member
    #848912

    timethief
    Member

    I have been archiving on my blog articles from a column I write and I have been back-dating them to the dates that they were originally published.

    When we publish a post the software automatically places the post at the top of the main page for posts in our blog, and autmatically also places a copy in the Archives pages and in Categories and Tags pages in accord those we assigned to the post. We do nothing at all.

    If we start editing posts and changing datestamps we create broken links 404 (page not found) and that’s not a good thing to do. See > Avoid creating 404 pages

    #848972

    carmenmccain
    Member

    Hi, thanks for the tips, but I probably wasn’t clear enough in my initial post. I am not changing the time stamps for already published posts. I am publishing them initially as a previous date. When I click on links to the disappeared posts they show up fine. It is just when I scroll down my home page that the post below the current one, disappears. Before it disappears, I see a kind of graphic expanding circle, it disappears, and as you scroll down further, you see the post that should have been the 8th post, but is now the 2nd one. Not only have the new posts disappeared, but posts that have been there for the past two months have disappeared.

    #848974

    carmenmccain
    Member

    I’ve also noticed that after the posts disappear, there is a horizontal line between the first post and the 8th post. I have tried clicking on it and nothing happens.

    #848980

    timethief
    Member

    Before it disappears, I see a kind of graphic expanding circle, it disappears, and as you scroll down further…

    Aha! You are using Coraline and Staff have introduced “infinite scroll” to some themes including yours. They will be implementing it on all themes that have a suitable structure for infinite scroll. https://en.forums.wordpress.com/topic/to-infinity?replies=137

    As Coraline is a theme with footer widgets you can use a workaround to regain control over how many posts are displayed on the front page of your blog. If you have a theme with footer widgets all you need to do is install an empty text widget into any footer area for widgets. Once you have done that your number of posts set on the Settings > Reading page will prevail.

    Will you please try that?

    #848982

    carmenmccain
    Member

    timethief, thanks so much. Great advice. When I inserted “text” into the “fourth widget area” it stopped the infinite scroll thing. Now below the first post there is a little box that says “load more posts”, and I can see the formerly missing posts below that. Unfortunately, it has entirely destroyed the format of the blog–spreading the posts below my columns over the entire page, so that the photos are left hanging in the air. It also no longer shows 10 posts at a time. This is really distressing. I’ll have to figure out what to do to fix that problem now, but at least you can now see the posts.

    thanks for your help.

    #848983

    timethief
    Member

    I just looked at your blog and it has layout problems for sure. Will you please try this? Go to Settings > Writing and select “ ___ WordPress should correct invalidly nested XHTML automatically” and then scroll down and click “Save Changes.”

    Posts > All Posts, change all your latest posts to Draft, click Update, change them back to Published, click Update again. (You can edit all of them at once: tick the square in front of their titles then select Edit from the Bulk Actions dropdown and click Apply.)

    I have flagged this thread and it will be moved to the Themes Forum where Themes Staff will be able to assist you.

    #849002

    carmenmccain
    Member

    timethief, thank you so much! I followed your suggestions and it seems to have solved the problem–though the continuous scrolling does make my three column layout look a bit weird now. When I saved as a draft and republished the posts, they seemed to have corrected themselves.

    Thanks again.

    #849003

    timethief
    Member

    I just viwed you blog using Firefox 11 and I’m sad to say there is still an layout issue. I’m flagging this thread so Theme Staff can help with it.

    #849010

    carmenmccain
    Member

    ok, thank you.

The topic ‘Missing posts on my homepage’ is closed to new replies.