Missing tags

  • Author
    Posts
  • #2514150

    flowbeth
    Member

    Hello everyone!
    This morning I edited a draft and posted it, I added 14 tags and sorted the post into 1 category.
    I never use the preview option, I always just publish and view it on my full browser and then go back into the editor if I need to.
    What I noticed today was that when I went back to edit the post, I only had 7 tags on the post!
    I don’t duplicate my tags, I stick to the 15 tag/cat maximum and I try to make the most of that limit often using over 10 tags per post.
    I’ve seems a drop in stats lately and I out it down to the time of year and everyone busy but, when I checked a few other posts, I noticed that they’ve all got very few tags too! One I checked only had 3!
    Does anyone have any idea why this is happening or am I going to have to go back into every post and re-add more tags?
    Does this happen for a specific reason? Am I the only one or has anyone else noticed this?

    The blog I need help with is kaboodlemum.com.

    #2514223

    flowbeth
    Member

    Any ideas (adding a comment so I get emails when some one replies lol)

    #2514325

    kokkieh
    Staff

    Hi there,

    I’m not aware of any issue with disappearing tags. I checked your most recent published posts and except for the two with three and four posts, all have around 10/11 posts. Could it be that some of the multi-word tags were supposed to be separate tags? That could happen if you omitted a comma between them when adding your tags.

    Are you using the WP-Admin editor or the new editor when adding your tags? Can you check if the same thing happens if you use the other editor from your regular one?

    Lastly, if I may offer some advice regarding tag use: using fewer is actually better. The more relevant and targeted your tags are, the bigger the chance that people will find your posts when they search for tags. Shorter tags also tend to be searched more than multi-word tags. Our spam filters kick in if you use 15 or more tags and categories combined, but don’t try to use the maximum allowed for each post, as that can actually become counter-productive.

    #2514326

    adaklara
    Member

    I cannot add new tags in the new editor, only in the old one. There seems to be some problem with that.

    #2514327

    flowbeth
    Member

    hey @kokkieh I am using the new editor when posting. As requested I made a trial post in the classic Dash Editor and used 6 tags – http://kaboodlemum.com/2015/12/11/trial-post-missing-tags-new-editor/
    all tags stayed and remained on the post.

    I made a second post using the new editor and the exact same tags for it, upon posting it dropped 4 out of the 6 tags and turned the two remaining into hashtags – first time I’ve seen that happen. http://kaboodlemum.com/2015/12/11/trial-post-missing-tags-new-editor

    also, used relatively simple tags (blogging, writing, wordpress, new editor, old editor, missing tags)
    The reason there were more tags when you check my posts was because I edited the post after publishing it.
    Basically, on first publish, the new editor ‘loses’ the majority of the tags I have put in so I edit the post and re-add them again, the update keeps them.

    With regards to ‘less is more’ I find using as much as I can better, as I previously mentioned, I have noticed a difference in my viewing/visitor numbers, they’ve gone down and I think the reason is because most of my tags have been getting ‘lost’.
    When I publish a post about parenting and use the tag ‘parenting’ and the editor is losing that specific tag – I’m not appearing in my target audience readers.
    I think this is directly a result of the new editor and I am not the only person over the last few weeks to ask a question about missing tags.
    Oh and I use tags with more than one word quite frequently and find if I do, I tend to get better hits from search engines.

    Thanks for the reply. I hope this helps :)

    #2514336

    kokkieh
    Staff

    @flowbeth
    I have been trying to replicate this problem on a test site, but all my tags are there every time I publish. I tried it in both Firefox and Safari, and using your theme.

    The fact that I can’t reproduce it tells me it might be a problem specific to you, or rather, your browser. Can you try clearing your browser cache and cookies and see if this keeps happening? It could be that with our update of the editor a couple weeks ago some files from the previous version were left over in your browser and that might be causing this.

    You can find instructions how to clear your browser cache here:
    http://en.support.wordpress.com/browser-issues/

    Thank you for the test posts to help illustrate this, but you can delete them now.

    #2514337

    kokkieh
    Staff

    @adaklara
    Also please try clearing your browser cache and cookies. If that doesn’t work, please start a new thread and add “modlook” to the tags, and we’ll help you there:
    https://en.forums.wordpress.com/?new=1

    #2514338

    flowbeth
    Member

    @kokkieh
    I’m using Windows 10 browser ‘edge’ I’ve cleared my browser and it remains the same.

    #2514339

    flowbeth
    Member

    Also just posted using new editor via safari on iPad. (Full site editor not app) – same thing happened. It removed only two tags that time. It removed ‘writing’ and ‘missing tags’

    #2514340

    flowbeth
    Member

    Just posted another trial post from my iPad. Used 6 different tags and all stayed. If the problem was consistent maybe I’d understand a bit better but it’s not. It’s really quite frustrating.
    I’m assuming that there is no solution other than to edit any tags that get dropped back in after publishing.

    #2514360

    kokkieh
    Staff

    I’m assuming that there is no solution other than to edit any tags that get dropped back in after publishing.

    Until we’re able to figure out what’s causing this, that’s the only solution, yes. I will keep trying to reproduce the error on my side. Knowing it’s not browser or device-specific helps, so thanks for testing that.

    Can you please describe your workflow for me? In other words, do you add tags as you write a post, or do you write the post and then add all tags at the end?

    And have you happened to notice whether autosave takes place before you click Publish or not? (While writing a post, look above the Publish button. A few seconds after you stop typing it should say ‘Saving…’ and then ‘Saved’ when autosave completes.)

    Do you add tags by typing them in each time, or do you select them from the list of existing tags?

    Do you publish immediately or do you schedule posts?

    If I know how you work, I can duplicating your workflow to check if something you do might be triggering the error. If I can do that I can tell our developers that a certain action causes this, which will enable them to fix it.

    #2514362

    flowbeth
    Member

    okay, I write a whole post and then publish once done. I fill out the post and then I do the sidebar stuff so I categorise, add tags and all the other stuff then I publish. I work down the sidebar starting with the categories, then tags, then featured image, then sharing, then I will publish.

    if it were a case of the auto save not saving prior to posting then my featured image wouldn’t post either. But, since you asked, I did do a trial where I added the same 6 tags again and then pressed save instead of publish and it removed 4 of them again. I don’t think that is the issue.

    I then tried again with another set of 6 tags, ones that I would use on a day to day/post to post basis. I pressed save not publish and it removed them.

    I also type my tags in one by one each time, instead of selecting them from the list. When I tried making a post by selecting them from the list and pressing save instead of publish, they stayed.

    I’ve then done it again and added the same tags I selected from the list but written in one by one and its removed them again. 4 out of 6 leaving only 2 tags.

    I could go on from now using the list of tags but sometimes I write new ones that I haven’t used before. I’m concerned now that if I do they will get lost.
    Again, I could just edit them back in.

    I know that there is a solution just through selecting from the list and then editing in any that it drops. The thing is though, I shouldn’t have to. Since this new editor has landed, It’s been nothing but a nuisance. Its made my blogging experience much more difficult. It takes me twice as long to get a post written and published after having to sort out everything the editor has messed up. Its completely altered my perception of WordPress and ruined my blogging experience.

    Thanks for the help.

    Here’s another post also discussing this https://en.forums.wordpress.com/topic/tags-disappearing-on-new-posts?replies=6#post-2513814

    #2514363

    kokkieh
    Staff

    I completely agree with you that this shouldn’t happen.

    Thank you for the detailed information. Hopefully it will help us narrow down the cause of this.

    #2514382

    kokkieh
    Staff

    Just wanted to let you know that we’re still trying to find out what’s causing this. Thanks for your patience as we work on this.

    #2514386

    supernovia
    Staff

    I’m going to consolidate threads and move the conversation on over to other one so our info is in one place. Feel free to join in here:
    https://en.forums.wordpress.com/topic/tags-disappearing-on-new-posts

The topic ‘Missing tags’ is closed to new replies.