Mobile layout of stay theme

  • Author
    Posts
  • #1267943

    clairecard
    Member

    I am using the Stay theme and have set up the website and all looks good until I view it on my tablet then the main image is twice the width of the page so overhangs the rest of the page and doesn’t look great.

    The Stay theme is mobile compliant and the demo theme doesn’t do this so why does mine?

    Thanks

    The blog I need help with is arbredecerise.wordpress.com.

    #1268084

    timethief
    Member

    Stay is a responsive width theme.

    Responsive width means the layout adapts depending on the size of the device being used to view your site. When responsive width themes are viewed on mobiles sidebars appear below the posts in order to provide as much space as possible for reading.

    If you have enabled the mobile theme here > Appearance > Mobile then disable it.

    #1268096

    clairecard
    Member

    Thank you – I have changed the setting as you suggested but the main image is still significantly over-hanging the rest of the page when I view on the tablet. Any other ideas?

    #1268099

    justpi
    Member

    @clairecard:
    “the demo theme doesn’t do this so why does mine?”
    Because the demo doesn’t have a page like the one you created.
    Your page is a “Home” template page, with a featured image set to it. In contrast to the other templates, the featured image in the Home template doesn’t shrink, because it’s missing the max-width:100% rule. This needs to be fixed by WP.

    #1268100

    clairecard
    Member

    So there’s nothing I can do to change it?

    #1268101

    justpi
    Member

    You can insert the image in the content of the page instead of setting it as a featured image.

    #1268116

    clairecard
    Member

    Thank you so much – that works perfectly!

The topic ‘Mobile layout of stay theme’ is closed to new replies.