More problems with visual editor not working

  • Author
    Posts
  • #227653

    mgcardin
    Member

    I have read the FAQ entry as well as all of the forum discussions that talk about problems with the visual editor not working, and I’ve followed all of the suggestions and instructions, but on the two computers I use at my workplace the visual editor is still not working.

    On both computers I’m using Firefox 1.0.7 (I know, I know). The OS for both computers is Windows 98 (I know, I know). I have repeatedly cleared the browser cache, checked and unchecked the “use visual editor” option on the Users:Profile page, restarted both computers, and checked to see if there’s a problematic browser extension factoring into the mix (which isn’t the case). And yet the problem remains the same: on both of the computers I use at my workplace — which is a public school where all computers are on a LAN with a high speed Internet connection (I’m not sure exactly what type) — the visual editor spontaneously stopped working a little over a week ago.

    One interesting thing I have noticed is that when I’m on the “Write Post” page looking at all of the HTML code where the visual editor should be in action, the visual editor option still looks like it’s selected. But none of the formatting buttons appear. And if I click the html option, this makes the field for typing text completely disappear, after which there’s no response when I click the visual editor option. I have to navigate away from the page and then return in order to bring up the typing field again, at which point the same problem is in effect: no visual editor.

    FYI, at home I use Firefox (I forget which version but I think it’s newer than what I use at work) on two separate computers with Windows XP and have experienced no problems and no change in the visual editor experience.

    Any ideas?

    #227886

    raincoaster
    Member

    I think you should contact staff with this, as it seems to be very unusual. Give them all the details, and do it within the next hour, while they’re still open.

    #228196

    I’m having this same problem since yesterday — but I’m using FF 2.0.0.14. I’ve tested also Explorer 7, and it’s the same.

    I’ve tried resetting, clearing cache etc. Anyone else having this problem now?

    #228197

    jdrfwalk
    Member

    Yes, I am as well. I try to insert an image from my library and the pop up goes blank and gets stuck.

    #228198

    raincoaster
    Member

    Oh, that’s a different problem. TONS of people have that issue. Just upload the image, copy the URL of the image, and close the upload box. Insert it into the post via the Image Icon, the tree.

    #228199

    Just to clarify to anyone eles coming here, my issue is not the one mentioned by jdrfwalk and raincoaster, but exactly the one described by mgcardin. When I’m at the “Write post” page, the editor is locked in the HTML mode (although the visual editor option still looks like it’s selected).

    I’ve tried with the new FF 3, and still no go. Funnily, many people from Brazil are reporting the same issue:
    http://pt-br.forums.wordpress.com/topic.php?id=305&replies=21
    (I’ve tried changing the user interface in WP to english, but it’s also a no go.)

    #228200

    I’ve tried today with IE 6, and it works! The problem is still there in Firefox, however.

    #228201

    thyagomarcel
    Member

    What’s happened guys? I cannot use the visual editor and a lot of brazilian also got this problem. We’ve changed the language or something like that and no go!! What´s going on wordpress??

    #228202

    raincoaster
    Member
    #228203

    pek2008
    Member

    I blogging sometimes from Portugal, some others from Brasil, and I also have the same problem repported by miguelsvieira and mgcardin, as I started to explain in here:

    https://en.forums.wordpress.com/topic.php?id=30404&replies=1

    (Not having the problem mencioned by jdrfwalk.)
    It happens both in IE and Firefox. Tried empty cache+cookies+temporary files. The checkbox for the visual rich text editor is marked. Still can´t switch from HTML mode to VISUAL mode.

    Just like mgcardin, I also notice that when I’m on the “Write Post” page, what I actually see is the bar of the HTML mode, although the option that appears automatically selected
    is the VISUAL one. Even if I click to switch it nothing happens.

    Thanks, miguelsvieira for leading me to this threat and to raincoaster for the advice. Did your’s already been solved?

    #228204

    raincoaster
    Member

    Contact staff. They may have to fix this individually for each affected blog.

    #228206

    dylantarre
    Member

    Hey guys, I was having this same problem, I came across your post, no answers here. But I did find the solution here:
    http://blog.fryewiles.com/development/06-18-2008/wordpress-25-visual-editor-not-working-in-dreamhost-fix-it

    I don’t have dreamhost, but I was able to find where my php.ini was located and added this line at the end:

    zlib.output_compression = On

    Now all is working fine. Hopefully that works for you guys.

    #228207

    @dylan, that will only work for self-hosted blogs, not for those hosted here at wordpress.com.

    #228208

    sondan
    Member

    I have the same problems as well mgcardin so you are not alone.
    I was very glad to read your post because it let me know that I was not the only one with these problems that never seemed to be solved. Especially your third paragraph is “right on” in my experience. If you get any solutions would you please be so kind as to share them. Thank you so much.

    I sure hope that these bugs eventually get worked out.

    #228209

    tellyworth
    Staff

    A problem with the pt-br translation that caused the editor to break was fixed yesterday.

    #228212

    pek2008
    Member

    I confirm that the problem is solved and that everything is working fine, by now.

    https://en.forums.wordpress.com/topic.php?id=30404&replies=1

    To those who tried to help and to those who fixed it: THANK YOU very much!!!

    Maggie C.

    #228213

    katkmeanders
    Member

    It is still broken, and posts I make self-bork. I am using IE 6. Not only do posts self-bork, but while trying to edit a post, the “Edit” field will er…bounce up and down the page, and go from normal width to blowing the margins from one line to the next. Blocks of text will disappear (or the whole post) change color in part or whole, or migrate to the very end of the post for no apparent reason. Hard returns mysteriously insert themselves, several in a row, with no rhyme or reason. Saving only makes things worse, because saving seems to cause random “borkings” to occur. See my recent “My Replies to Daisy’s Queries” post for a good example. (My blog is linked in my profile.) That’s as good as I can get it, I don’t dare try to fix it anymore. That’s after *NUMEROUS* copies and pastes from a rich text document, then saving and finding the post borked itself. Should I contact support to see if they can individually fix my blog?

    #228214

    katkmeanders
    Member

    Adding, and yet, I managed to make a new post, (with no copying and pasting) and so far it isn’t borked. Is it just if you copy and paste? Why? *puzzled* Again, I am (still) using IE6. (Will use IE7, once it works for me, or Firefox or another browser once me and the Mr. can agree on which one.)

The topic ‘More problems with visual editor not working’ is closed to new replies.