Mozilla vs WordPress

  • Author
    Posts
  • #2787645

    I am going to repost a post I made on a different WP forum yesterday. I could not actually access this particular page in Mozilla, but strangely I can in IE.

    This is a little completed and confusing so please bear with me.

    My post from yesterday:

    I am having an issue on all my WP blogs. This is difficult to explain but I will do my best.

    Apparently, when the Desktop Ap has an update, pages become inaccessible in a browser. I say that because when the latest desktop ap for PCs was released I could not access any pages beyond the ‘exterior’ of my blog. e.g. Reader, Stats, New Posts…

    I noticed something yesterday when I was in the middle of making a post. I was trying to update an old post in one tab and make a new post in the other, strangely the tab in which I was trying to update a post, the screen was a huge blank except for a large WordPress icon.

    I didn’t give it much thought because I was able to make the new post and didn’t post much else yesterday. However, I had to update the old post by going in as WP Admin/Dashboard/Posts/Edit.

    Today, in my browser, which is up-to-date, as like then the new Desktop Ap for PCs was released, I cannot access any pages other than my dashboard. That is to say I cannot open the Reader, Stats, or make a New Post from the links on my blogs front page, they all lead to a blank page with a large WP logo.

    I tried to open the desktop ap, it was actually a little stubborn but finally opened and viola–there was a new update! I wasn’t too surprised, and like when I first installed it, figured the browser view would return to normal if I installed it, so I did.

    I was wrong, the browser view didn’t return to normal and I am still pulling up blank pages from the aforementioned links wiht a huge WP logo in the middle. However, this time, in the address bar, there is a distinct address inserted before my blogs address that reads:

    ‘WordPress.com (Automatic Inc) (US)’

    I do not understand.

    I have disabled and enabled add-ons, dumped my cache, everything that I know what to do, and the Reader, Stats, New Post, and who knows what other links on my blogs front page keep returning me to a blank page except for a large WP logo.

    What gives?

    Any help or explanation would be helpful, in fact, I had to take the long way around to get to this page that when I was at https://en.support.wordpress.com/ and clicked the ‘help’ link beneath the avatars–I got the same blank page with the WP logo.

    So yeah, what gives?

    Thank you.

    You can find that post in this forum:

    https://en.forums.wordpress.com/topic/desktop-apbrowser-using-browser-returns-locked-pages?replies=1#post-2785273

    That said, I also made a somewhat similar post in the Mozilla forum:

    https://support.mozilla.org/en-US/questions/1146077#answer-933894

    There is a screenshot there of the view I keep getting

    when trying to access the Reader, Stats, New Post as well as this page and who knows what else from the front page of all three of my WP blogs.

    Believe me when I say I have done all that I know how to do without doing a fresh re-install of Mozilla, which I assure you s up-to-date. That I am able to access the pages properly in IE makes me want to blame Mozilla.

    However, when I consider how & when it occurred as compared to the first release of the pc desktop ap, in which I could not access the Reader without first installing the ap, makes me wonder & want to blame WP because I have had conflicts before between Mozilla & WP.

    I do not understand why I had to install the ap to begin with in order to access the Reader. That is not the fault of my browser but the fault of WP, in the sense that there seems to be some conflict somewhere whether it is with the ap, with WP or with Mozilla.

    Since this seemed to occur the same time the desktop ap ‘needed’ updating, I am wondering if I shouldn’t just un-install the ap and see what is and isn’t accessible. However, this doesn’t explain why it all works in IE.

    I don’t really want to do a fresh re-install of Mozilla unless I absolutely have to, because I am not completely sure the problem is with the browser. It may be. But I am very partial to Mozilla because I am visually handicapped, that said, I think the sktop ap is cool, but it is typically inaccessible to me because of my disability which is why I prefer using my browser, which unlike Chrome, takes my system colors.

    IE I simply hate, but will use it if necessary, like I am now.

    So if after reading all this, and please, taking a look at the screenshot on the Mozilla forum, has any ideas, I could really use some help here.

    Thank you.

    The blog I need help with is thevaleofsoulmaking.wordpress.com.

    #2787744

    kokkieh
    Staff

    Hi there,

    I assure you there is no way an update on the desktop app can influence the browser interface in any way. The two are not connected in that way. I also use the desktop app and Firefox daily and have not encountered this issue in the way you’re describing.

    The issue with only the WordPress logo loading happens when your browser is unable to load some of the code that runs the site. The problem can be with either your browser or your connection.

    To check on the connection, please try unplugging your modem/router for a few seconds to reset it. If possible, also see if you can load the site with a different connection, like public wifi at a library or coffee shop.

    I see you already tried with your browser in safe mode, which rules out any browser extensions being the cause, but the other problem can be if JavaScript is disabled in your browser. To check that, please visit this page in Firefox:

    http://enable-javascript.com/

    If that page tells you JavaScript is disabled, please follow the instructions there to enable it. Then clear the browser cache and cookies and try loading WordPress.com again.

    #2787751

    Well I relly don’t feel that it’s my connection.

    Your comment about the Java resonates with me, though I have only noticed the issue with WordPress and not on any other site.

    Consequently, I did go into the configuration, and in truth, the Java command was missing. So I then went into my plug ins and apparently the Java was off or corrupted. It highlighted and had an exclamation point in the line.

    Of course, I then went to Java and installed the latest version and confirmed that it was up-to-date, showing as enabled in the configuration as well as showing properly in my plug-ins.

    I then dumped my cache, closed and rebooted my browser and tried to view the Reader page in my blog.

    I am still getting the same view.

    Mind you–I did not clear my cookies. Do i absolutely have to clear my cookies even though I have dumped my cache?

    If I dump my cookies and get the same view then what?

    I will let you know how it goes.

    Thank you.

    #2787752

    kokkieh
    Staff

    Java is not the same thing as JavaScript. Java is an application that you install on your computer which is required by some other programs and websites in order to work.

    JavaScript is a web programming language, and is what the WordPress.com site is built with. JavaScript is not something you install. It is built into all popular web browser by default, and Firefox is fully compliant with the latest JavaScript standards. But it’s possible to disable JavaScript in your browser, in which case no website built with JavaScript will work.

    Please follow the instructions on this site to ensure JavaScript is enabled in your browser:

    http://enable-javascript.com/

    Well I relly don’t feel that it’s my connection.

    Mind you–I did not clear my cookies.

    The reason I suggested those steps is because in my experience one of them fixes this issue every single time. But I cannot force you to try those steps if you don’t want to.

    #2787756

    Follow me on this, because I visually handicapped and don’t see very well. For whatever reason, I followed your initial instructions exactly, even cleared my cookies, and for whatever reason, the page still views incorrectly. Okay.

    I cleared the cache again, even dumped my cookies and rebooted my machine. Still having the same issue. So I go back into my plugins and look a little closer, mind you I don’t see well, and this is what it says above the only Java plug in i have:

    ‘Java Deployment Toolkit 8.0.1110.14 is known to be vulnerable. Use with caution.”

    Accordingly, Mozilla won’t let me activate it.

    However, I do find this a bit strange. I keep things very up-to-date, not that that is any real concern with Mozilla sometimes, but I have yet, as near as I can tell, had an issue with any other site but WP.

    Which I suppose is par.

    I’m at a complete lose right now. I don’t want to back step the program, that seems almost as foolish as using, what Mozilla considers–a vulnerability. All the options to activate it have been grayed out.

    I did post this on the Mozilla forum, we’ll see how they respond.

    Oh, and thank you for your attention & help.

    I will let you know if I get the issue resolved. Thank you again, and thank you for the information. Between WP & Mozilla I’m getting a wealth of troubleshooting knowledge.

    #2787759

    I do not know what I did or didn’t do, but for some reason the page started loading properly. As per the responses on Mozilla, I’m a little confused as to the plug in, which still shows as disabled, as compared to, I guess, ‘javascript.,’ because I really did nothing except, perhaps, go to the Java site, download and overwrite the current version.

    All the same, it’s been a learning expeirence, I simply wish I knew what exactly it was that I did because the pages load normally now.

    I will say, however, I have experienced conflicts with WP & Mozilla before, and perhaps this has just been another such experience.

    All the same, thank you for the information and hopefully the issue is resolved, for now.

    However, it might be nice to be able to upload a screenshot to the forum itself. If I can, then I’m not seeing it, but it would have made things a little easier, particularly when, in theory, I could not upload a screenshot to my own blog.

    Food for thought.

    #2787771

    kokkieh
    Staff

    I’m a little confused as to the plug in, which still shows as disabled, as compared to, I guess, ‘javascript.,’ because I really did nothing except, perhaps, go to the Java site, download and overwrite the current version.

    Java and JavaScript really are two different things, and we don’t use Java on WordPress.com, but it could be that in the process you changed another setting which sorted things out. But I’m glad it’s working now.

    I will say, however, I have experienced conflicts with WP & Mozilla before, and perhaps this has just been another such experience.

    I also use Firefox, and have used it for as long as I’ve been on WordPress.com without any issues, so this is somewhat surprising :) If you run into any other issues, please let us know.

    However, it might be nice to be able to upload a screenshot to the forum itself.

    It would be nice, but our forum software was not designed with that option in mind, unfortunately. But in future, you can upload your screen shot to a service like snag.gy or cloudup.com and share the link here, or even upload directly to your media library where any member of WordPress.com staff will be able to see it.

    #2787774

    Thank you.

    All i really did was download and overwrite my version of Java, that was apparently enough, mind you, I could not even find it in about:config until I did that.

    I’ve used Firefox since Netscape. I don’t much care for IE, I don’t trust it anymore than I trust Hillary Clinton, and Chorme, for me, is doggy. I only really had one other conflict, the browser wasn’t displaying some characters properly, but at the time I had that issue with several sites, not just WP. It was so long ago I forget now how we fixed it.

    Thank you for the link. I will definitely keep that around if I ever need it in the future. I used to a couple of upload sites like that, though I let them go over time.

    You guys have come a long way since when I first started blogging here. I wouldn’t go anywhere else.

    #2787776

    kokkieh
    Staff

    You guys have come a long way since when I first started blogging here. I wouldn’t go anywhere else.

    That is good to hear :D

    Please let me know if I can help with anything else.

The topic ‘Mozilla vs WordPress’ is closed to new replies.