Multiline text in LaTeX

  • Author
    Posts
  • #3045502

    I am trying to insert multiline text using LaTeX into my WordPress blog, but I can’t figure it out. When I try to write a long sentence using the latex \text{} command, instead of going on to the next line, the text shrinks to fit it into one line. I’ve tried various things, but I can’t get it to go to the next line and retain font size. As a sort of temporary fix, I’ve just separated my text into multiple \text{} blocks, which always start on the next line, but this is not a solution and does not show up well on mobile devices. Would appreciate any assistance.

    Ex: $latex \textbf{Definition. }  \text{A}  \textbf{ Sample Space } \Omega \text{ of an experiment is the set of all possible outcomes}$ $latex \text{of that experiment.}$ $latex \text{Ex: For a dice roll, } \Omega \text{ = \{1, 2, 3, 4, 5, 6\}; For a coin toss, } \Omega \text{ = \{H, T\}}$

    The blog I need help with is sidrastogi.wordpress.com.

    #3045625

    Hi –

    Are you adding the LaTeX through the text editor or the visual editor? Is it happening in a browser or app?

    Our LaTeX support guide is available at https://en.support.wordpress.com/latex/

    And more resources for troubleshooting: https://www.latex-project.org/help/documentation/

    #3045627

    I’m using the visual editor in a browser (Google Chrome). I looked at the support guide and documentation, but couldn’t figure out this problem.

    #3045831

    I’ll be happy to take a closer look. Which post are you working on now?

    #3045832

    I suspect switching to the text editor will help.

    #3045847

    Please look at Probability Theory 1. The issue becomes apparent when viewing on a mobile device.

    #3045848

    Also, I tried the Text editor but I don’t think that helped.

    #3045849

    Ok. Which mobile device are you using and browser type? Could you take a screen shot for me?

    #3045850

    I’m on an iPhone and I have used multiple browsers (Chrome, Safari, the WordPress app, etc.). I do not believe this issue has to do with the device/browser, I am just not sure how to ensure that LaTeX text goes onto the next line without it shrinking. As a fix, I just separate it into multiple LaTeX blocks, as I showed in the original post, but it does not show up the same size on mobile devices and it is not a real fix. I am looking for a way to get the multi line text in LaTeX. I can’t post a screenshot on here.

    #3045872

    I want to try and replicate your experience so that I can learn whether or not this is a bug. Do you mind telling me what device you are using and adding a screen shot to your media folder for me?

    #3045875

    I apologize if I was being unclear. This is not a bug, I am simply looking for a way to type multi-line text in LaTeX. The program is performing as normal. In any case, I have added a screen shot to my media folder. I am using an iPhone 6S, but as I mentioned this is not a bug, I’m just looking for information.

    #3045876

    To replicate my experience, you should try typing “A sample space is the set of all possible outcomes of an experiment.” using the LaTeX \text command as follows:

    $latex \text{A sample space is the set of all possible outcomes of an experiment.} $

    You will see that the text shrinks rather than go to the next line. This is the problem I am trying to figure out.

    #3045914

    Hi, sorry to bug you, but have you been able to figure out a solution? Would appreciate if you could let me know as soon as possible. Thanks.

    #3045920

    Hi –

    I am able to reproduce your experience with those instructions. This is not how it should appear on mobile. The mobile and desktop views should replicate the same formatting of the LaTeX. I’ve reported this internally, but for now I do not have a work around to adjust that line spacing.

    #3045921

    The issue is not just on mobile, it is also on desktop. I just pointed you to the mobile version because it’s more easily visible. Please let them know that the issue applies to desktop as well.

    #3045922

    No problem :)

The topic ‘Multiline text in LaTeX’ is closed to new replies.