Need help? Check out our Support site, then

Mustisite: Error in connecting other blogs than main blog to

  1. Hi,

    I am building a mulstisite network with subdirectories. I have installed Akismet and Jetpack network-wide. I have set a gloabl API key in my config file define('WPCOM_API_KEY','myAPI');

    Akismet works fine in all blogs.
    My main blog connects succesfully to
    In all other blogs, when trying to connect to I get the error:

    Invalid request, please go back and try again.
    Error Code: invalid_request
    Error Message: Mismatch in redirect_uri.

    Can you please tell me what is wrong?

    In addition, is it possible to use the same account gloabally for all blogs to connect to Stats, similar to Akismet?

    Thank you
    Blog url:

  2. Could you try and disable all other plugins and reactivate Jetpack. This way we can see if other plugins interfere with Jetpack.

    Also make sure you are running the latest WordPress and Jetpack version:

    Looking forward to your reply.

  3. Hi, I have already tried that, but with no success. I am running WP 3.3.2 and Jetpack 1.2.4

  4. Could you please try to revert the theme to its default (e.g Twenty Eleven theme) en reactivate Jetpack to see if that helps.

    Otherwise try installing the Jetpack Compatibility Plugin so we can see some additional information from your site.

    1) Download the plugin from
    2) Upload the plugin to your site via Dashboard -> Plugins -> Add New.
    3) Activate the plugin and go to Plugins -> Jetpack Compatibility Test.
    4) Click the "Select All" button.
    5) Send the results of the test back in a reply.

  5. [Edited by mdawaffe: Thanks these specific tests check out fine, so the problem must be something other than what we first expected]

  6. "Mismatch in redirect_uri" is a very odd error message. You should win a prize :)

    Could you please try reconnecting one of the non-main-blog sites again? We have added some debugging on our side that may help determine the problem.

    Sorry for the hassle, but thanks for the help.

  7. I just did try to reconnect from a non-main blog site. I did that as a super admin.

    I am dreaming of the prize...

  8. And you got the same error again? Interesting: it didn't show up in our debugging.

    Could you try once more please?

    Also, could you please paste the full URL of that error message here?

  9. Just did again.

    [Edited by mdawaffe: Thanks for the URL]

  10. Thanks. If you go to that sites Settings → General, what are the values for the following two settings?

    WordPress Address (URL)
    Site Address (URL)

  11. Oh - sorry, I forgot that's not where those settings exist in MultiSite. Let me figure out a better question :)

  12. Please:

    1. Go to your Network Admin → Sites
    2. Look up the site you just tried to connect
    3. Click the "Edit" link for that site (you'll have to hover over that site's row to make the edit link appear)
    4. Click the "Settings" Tab
    5. Find the "Siteurl" and "Home" values in the big table and paste them here.

    Thanks for your perseverance.

  13. It is a network with subdomains. The specific site is

    I have only seen these settings in a single site installation, correct?

  14. Is this URL familiar to you?

    For some reason, your site is sending the "client_id" for, which is confusing Jetpack.

    Have you every copied any database tables or WordPress options from prueba to ktimamavrika?

    Have you ever installed the old Stats plugin on any of these sites?

  15. I have my main blog:,

    a template blog which is not visible:,

    and three other blogs created on the following order based on the template blog:

    I have not copied any tables of prueba to ktimamavrika. But both blogs, as all blogs of the network, are created based on the template blog with the NewBlogTemplate plugin , which I guess is copying tables from the template blog to the new blogs.

    Both Akismet and Jetpack are network activated. As stated above, I am using the define('WPCOM_API_KEY','myAPI'); in order to have a common API for all blogs of the network and it works fine for Akismet.
    In main blog, I have connected to succesfully in order to have the stats. When trying to connect from my other blogs, I get the error.

    P.S. It is too late for me now, I will continue tommorow, OK?

  16. On the site, try deleting all the options that start with "jetpack_".


    (Some of those may not exist on your site.)

    After deleting those options, try again to connect that site.

    If you don't have access to that site's database tables, or are unsure how to delete those options, let us know and we can help.

  17. If I understood well, I did a

    SELECT *
    FROM agragorwp_47_options
    WHERE option_name LIKE '%jetpack%'

    and the result was 3 rows. I export it and this is the corresponding insert statement for these rows:

    INSERT INTO agragorwp_47_options (option_id, blog_id, option_name, option_value, autoload) VALUES
    (244, 0, 'jetpack_activated', '4', 'yes'),
    (245, 0, 'jetpack_options', 'a:6:{s:7:"version";s:16:"1.2.2:1332752949";s:11:"old_version";s:16:"1.2.2:1332752949";s:2:"id";i:34576810;s:28:"fallback_no_verify_ssl_certs";i:0;s:9:"time_diff";i:107;s:10:"blog_token";s:65:"Pr!LCw!u04HCBtGKs^kXNkLf#Sz(QZAZ.ZNTXXGV1$VLzhvVkdg%U5Iu^Vxbx$m7j";}', 'yes'),
    (254, 0, 'jetpack_active_modules', 'a:11:{i:0;s:10:"vaultpress";i:1;s:5:"stats";i:3;s:13:"subscriptions";i:5;s:21:"enhanced-distribution";i:7;s:10:"shortlinks";i:9;s:19:"gravatar-hovercards";i:11;s:7:"widgets";i:13;s:18:"after-the-deadline";i:15;s:10:"shortcodes";i:17;s:10:"sharedaddy";i:19;s:5:"latex";}', 'yes');

    Do you want me to delete these 3 rows?

  18. Yes, please.

    Delete those three rows, then try connecting that site again.

  19. It is connected succesfully. Of course, if I try with another site of the network I get the same error.

  20. I believe the NewBlogTemplate plugin copied Jetpack settings from one site to another.

    Jetpack should handle this error case better than it currently does, but its settings are site-specific so can't be copied from one site to another.

    I believe if you delete those "jetpack_" settings from the other sites as well, you will be able to connect each of the successfully.

  21. So, I cannot have WP Stats for all my sites with the same connection, as I have Akismet with the define('WPCOM_API_KEY','myAPI'); ?

  22. This is a known limitation of the current Jetpack plugin: Jetpack needs to be authorized/connected to individually for each site in your network.

  23. I hope there are plans to support a network-wide approach. For the time being, I will not activate in my whole network Jetpack, but only in my main site.

    Thank you for your time and effort!

  24. Apologies for the frustration. Thanks for the feedback and for letting us know how your site is set up. It'll help us make Jetpack better.

Topic Closed

This topic has been closed to new replies.

About this Topic


No tags yet.