Need help? Check out our Support site, then

MX record

  1. Hi

    I had e-mail working for the domain below on another server (a.b.c.d)
    as well as web redirection.
    I however just changed my settings to map the domain to, and adjusted MX records to point to a.b.c.d

    I no longer can receive e-mails. I would have thought this should be a seamless migration.
    Note: e-mails sent from the a.b.c.d mail server, from another domain, are sent with no problem. So it seems that the emails which fail are the one who are redirected via wordpress Name servers.

    I have set up my MX record as follows:
    A mail a.b.c.d
    MX 10

    Thank you in advance for your help!

    The blog I need help with is

  2. Sorry I meant I set it up as follows

    MX 10

  3. Hi!

    I did a quick check and it looks like there are a couple of problems with your domain. DNS servers are not yet responding to queries on this domain, and there are also no MX servers being found. Maybe things are not setup properly with your registrar?

    You can use the following link to see how the internet sees your domain name DNS entries:

  4. @iamdiogo
    Thanks for your reply.
    I jsut checked your link and indeed it states that :
    Nameserver records returned by the parent servers are: [''] (NO GLUE) [TTL=172800] [''] (NO GLUE) [TTL=172800]

    So this means the registrar is set up properly, returning wordpress name servers....Correct?


  5. Also, looking further down the report:
    Error Mismatched NS records WARNING: One or more of your nameservers did not return any of your NS records.
    Error DNS servers responded ERROR: One or more of your nameservers did not respond:
    The ones that did not respond are:

    It looks like wordpress Nameservers are not responding. Could it just be a delay between configuration and actual configuration on those name servers? Does wordpress apply the config straightaway on the DNS or does it do it in baches every so frequently?

    Thank you!

  6. Hi! Yes, You're right.

    It's the WordPress servers that are not responding. I would guess that the changes are applied shortly after you request them, but it might take a little while to propagate properly.


  7. Anyone know how long it takes before WordPress name servers are updated? I have lost access to my website and emails.


  8. I did a domain check on wordpress support and I get this:

    Invalid Nameservers

    Your domain is set up with the following name servers or their numeric equivalents:

    In order for your domain name to work at, you should remove the above nameservers and add only the ones listed below.

    I am puzzled....the lsit is empty...and the recommended DNS ARE the one I set up and shows in this
    I raised a support ticket for this too...i am just hoping for a quick resolution as I have lost my website and email...


    I have flagged this to staff as i think this is an issue with DNS on WordPress.


  10. Your "staff" tag will not help - that is used for internal communications and tends to irritate the staff and the people that use that tag are not the ones that can help you

    I have flagged this for the staff to help

    Domain Helper shows no Domain Mapping in place for - but your site does load and does not seem to be a mask and forward

    Whats my DNS show no name servers currently: which should crash your site

  11. @auxclass.
    I am new to this so sorry if I have misused the Staff tag.
    How do you "flag to staff" ?

    I see two issues:
    1) Ok, propagation not complete, fair enough, it will take time.
    2) the most important: even when the right DNS are found, they do not respond :

    Am I missing something here?


  12. "modlook" gets moderators and staff / Happiness Engineers - I found out about the 'staff" tag issue when I flagged a few threads with that - since I help a lot in the forum (unpaid) - I got some special attention and an explanation of the confusion the staff tag causes

    You might need a zone record added to make things work - the staff can do that - I tried and the system would not accept my entry - the staff can also look at your account and settings I can't -

    some of what I saw was confusing so I posted what I found to help the staff get started -

    The staff do have a good record of making things work - so keep the faith

  13. @auxclass
    Many thanks! I am impressed by your help :-)

  14. You be welcome & good luck

  15. Hi. There has been no progress on this at all for 12 hours+!.

    I had a ste up and running as well as email. I have been advertising it. Since I have paid for the mapping upgrade nothing works.

    WORDPRESS staff: HELP please

  16. The staff work the requests from the oldest to newest - so this is a time for patience - The staff are having a company wide meetup to plan the direction of WordPress for the next few months out into the several year plan, so they are not working the forum quite as often as they normally do

  17. @auxclass
    I am new to this....are we talking hours? Days?

    Am tempted to reverse my Dns setting to point to my old server to get it to work while this gets fixed. One I am confident the config was done on wordpress - how for sure? - then Ireverse back....

    Good idea?....

  18. TWO days later....still no sign of support. I know Patience is key here, but I wonder how long should I wait? I am for sure loosing credibility and possibly business, as I have been advertising this site a lot recently.

    I am tempted to reverse back but not sure if it is a wise decision....if WordPress support fixes that today then it is Ok, but if this will remain as it for another few days, not OK!

    Any idea how long it can take?


  19. Hello there,

    Sorry about the delay. Setting an MX record may take up to 72 hours to start working. Please verify with your domain registrar that the following MX records are correct:

    A mail
    MX 10

    If these records are correct and you're still having problems please let us know.

  20. @bdukes
    Thank you for your reply. In fact I have closed this topic because I fixed the issue by deleting the old domain mapping and recreating it.

    The initial mapping was incorrect, using I set it up for (without www) and it is now working all fine!


  21. Glad yo got everything working! Let us know if you need anything else :)

Topic Closed

This topic has been closed to new replies.

About this Topic