My blog doesn’t appear?

  • Author
    Posts
  • #48856

    like the title, my blog doesn’t appear in search engine like google, what’s wrong? i already set my blog to be visible. please help.

    #49027

    sulz
    Member

    if your blog is newly set up you have to wait a few weeks before your blog appears in search engines.

    #49041

    timethief
    Member

    Like sulz says there is a delay – usually a 4-6 week delay from what I can tell. There are some things you can do to get search engine attention listed in this thread http://wordpress.com/forums/topic.php?id=5859&replies=9#post-37917
    Also you can “claim” your blog at Technorati. And if your want tips on blog promotion look here http://pimpmyblog.wordpress.com
    Happy Blogging :)

    #49061

    drmike
    Member

    May also have to do with your blog not having any content. You haven’t made a single post yet. There’s nothing for the search engine spiders to index.

    You may want to double check your settings. I’m showing that you haven’t set it to visable:


    <meta name='robots' content='noindex,nofollow' />

    Hope this helps,
    -drmike

    #49075

    i think i already set it to visable. maybe i just have to wait. thanks.

    #49077

    drmike
    Member

    Shouldn’t be any wait for the visability options. Those go live upon selection.

    Please double check Dashboard -> Options -> Privacy and make sure the top selection is the one that’s marked.

    /me waves at another Charlotte, NC person. :) (I get to see the poster’s Ip address when I’m logged in)

    #49079

    yes, i already chose this option, “I would like my blog to appear in search engines like Google and Sphere, and in public listings around WordPress.com.”. that’s all i have to do rite?

    #49080

    drmike
    Member

    Yup, looks good now. You just need some content now. :)

    Good luck,
    -drmike

    #49136

    nosysnoop
    Member

    My blog got listed in about a week after I came here from Blogger. But a ProBoards site of mine still isn’t listed after months of trying *confused*

    #49167

    drmike
    Member

    Something’s up with Proboards getting scanned by teh spiders. One of the Kim Possible boards I visit went months with just getting the front page listed as well. having everything run off of a cgi script probably doesn’t help either over there. Also when they move you to another server and do the redirect to the front page probably doesn’t help either.

    You also have to remember that the first thing the spiders see is inbound links. With about two hours of work, I can change about 105k inbound links to a new site. :)

The topic ‘My blog doesn’t appear?’ is closed to new replies.