My blogroll disappeared

  • Author
  • #724646

    I am new to WordPress, and started my blog here a few weeks ago. I added the “Links” widget to my sidebars, and added some links. It appeared on the blog’s page for a short time (maybe an hour.)

    When I tried to change the name/title of the blogroll, the blogroll just disappeared. I have not been able to get it back. I’ve tried the following:

    Deleting the links widget from my sidebar
    Deleting the links themselves from the links widget
    Logging out of WordPress and back in.

    I am frustrated, because I’d love to support other blogs on my own blog. Please help! Thanks very much!

    The blog I need help with is


    I should add, I deleted the links and links widget, and then I logged out of WordPress, logged back in, and re-inserted the links and the links widget.



    Well, does it keep disappearing?

    Making one single change for the first time to your sidebar deletes all the widgets in it. There’s a message to that effect on the widgets page the first time you use it. Thereafter, it disappears. Is that what happened here, perhaps?


    At the moment the Links widget has not been added to your sidebar. And your description is confusing, because you can’t “change the name/title” of the widget or “delete the links themselves from the links widget”. Links are added in Links > Add New (in you dashboard sidebar) and edited or deleted in Links > All Links.

    So first go Links > All Links and make sure your blogroll links are there, that each one is assigned a link Category, and that is says Yes under Visible. If they’re not there, go to Links > Add New and create them. Then go to Appearance > Widgets and drag the Links widget to Sidebar, select “All Links” from the first pulldown if it isn’t already selected, Save. The category/categories you have assigned to your links will automatically become the title/titles of the blogroll in your sidebar.

    If you find you can’t drag the Links widget to Sidebar, click Screen Options (top right) and click Enable accessibility mode.


    Apologies for the confusing description. According to my dashboard, the “Links” was in my “Sidebar 1.” The problem was I didn’t realize I needed to create a category name for the links, and then click that the links were part of that category. I sort of had ignored the “category” part because, clearly, I am new at this. :)

    It’s there, now – thanks very much for your detailed guidance everyone!

The topic ‘My blogroll disappeared’ is closed to new replies.