My buttons have dissapeard since editing my CSS

  • Author
    Posts
  • #939672

    I was editing my genesis magazine theme, so that I could include a larger image in my header. So I copied all the original CSS data and copy and pasted it into the editor. I then modified the depth for the header image and it worked….the only problem is that the search button and subscribe button from the widgets don’t seems to appear anymore. I tried looking for “button.png” file in my media library, but cant find it anywhere. please help?

    The blog I need help with is thebioscopist.com.

    #939778

    timethief
    Member

    So I copied all the original CSS data and copy and pasted it into the editor…

    I don’t help with CSS but I do know when you alter a theme‚Äôs stylesheet, you only need to put in the Editor the modification/additions to the CSS, not the entire thing.

    #939779

    cheers, i’ll give it a go

    #939783

    okay, i have a bit of a problem…I cant go restore back to the original theme. Does anyone know how to do that?

    #939788

    johnconners
    Member

    In the Custom Design > CSS tab just clear out the contents of the edit view, then ensure you’ve selected ‘Add my CSS to XXX’s CSS stylesheet.’, click ‘Save Stylesheet’.

    FYI, your problem above was that the images were referenced in the stylesheet like so:

    images/red/button.png

    So you’d need to replace them all with:

    Basically putting the full URL to the various images. However as timethief above says, you only need to enter the styles you want to override rather than the entire stylsheet.

    #939789

    thanks a tonne john, really appreciate the help.

    #939830

    Stylesheets, in nearly every case, will use “relative” urls (relative to the location of the CSS file). Since your custom CSS is not stored in that original location, all the relative urls will not work. This is one of the reasons you want to put into the stylesheet, only the specific selectors, and only the specific declarations you are changing or adding. This also makes it much easier to keep track of what you have changed when you go back in to make changes later.

The topic ‘My buttons have dissapeard since editing my CSS’ is closed to new replies.