My comments aren’t appearing

  • Author
    Posts
  • #121335

    b0bbyg
    Member

    This is happening to me too, and it is marking my stuff as spam. I de-spammed the comment in question (it was on my own blog) but can anyone offer an explanation as to why Askimet seems to have got the idea into its head that so many users are spam?

    #121336

    neemfirst
    Member

    So what if it’s NOT Askimet?
    I tried to leave a comment on my blog today, and yesterday too from a different IP. After reading entries above, I checked the Askimet, and it read (0).
    Also, unlike the other entries above, my comments weren’t “accepted” before disappearing.
    After I enter my name & email info (as if I am Joe Schmo who landed on the blog) and comment, it gives me a screen that says that the commenter has to be logged in to leave a comment.
    I couldn’t find anything about that in the FAQ, perhaps b/c I’m an idiot. So, does a random person on the web who happens upon my blog, have to log in and set up an account in order to comment? The comment screen didn’t seem set up for that, so I’m a bit confused.
    Help Please. Thanks
    On the plus side, while logged in, I can comment w/o it going to spam. (Yeah!)

    #121337

    timethief
    Member

    The blog linked to your username is not a wordpress.com hosted blog.
    Are you referring to a wordpress.com hotsted blog?
    If so please post the url for that blog.

    #121338

    judyb12
    Member

    @neemfirst,

    what is the URL for your blog? Your username is linked to a site not hosted here, so i wonder if perhaps you are looking for help in the wrong place?

    Read Me First

    {wave at TT} simultaneous typing :)

    #121339

    neemfirst
    Member

    URL: http://neemfirst.wordpress.com/
    Maybe….I have a feedburner posting the info on my website, but I don’t think that would interfere.
    thanks for the comments

    #121340

    neemfirst
    Member

    I’m also in the process of having my website host re-direct the blog page on the site to the true blog here at wordpress.com. But I don’t think that would interfere, either.

    When I created the blog here at wordpress.com, I went thru the normal templates and options…I don’t know why…

    TT: What do you mean when you say my “username” is not a wordpress.com hosted blog? you mean “NeemFirst”? Wierd.

    #121341

    neemfirst
    Member

    ok…I’ll change the neemfirst username issue.

    #121342

    neemfirst
    Member

    So…under Profile and Personal Options, it asks for a Website URL. I figured I’m supposed to put my website URL…not my blog URL. Am I wrong? Or would this need to be changed elsewhere instead?
    thanks

    #121343

    The same happened to me some time ago but Askimet leaned quite fast…

    #121344

    @neemfirst

    Put your blog URL in the “website” field and update.

    #121345

    neemfirst
    Member

    @thesacredpath
    thanks…I made the change and it still produced the same results. I also changed some discussion options, and no change. I’ve put a support ticket in.

    #121346

    zhoutao
    Member

    My comments are neither in the spam queue, nor are they anywhere else. They just Disappear and it annoys me to find out that a whole essay length comment I typed perishes with a click and I can’t recover it.

    #121347

    b0bbyg
    Member

    Sigh… I am still apparently spam, despite no longer being considered spam on my own blog – when I try to leave comments on other people’s blogs, they don’t appear.

    #121348

    timethief
    Member

    Dashboard -> Comments -> Akismet Spam

    Go to your Akismet spam filter and open it. Then mark your comments “not spam”. After doing this several times Akismet will learn your comments are not spam. Get your friends to do the same with your comments on their blogs.

    Tip 1: Never ever mark a comment you do not agree with as spam just delete it if you do not wish to post it.

    Tip2: Either post a link to your blog when you post to the forum or link your username to your blog

    #121351

    b0bbyg
    Member

    Thanks.

    #121352

    timethief
    Member

    You’re welcome. Happy blogging. :)

    P.S. You linked your blog to your username – cool. And your blog looks cool too. :)

    #121353

    b0bbyg
    Member

    Thanks again!

    Especially for telling me how to link it in the first place! :)

    #121354

    timethief
    Member

    You’re most welcome. As you are new to wordpress, I believe the information at the links found in this Beginner’s Guide may be useful to you https://en.forums.wordpress.com/topic.php?id=11280
    Cheers :)

    #121355

    b0bbyg
    Member

    That’s awesome! Thanks!

The topic ‘My comments aren’t appearing’ is closed to new replies.