Need help? Check out our Support site, then

My Design Tools for custom colors won't load?

  1. Hello WordPress team!

    I'm having an issue wih tmy site. I just switched to your Newsworthy theme and i'm really loving it. Last week i uploaded a custom background and so far i like how my blog looks, but now i am unable to customize the colors. Every time i go to Appearance > Customize, it just says "Loading Design Tools..." on the right but a complete white space on the left. I thought of using another free theme and then go back to Newsworthy but the design tools still wouldn't load. It's weird because they load on Premium themes though.

    The things i have done so far are:
    > signed out, signed back in at WP
    > clear cache/cookies of my browser (Google Chrome)
    > used another browser (Firefox, IE)
    > used a different computer and a different ISP

    None of these things worked. What else can i do? All i want is to change the color of my blog title (Constantly Reinventing) and tagline ( to white. :-(

    Hoping you could help me out, thanks and more power!


    The blog I need help with is

  2. My customize tool has been bugging too. I posted 3 times on here. No response.

  3. @odeegulmatico
    Did you purchase a cusom design upgrade?

    No changes you try out aside from those such as Custom Background, Custom Header and Theme Options which are stated on the theme description pages for each theme will be visible to visitors unless you purchase an annually renewable custom design upgrade?

    When using the theme customizer please be sure you are using one of the browsers and versions found here and also be sure you have enabled third party cookies.

    NOTE: If you do not have a CSS upgrade then skip using the theme customizer. All of the very same functions can be accessed from your dashboard.
    Appearance > Header
    Appearance > Background
    Appearance > Theme Options (applicable only to some themes)
    Settings > Reading (set a static front page)
    Site Title and Tagline > Settings > General

  4. @timethief

    no, i didn't purchase any design upgrade. i don't think it's my browser since i've used three browsers (Chrome, Mozilla, IE) and three computers already. Yes, 3rd party cookies are already enabled. And i think you didn't read my post because i said all i want to do is change the Site Title and Tagline's color to white, and i can never do that on Appearance > Header/Background/Theme Options and all those things you said at the end.

  5. Sorry, you're wrong.
    a) You change the default title and tagline color in Appearance > Header.
    b) But you're not using the default title and tagline, you're using a header image instead:
    If you want to replace it with a new version, again you do this in Appearance > Header.

  6. hi @justpi sorry i forgot to update this thread. i wasn't using a header image when i posted in this forum. i just used one earlier today after getting pissed with the design tools. but before i did, i went to Appearance > Header and there's no option to change the tagline color, only the default title's. that's when i figured out i'll scrap it out and use a header image instead.

    problem resolved, although not really.

  7. The customizer has fewer options than the regular sections of the dashboard sidebar. The fact that changing the text color in Appearance > Header doesn't apply to the tagline is a quirk of the particular theme you're using - nothing to do with the customizer.

  8. i was able to change the color of both my site title <i>and</i> tagline in custom tools before, using the same theme Newsworthy. Now suddenly i am unable to do it, and also unable to do Live Preview on any free themes (still the same blank screen on the left and "Loading Design Tools" on the right)

  9. The customizer is working in my tests blog, and I can assure you that it has no option to change the tagline color in Newsworty (except if you have the Custom Design upgrade).

  10. Ok, I am having the same problem as odee. However, I am sure that I did, in fact, purchase the Custom Upgrade (the cheapest/next to default option). But I still can't get my preview to load; it just says on the right "Loading Design Tools..." AND, as advised by many other helpers, I've tried to just customize it in the Appearence>Custom Design as well as other routes. I can't even get to my CSS page (that I also paid for). Yet, it still won't let me change the color without actually getting to the Preview page or whatever. I've tried it on several different computers, I've tried other browsers, I've done the whole bit (disabled/enabled cookies, third parties, signed in/out, etc). I'm basically having the same problem as odee (and yes, I can change the header, but I still can't change the background color, txt color, or anything to do with color at all).

    Really, I just want to be able to adjust colors and themes while simultaneously looking at it, which is by the way, a very intermediate option. Seriously, this is pretty cheap of wordpress. I can't imagine this being anything more difficult than basic web design. Please, please help me fix or help my by ending wordpress altogether.


  11. Also, my blog (in its embarrassing beginning stages) is

  12. When using the theme customizer please be sure you are using one of the browsers and versions found here and also be sure you have enabled third party cookies.
    Exactly which browser (and version of it) are you using? Check here if necessary

  13. Ok, I am sure that I have the latest version of Safari (6.0.4) and I when I went to the cookies verification site, it told me that I did in fact have cookies enabled (the little green check mark). I still can't get the damn design tools to load. Wtf!? I don't even get this. It was working fine like a month ago. What a piece of shit. Please, someone offer some other form of advice before I totally lose it.


  14. @gabrielmgibson
    Thank your for telling us you are using Safari (6.0.4). I tagged this thread for Staff assistance. While you are waiting for their help, would you like to try some troubleshooting and maybe a different browser? I'm using Firefox 21 and I don't have this issue.

    If you are not running one of the browsers and versions listed at please try upgrading or switching first.

    Note: If you are using an IE9 browser in compatibility mode that makes it render as IE7 and IE7 is not supported. To disable see >

    If you are running one of the browsers and versions listed at please do these five things:

    1. Try clearing your browser’s cache:

    2. Make sure that you have third-party cookies enabled:

    3. Make sure JavaScript is enabled

    3. Try with all browser extensions or add-ons temporarily disabled.

    4. Try enabling HTTPS:

  15. This isn't a browser issue, it's a bug (that WP hasn't fixed).

  16. In the meantime you can use the old CSS editor:

  17. @timethief

    I did everything you told me to do. I'm with justpi: I'm pretty sure this is a bug. And I'm pretty sure timethief works for wordpress. Timethief, would you do me a favor and tell all the people who run wordpress that it's a piece of shit? Also, tell them to fix this fucking bug. Thank you so much.


  18. Gabe, your first "pretty sure" is correct, your second one isn't...

  19. Nevertheless, how does one get wordpress to fix this?

  20. thistimethisspace

    I tagged this thread for Staff support yesterday when I was logged in under my timethief username account.

  21. i'm quite convinced that this is a bug, too. and it just happened all of a sudden; i never encountered this issue before and i've been blogging with WP for years now. wish we could get it fixed ASAP for those who are also getting the same thing. i was able to have a work around by using a custom header, but still... ^^

  22. Nevertheless, how does one get wordpress to fix this?

    All it takes is three simple steps, Gabe:
    Step 1, WP takes heed.
    Step 2, WP gets interested.
    Step 3, WP finds out what's wrong.
    Problem is, we haven't managed step 1 yet: users have been complaining about this for months, but so far the few staff replies have been like TT's (blaming the browser).

  23. thistimethisspace

    I did not blame the browser. I simply posted the steps gabrielmgibson could take to eliminate the possibility of a browser related issue.

  24. WordPress sucks. How do I get my money back?


  25. @gabrielmgibson provides a 30-day refund on all upgrades except Domain Registrations, Domain Renewals, and Guided Transfers.
    Provided you are logged in under the same username account that purchased the upgrades, you can request a refund yourself directly from the Store section of your Dashboard
    If applicable also see

    Note: It takes from 1 - 2 weeks for the refund to be received.

  26. @gabrielmgibson: You do not have any content published on your homepage

    Also, you have selected a static page in your Settings -> Reading but did not actually choose and save what page you wanted to use for your homepage:

    Without any content on your homepage, the Customizer will not work. Try selecting your front page as indicated above, or choose "latest blog posts" in those settings while you configure your site and see if that helps.

    Let me know if you have any questions!

  27. @odeegulmatico: I tested on one of my blogs using the Newsworthy theme to see if I could replicate the behavior you're experiencing and I was unable to do so. However, on your blog, I get the same error.

    I'm going to have one of our developers take a closer look at this problem and see if we can figure out what is causing the Customizer to not load on your site. I'll respond once I have more information.

    In the meantime, let me know if you have any questions!

  28. Thanks for reporting this issue. I was also able to reproduce the problem and will need to get help looking into it (probably tomorrow at the soonest). But! I wanted to show you guys the super, super helpful screenshot sconnek included for us when she reported the issue:

    In that screenshot, you can see the error "Uncaught TypeError: Cannot read property 'name' of undefined" next to file name fonts-customizer-admin.js. This is just the kind of thing that makes tracking down bugs much easier, thanks @csonnek!

    @odeegulmatico, in the mean time, you should be able to do everything you can with the Customize screen in the other Appearance screens (like Header and Background) like justpi and timethief mentioned earlier in this thread.

  29. Thank you, thank you, thank you csonnek!!!! I put content on my page and was able to get the design tools. You see, I didn't know this because I changed my theme a bit ago and didn't add any content (I had all the content saved so I just wanted to work on colors, headers, etc). Oh my god, that was so easy, I'm super embarrassed I lost my temper over it. Anyway, thanks again to everyone for the help.


  30. @odeegulmatico, hi again! The issue you reported where the customize preview was blank for has been fixed.

    Note that you will need to click the "exit the preview" link at the top of the Appearance → Themes → Customize → Colors panel to see the Newsworthy theme's default color tools—the options should match what you find in Appearance → Background and Appearance → Header.

Topic Closed

This topic has been closed to new replies.

About this Topic