My facebook posts are appearing differently to how they were last week

  • Author
    Posts
  • #2391089

    snlatif
    Member

    Hello, I publicise to Facebook too. Previously my posts appeared with the custom message that I had written and then a link to the post with the image. Now, my custom message doesn’t appear – instead there is an excerpt from the blog post and the image. It looks really untidy and messy. I have screen grabs I can send of the before and after. I have reconnected Facebook in the hope it helps. How can I have my post publishing neatly as it had done before? Thanks.

    The blog I need help with is lipbalmandhandcream.com.

    #2391200

    Hi!

    We did recently make some adjustments to how Publicize works with Facebook. I’m taking a look at how the following post was Publicized:

    http://lipbalmandhandcream.com/2015/05/23/lipstick-queens-frog-prince-lipstick-morphs-from-an-emerald-green-to-a-rose-pink-in-under-a-minute-the-hotter-your-lips-the-bigger-the-transformation

    The custom message for that post is as follows:

    Lipstick Queen’s frog prince lipstick…morphs from an emerald green to a rose pink in under a minute. The hotter your lips, the bigger the transformation!

    That message is appearing at the top of the post as shown here:

    http://d.pr/i/16fgB

    The changes we’ve recently made will have the following effects:

    – Posts are displayed a bit differently depending on the type of post. Gallery posts, for example, are displayed differently than traditional post.

    – We’ll display the custom message at the top of the post. Beneath that, we’ll display an excerpt. If you don’t have a custom excerpt set, we’ll grab the first bit of the post.

    – We’ll display the full link of the post within the Facebook post.

    If you would like your posts to appear similar to how they did before, I would suggest the following:

    1. Only add a custom message if you have something to add like “Hey everyone! New post going up today!”

    2. For the manual excerpt, you could use something like you did with the custom excerpt below that explains what the post is about.

    Can you give that a try on your next post?

    #2391204

    snlatif
    Member

    Hi,

    I’ll add a manual excerpt and see how it displays on FB. I cannot remove the custom message completely because it is what displays when publishing to my other social networks.

    It would have been helpful to know of these changes as a regular blogger so I could have prepared for it :)

    Thanks
    Sofia

    #2391232

    Great Sofia! Let us know how it works out or if you need anything else.

    #2391248

    snlatif
    Member

    Hi

    I did as suggested, writing a manual excerpt but what ended up publishing to facebook was the custom message and the wrong image! I’ve had to delete the post as it is embarrassing. I’ve checked my other social networks and the correct image was published.

    It seems that whatever changes that were made to publishing to FB have not worked properly. Below is a link to what was published:

    https://plus.google.com/photos/104151268646308705731/albums/6152334399524185857?authkey=CJGm54rkhOjDwAE

    What can be done about resolving this?

    Additionally, I have reset my twitter connection twice now and nothing is publishing to it. What is the solution there?

    Thanks
    Sofia

    #2391250

    snlatif
    Member

    Hi, now my blog header image is not showing and I have tried it across 3 different web browsers. What is going on with wordpress? It’s not normally this glitchy.

    #2391256

    Hi, now my blog header image is not showing and I have tried it across 3 different web browsers. What is going on with wordpress?

    I suspect this is unrelated to the Publicize issues. The header image you appear to be using isn’t available in your Media Library. Here’s the image URL:

    http://lipbalmandhandcream.files.wordpress.com/2015/04/cropped-lipbalmandhandcreamheader2.jpg

    That’s coming up as a “File Not Found” on my side. Did you delete the file by chance?

    Please try reuploading a new header image via Appearance -> Customize -> Header.

    I did as suggested, writing a manual excerpt but what ended up publishing to facebook was the custom message and the wrong image! I’ve had to delete the post as it is embarrassing. I’ve checked my other social networks and the correct image was published.

    Can you let me know if the image it grabbed was in fact the old header image you had on your site?

    Additionally, I have reset my twitter connection twice now and nothing is publishing to it. What is the solution there?

    It looks like there was an error publishing to Twitter when the custom message exceeds 140 characters. I’m looking into why this is happening! Ideally, it should just truncate the message when publishing to Twitter.

    #2391257

    Hi!

    One more update on the Facebook Publicize connection, now if you set a custom message for the post, we’ll display that instead of the excerpt. Previously, you noticed both on your post.

    If a custom message is set, you’ll no longer see the excerpt along with the post. You’ll just see the custom message and a link.

    If a custom message is not set, you’ll see the excerpt and then a link.

    #2391258

    snlatif
    Member

    Hi

    No idea why the header image has disappeared. I hadn’t touched it. But thanks for figuring it out, I will know what to do if it happens again. I’ve uploaded a new header image :)

    With the FB post that I sent you a link to, no that is an image from a post published on Fri May 22nd, 2015.

    OK about Twitter, I will shorten my custom message but hope this issue gets resolved.

    Thanks
    Sofia

    #2391280

    With the FB post that I sent you a link to, no that is an image from a post published on Fri May 22nd, 2015.

    Understood. I was wondering if it was set as your header image or affiliated with your site in some other way when you published the post (on your sidebar, for example). Facebook tries to grab the best image for a particular post. If the featured image is too small, for example, Facebook will do its best to grab another, larger image. This doesn’t appear to be the issue for this particular post so I’m not really sure what happened. If Publicize fails to grab the correct image for your next post, please let me know!

    OK about Twitter, I will shorten my custom message but hope this issue gets resolved.

    We’re working on it! I’ll update you as soon as I know more.

    #2391286

    snlatif
    Member

    Thanks.

    My next FB post published fine, using the custom message and not the manual excerpt, and the correct image. I’ll keep a close eye on it to see if it changes.

    #2391301

    Awesome! We appreciate it.

    #2391346

    snlatif
    Member

    Hi

    This morning’s post (link below) grabbed an image from my instagram feed instead of the featured image which shouldn’t be too small as it is 2940 × 1960. It has published fine to all my other social channels. I’ve had to delete that FB post and repost manually.

    https://goo.gl/photos/fsGYxVbgYBbQnPi69

    Everything else was fine – custom message and link itself – but the image. The post was created correctly in wordpress so not sure what happened there.

    I’m a bit worried that this is going to keep happening and my followers are going to think I’ve gone a bit nuts. Not good for my brand image. If this happens again I’m going to have to post to Facebook manually aren’t I?

    Thanks
    Sofia

    Thanks
    Sofia

    #2391353

    Hi Sofia,

    Thanks for the report! This is really weird because Facebook is actually seeing the correct image. For example, you can run the post through the Facebook debugger here:

    https://developers.facebook.com/tools/debug/og/object/

    Just enter the URL of the post and hit “Fetch New Scrap Information.” The preview has the correct image as shown in this screenshot:

    http://d.pr/i/13Qce

    Was this post scheduled by chance or posted immediately?

    #2391354

    snlatif
    Member

    Hi

    It is all very strange! When I manually re-posted earlier after deleting the old post, it pulled through the correct image, which is what is live now on Facebook.

    The post had been scheduled to publish.

    Thanks
    Sofia

    #2391356

    Thanks Sofia! I think this issue could only be with scheduled posts. I realize this is frustrating to have to delete and repost your Facebook post. We’re definitely working on this. If you could let me know if this happens again and whether or not the post was scheduled, that would be very helpful!

    #2391360

    snlatif
    Member

    Hi Jeremy, so far so good. This morning’s scheduled post has published to Facebook with no problems at all. Fingers crossed this continues. Thanks, Sofia

    #2391363

    Excellent Sofia!

    #2391365

    snlatif
    Member

    Hi Jeremy

    It happened again this morning. Link below. It pulled the same image from instagram that it did for the post from Friday. Featured image was 3128 × 2346. Reposted and it has pulled the correct image. Clearly a problem with scheduled posts.

    https://goo.gl/photos/MHJi6N1jbY3cXuep6

    I look like I don’t know what I am doing to my readers. so I am deleting the connection between WP and FB, and will post manually from now on. I can’t risk it being published incorrectly again.

    Are others having the same issue? Will you let me know once it has been resolved?

    Thanks
    Sofia

    #2391366

    Thanks Sofia! I appreciate your follow-up here. This does appear like it may be an issue with scheduled posts. We haven’t had many other reports of this issue, but we’re still looking into why this might be occurring. I’ll let you know as soon as this is fixed!

The topic ‘My facebook posts are appearing differently to how they were last week’ is closed to new replies.