My load media button does not work when I have a new post.

  • Author
  • #1949487

    I can not load media into a post via load media button. I also am able to load pictures into my media library but I can not than get them into the post.

    The blog I need help with is



    Are you using the New Post button here ? It was having issues but according to staff it’s supposed to be fixed now, so please let us know if that’s the case.

    Meanwhile you can try the post editor in the main dashboard. Go to your blog’s main dashboard and create a new post by clicking on Posts ->Add New in the sidebar menu. You’ll find creating posts this way is much more stable and provides many more options for making it look exactly like you want. Existing posts you can edit by going to Posts ->All Posts and clicking the Edit link under the post title.

    See here to insert images using the Add Media button in the post editor:

    Additionally, try clearing your browser cache and cookies and make sure you have third-party cookies enabled. You can also check whether you have the same problem on a different browser and make sure your flash player is updated.


    I am so frustrated. The problem I am having is with in my computer, as I was able to utilize the media button on another computer…. I installed Google Chrome no effect. I typically use the post button from the dashboard. I can bring up a new post but I can not utilize the upload media button. I can add media to my library but is there a way i can add it to a new post?



    I’ve tagged this for staff to follow up. Please be patient while waiting for them to respond.



    Hi there,

    Sorry about the trouble you experienced. Can you take a look at these instructions for uploading and inserting images into your posts?

    Which step in the instructions are you stuck in? What happens when you click on the “Insert into Post” button?

    A corrupted browser cache may also be the culprit here. Can you kindly clear your browser cache and see if that helps?

    Looking forward to your reply. Thanks!


    I am stuck on the second step add media. Which I thought was clear, when I wrote I can not use the add media button… I can add files to my media library still can not get them in the post…Is there somebody from WordPress who can look at this issue? I get the help eachother out aspect, but I am paying a fee to WordPress. I would like to here from the company if they can help or do I have to shut down the blog I have had since 2012?



    Hey there!

    Let me apologize for the trouble you’re experiencing.

    I’m a Staff member and I’m here to help as much as I can.

    Did you try to see if clearing your browser cache helped?

    Enabling HTTPS when visiting admin pages may do some good as well. This can be done by visiting Users -> Personal Settings in your blog dashboard:

    For more info on HTTPS, click here:

    Let me know if any of my suggestions helped. Thanks for your patience!


    I have enabled https and cleared my cache still no luck. It is only the media button that does not work, the add a poll and other button works…


    Just for my own curiosity really, are you able to get the Add Media to load if you try to post from this link?




    And it does not work from here either?

    When you are on that page I just linked have you tried a force refresh?

    Can you let us know what operating system, browser and version you are using.
    You can find out at this website



    Chrome 36 on Windows 7. It says Java is enable , but not detected?


    I don’t believe java should interfere with this.
    Have you tried the force refresh as mentioned above yet?


    Yes, I am sorry I did the force refresh and nothing..


    Thanks for the information. I know you just installed Chrome what browser did you use before that Internet Explorer?

    Could you try starting Internet Explorer with no add-ons then logging in and seeing if that works.

    To start Internet Explorer with no add-ons you can go to the start button search for Internet Explorer and one of the options will have No Add-ons listed beside it.


    Still nothing…


    I’m personally out of ideas.
    It works on the other computer you tried but not in either browser you’ve tried on this computer.
    I would say there is some setting or program on that computer that is causing you the issues.
    Take another look at especially the more troubleshooting section.

    I’ll tag staff again to see if they have any other advice.



    Hi there,

    I’m sorry to hear that this continues to be a problem. Sandy may be correcting in saying that a security program installed on your computer might be the culprit. Can you please try disabling any anti-virus, security or adblocking software temporarily and see if that helps? Please let us know what happens. After your tests, please remember to turn the programs back on. Thanks!


    I have followed every instruction you suggested. I also swept my computer for viruses. I got rid uninstalled an reinstalled my Norton protection. I don’t know what happened. I had my blog for 2 years and it makes me sad that I have to shut it down. I would now like to know how I can get my refund.



    Hi there,

    I had my blog for 2 years and it makes me sad that I have to shut it down. I would now like to know how I can get my refund.

    Sorry to hear that. Yes, I would be glad to offer you a refund.

    Before anything, are you experiencing the same problem in your other blogs as well? Or is it in just your “” blog? We may be able to sort this out by creating a new blog and transferring over your content. Let me know if that interests you. Thank you!

The topic ‘My load media button does not work when I have a new post.’ is closed to new replies.