My photos aren't uploading into posts. How do I fix this?

  • Author
  • #1416571


    Images I take from the Internet can upload to a post just fine, but any new photos I try to upload from my desktop do not upload. The only one I used that was mine I was able to add from a URL because I had posted it to Instagram.

    Sometimes it appears my photos have uploaded all the way, or part of the way, but nothing shows up. After a number of minutes (maybe about 10 mins), it says there was an error and I should try again later.

    I have tried the following, and it still doesn’t work:
    – Restarting my computer
    – Using Firefox and Chrome
    – Clearing my browser cache
    – Deleting wp-admin and wp-includes from the server and re-uploaded the latest WordPress file
    – Compressing the jpegs and uploading those smaller file sizes

    Is there a simple way to fix this? I am not experienced enough, technically, to dig through my computer for an answer on my own.

    The blog I need help with is



    Please let us know:
    (a) Exactly what kind of device you are using to connect to the internet and to
    (b) Exactly which browser (and version of it) you’re using by checking here if necessary
    (c) And what any error reports you receive state.

    I’ll tag this thread for Staff assistance. Please subscribe to the thread so you are notified when they respond and please be patient while waiting.



    Please follow timethief’s steps so we can help you better.

    Thank you.



    Hi, thanks for your patience.

    I am using a Samsung laptop. Firefox 23 mainly (I’ve also used Chrome 29 – both have this problem).

    The error message is all in red and says this:
    Error [image file name here] An error occurred in the upload. Please try again later.



    Do you also encounter this issue on a different Internet connection?



    I’ve only tried on the connection I have at home, but uploading photos did previously work for me when I used the last version of WordPress for a different blog that I no longer run.



    Just to confirm, is this issue happening on ?

    You can read more about the different media uploaders at



    That is correct.



    Could you please try both the multi-file and browser uploader and let me know which one isn’t working for you:



    The multi-file uploader is the one I’ve tried to use that isn’t working. The browser uploader isn’t showing up anywhere as an option for me.

    This is everything that shows up when I click “Add Media” in a new post:

    Drop files anywhere to upload
    Select Files

    Allowed file types: jpg, jpeg, png, gif, pdf, doc, ppt, odt, pptx, docx, pps, ppsx, xls, xlsx, key.

    Maximum upload file size: 1GB.

    186.6 kB used, 3.0 GB (100.0%) upload space remaining. You can upload mp3, m4a, wav, ogg audio files and increase your available space with a Space Upgrade. You can upload videos and embed them directly on your blog with a Video Upgrade.



    Are you trying to drop files into the browser or are you use the ‘Select Files’ option? also, what kind of file type does your image have?

    The Browser uploader can be found right below the drag-and-drop box:

The topic ‘My photos aren't uploading into posts. How do I fix this?’ is closed to new replies.