My post is deleting when I hit "save" or "publish"

  • Author
  • #617073

    I just wrote a post and hit publish. However, as soon as I hit “publish” my entire blog post disappeared and I apparently published a blank page. I was able to get back to my content and then tried a simple “save.” Same result: my entire entry disappeared again.

    I have since tried several times to “Update” or to “Save” on both Firefox and Safari and each and every time it deletes out my post. I looked for help on the support forums but was sent here.

    What can I do to post again?
    Blog url:



    Is “GO IRISH!” the post that you’re referring to?

    If so, your “20 May, 2011 @ 10:26” revision appears to be in tact.

    When editing the post, scroll down to the Revisions section and click on this one. You’ll see the revision in its entirety. Scroll down again, and click the “Restore” link in the row for the “20 May, 2011 @ 10:26” revision.


    The 10:26 revision is only a draft from this morning – does not contain any of my pictures or all of my text.



    Unfortunately, that’s all that appears to be available. We may be able to find something, but that’s going to require a bit more digging.

    Please contact us again via and file a private request (if the option presents itself).


    Oh, and each of those blank revisions are where I’ve tried copying and pasting my post again and saving/publishing it again, all for naught as you can see.


    Okay, I just tried starting an entirely new post and hit “save” again, and it once again just blanked out and deleted again. So it doesn’t seem to be isolated to this post alone.


    blah — it saved when I used just text. I guess I’ll play around a bit here and see if it’s adding the pictures that’s making go awry or what.


    Sorry for the billion updates. Just figured out it was one of my links making it delete. I still don’t know *why* a link would delete my whole post, but I deleted that link and everything else was able to be saved.

    Thanks. Matter resolved.



    Yay! I’m glad it’s fixed now.

    Would you mind sharing the link with us, so we can look into the matter?


    Sure — I tried posting this:

    I borrowed the picture and linked to that webpage. As soon as I deleted the whole thing, I was able to save again without deleting everything. I found that she had an actual button to copy the html from and that did work properly and is on my blog post. I obviously did something wrong, but would have just expected the picture to not work instead of deleting everything.

    (and sorry for the slow reply — left as soon as I figured out the problem.)



    Thanks for sharing that!

    That is definitely odd, but we’ll look into it and see if we can prevent it from happening again.

The topic ‘My post is deleting when I hit "save" or "publish"’ is closed to new replies.