my readers can’t leave comments but the settings are ok

  • Author
    Posts
  • #345036

    machetera
    Member

    A reader just wrote to me asking how to leave a comment, and the comment box seems to have disappeared from beneath the posts. Which might explain the lack of comments lately. I checked the settings/discussion and the box is checked to allow comments, so what is the problem?

    The blog I need help with is machetera.wordpress.com.

    #345197

    justjennifer
    Moderator

    A link to your WordPress.COM blog might be in order, starting with http://

    #345200

    machetera
    Member

    sorry, I thought that came through automatically when I posted my question.

    It is: http://machetera.wordpress.com

    #345202

    justjennifer
    Moderator

    Under “Settings>Discussion” is there anything under the “Automatically close comments on articles older than X days”?

    #345205

    Also check the “Allow Comments” option in the Discussion module of the post editor: it overrides the general setting.

    #345210

    machetera
    Member

    Okay, the override suggested by panaghiotisadam seems to have worked. Now I guess I just have to pull up posts individually to fix the problem. Thanks.

    justjennifer, there is nothing checked on the “automatically close comments on articles older than x days”

    #345284

    justjennifer
    Moderator

    True, but pan’s suggestion also implies that you’ve clicked each post to disallow comments on that post.

    If you haven’t done this, and as your first post suggests this was a recent change, I would recommend contacting Support directly with the problem. http://support.wordpress.com/contact/

    #345285

    @jennifer: It also implies the reverse, i.e. that maybe the allow option in the Settings wasn’t checked till very recently. (If I remember well, changing that setting will only affect new posts, not posts already published under a don’t-allow-comments status.)

The topic ‘my readers can’t leave comments but the settings are ok’ is closed to new replies.