Need help? Check out our Support site, then

My Username Doesn't Link to My Primary Blog

  1. My primary blog is set to, but when I click on my username after I've left a comment on another blog, it links back to, an old blog I haven't updated or made postings on. How can I get my username to link back to my primary blog?

    The blog I need help with is

  2. That sounds like a cache issue.

    Can you please try clearing your browser cache and cookies and then log back in and see if the links to go away?

  3. I have a similar issue.
    I created "readolivia" 1st, then "oliviasbiopiclog". Even though that I have checked the 2nd Blog as my Primary; any where I comment, the readers are directed to "readolivia"

    Is there a resolution to this?

  4. Here, in forum, it shows my username as ReadOlivia, otherwise, I go by OLIVIA (to display) and yet it connects to "readolivia"

  5. You can change the blog linked to your username here > Dashboard -> Users -> Personal Settings -> then scroll down to 'Account Details'. In the spot where it says 'website' fill in the URL of your selected blog and save the changes. Do note that switching back and forth will requires you changing the URL each time you choose to change your username link.


    Here's the link.
    @ jamesxavis: Also, more often than not Forum already may have a posted resolution, answered in an earlier question. Please search through intensively before popping up a query.

Topic Closed

This topic has been closed to new replies.

About this Topic