my Vigilance css and ie6,7

  • Author
    Posts
  • #490984

    spocrep
    Member

    ok I’m really sorry, take your time…

    #490986

    devblog
    Member

    it’s so strange that when I preview it in IE7 on my test blog, the menu displays just right….

    #490988

    spocrep
    Member

    you know it could be (IE tester) I’m using, it’s not accurate maybe!

    #490989

    devblog
    Member

    No, there’s soemthing else going on that I think I need to go like by line to debug this. When I load your blog, the menus are not visible.

    Would you tell me if you have any special options set for your theme? I need to replicate as much as possible the look of your blog to give you a better solution.

    #490990

    devblog
    Member

    I’ve looked your CSS in more detail and it needs code clean up. If you don’t mind waiting, I can start to tackle this tomorrow. I’ll do the best I can to fix this.

    #490992

    devblog
    Member

    damn it, I’m exhausted….

    this should read: “I’ve looked through your CSS…”

    #490994

    spocrep
    Member

    my theme options are all about the colors and the alert box, maybe just the language from general settings (ar – العربية), and the css changes I did

    #490995

    spocrep
    Member

    yes, sure tomorrow would be great I have work to do after a few hours, thank you so much

    #490997

    devblog
    Member

    Don’t mention it.

    I managed to replicate the menu problem in IE7, I’ll keep at it for a while tonight. If I get to fix it tonight, I won’t wait till tomorrow to post something.

    #490998

    devblog
    Member

    OK, remove ONLY this from your CSS


    #header > #nav {float: right;}
    `

    That fixed the menu in IE7. Since we’re absolute positioning it, the menu should be visible now. If this still doesn’t work. I’ll continue tomorrow when I’m more fresh.

    #491002

    spocrep
    Member

    it still doesn’t work, I think I’ve made a lot mess with my css!

    #491017

    devblog
    Member

    Okay man, this has to fix it. I don’t have IE 7 here, but it displayed well in IE 6.

    Replace your “#nav” selector with this:

    #nav {
    font-size:20px;
    font-family:Tahoma, "Times New Roman",Arial, Serif ,Sans-serif,Monospace;
    height: 33px;
    margin: 20px 0 0;
    width: 100%;
    }

    Lemme know.

    #491019

    spocrep
    Member

    you’re a Genius, I don’t believe this I think I’m gonna cry, It did fix it (image IE7)
    , this is a changing point for my blog, I’ve been dealing with people complaining about the look of it for over months and months, thank you so much, you have no idea how much you saved my life :P I can’t thank you enough :)
    give me your twitter account please so I can thank you and tell my followers about what you did for me :)

    #491020

    spocrep
    Member

    sorry, thats not the right image this one is: (image IE7)
    I’m too excited lol

    #491021

    devblog
    Member

    Please think nothing of it; I’m happy to be of assistance.

    Thank you, but since I don’t like twitter, I don’t have an account… :P

    Happy bloggin’!

The topic ‘my Vigilance css and ie6,7’ is closed to new replies.